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DIGITAL DOCUMENTATION (ADVANCED) 
 

OBJECTIVE QUESTIONS (SET 01) 
 
1. What is the shortcut key to align selected text to the right in Microsoft Word? 
a. Ctrl + L 
b. Ctrl + E 
c. Ctrl + R 
d. Ctrl + J 
Ans: c. Ctrl + R 
 
2. Which of the following is NOT a type of font style in digital documents? 
a. Bold 
b. Italic 
c. Regular 
d. Outline 
Ans: d. Outline 
 
3. What is the shortcut key to increase the indent of selected text in OpenOffice Writer? 
a. Ctrl + [ 
b. Ctrl + ] 
c. Ctrl + { 
d. Ctrl + } 
Ans: b. Ctrl + ] 
 
4. Which of the following is a type of tab stop in digital documents? 
a. Left-aligned 
b. Center-aligned 
c. Right-aligned 
d. All of the above 
Ans: d. All of the above 
 
5. What is the shortcut key to copy selected text in a digital document? 
a. Ctrl + X 
b. Ctrl + C 
c. Ctrl + V 
d. Ctrl + Z 
Ans: b. Ctrl + C 
 
6. What is Mail Merge in Digital Documents? 
a. A way to send an email with an attachment 
b. A process to combine a document with a database to create personalized copies 
c. A feature to create a table of contents 
d. A tool to add hyperlinks to a document 
Ans: b. A process to combine a document with a database to create personalized copies 
 
7. Which of the following is NOT a step in Mail Merge? 
a. Create a database 
b. Create a form letter 
c. Create a table of contents 
d. Connect to the database 
Ans: c. Create a table of contents 
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8. Which of the following is a type of database used in Mail Merge? 
a. Microsoft Excel 
b. Microsoft PowerPoint 
c. Microsoft Word 
d. Microsoft Access 
Ans: a. Microsoft Excel 
 
9. What is the purpose of a form letter in Mail Merge? 
a. To connect to the database 
b. To create a table of contents 
c. To create a personalized letter 
d. To create a hyperlink 
Ans: c. To create a personalized letter 
 
10. Which of the following is NOT a type of Mail Merge document? 
a. Envelopes 
b. Labels 
c. Emails 
d. Tables 
Ans: d. Tables 
 
11. Which of the following is a Mail Merge field? 
a. <<Address>> 
b. Address 
c. {Address} 
d. [Address]  
Ans: a. <<Address>> 
 
12. What is the purpose of a data source in Mail Merge? 
a. To create a form letter 
b. To connect to the database 
c. To create a table of contents 
d. To add a hyperlink 
Ans: b. To connect to the database 
 
13. What is the shortcut key to preview the Mail Merge document in Microsoft Word? 
a. Alt + P 
b. Alt + F 
c. Alt + V 
d. Alt + M 
Ans: a. Alt + P 
 
14. Which of the following is NOT a step to complete a Mail Merge in Microsoft Word? 
a. Edit the merged document 
b. Preview the merged document 
c. Save the merged document 
d. Print the merged document 
Ans: c. Save the merged document 
 
15. Which of the following is a Mail Merge option in Microsoft Word? 
a. Merge and Split 
b. Merge and Protect 
c. Merge and Format 
d. Merge and Center 
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Ans: d. Merge and Center 
 
16. Which of the following types of data can be used in a Mail Merge? 
a. Text only 
b. Numbers only 
c. Text and numbers 
d. Images only 
Ans: c. Text and numbers 
 
17. Which of the following is NOT a type of Mail Merge in Microsoft Word? 
a. Directory 
b. Email 
c. Form 
d. Presentation 
Ans: d. Presentation 
 
18. Which of the following is an example of a salutation field in Mail Merge? 
a. <<First Name>> 
b. <<Last Name>> 
c. <<Title>> 
d. <<Email Address>> 
Ans: c. <<Title>> 
 
19. What is the purpose of a Mail Merge wizard in Microsoft Word? 
a. To format the merged document 
b. To create the data source 
c. To guide you through the steps of Mail Merge 
d. To preview the merged document 
Ans: c. To guide you through the steps of Mail Merge 
 
20. Which of the following is a benefit of using Mail Merge in Digital Documents? 
a. Saves time and effort 
b. Increases document size 
c. Requires advanced technical knowledge 
d. Decreases document quality 
Ans: a. Saves time and effort 
 
21. Which of the following is a Mail Merge option in Microsoft Word that allows you to send emails 
directly from Word? 
a. Merge and Split 
b. Merge and Protect 
c. Merge and Format 
d. Merge and Email 
Ans: d. Merge and Email 
 
22. Which of the following is a way to customize a Mail Merge document? 
a. Change the font size of the data source 
b. Change the color of the merge field 
c. Change the page orientation of the merged document 
d. Change the filename of the data source 
Ans: b. Change the color of the merge field 
 
23. Which of the following is a Mail Merge option in Microsoft Word that allows you to choose 
which records to merge? 
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a. Filter 
b. Find 
c. Replace 
d. Sort 
Ans: a. Filter 
 
24. Which of the following is a way to edit a Mail Merge document after it has been merged? 
a. Edit the original data source 
b. Edit the merged document directly 
c. Edit the Mail Merge fields 
d. Edit the font of the merged document 
Ans: b. Edit the merged document directly 
 
25. Which of the following is a way to insert a Mail Merge field in Microsoft Word? 
a. Insert > Field 
b. Insert > Picture 
c. Insert > Hyperlink 
d. Insert > Table 
Ans: a. Insert > Field 
 
26. What is a Table of Contents? 
a. A summary of a book 
b. An index of a book 
c. A list of the chapters or sections of a book or document 
d. A glossary of terms 
Ans: c. A list of the chapters or sections of a book or document 
 
27. Which of the following is an advantage of using a Table of Contents in a document? 
a. It makes the document more visually appealing 
b. It provides an easy way to navigate the document 
c. It helps to shorten the length of the document 
d. It provides a summary of the document 
Ans: b. It provides an easy way to navigate the document 
 
28. In which tab of the ribbon in OpenOffice Writer can you find the option to insert a Table of 
Contents? 
a. Home 
b. Insert 
c. Page Layout 
d. References 
Ans: d. References 
 
29. How is a Table of Contents created in OpenOffice Writer? 
a. Manually typing the headings and page numbers 
b. Automatically generating it using the headings in the document 
c. Copy-pasting the headings and page numbers from another document 
d. None of the above 
Ans: b. Automatically generating it using the headings in the document 
 
30. What is the purpose of updating a Table of Contents in a document? 
a. To correct any errors in the page numbers 
b. To add or remove headings from the document 
c. To change the formatting of the Table of Contents 
d. All of the above 
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Ans: d. All of the above 
 
31. What happens when you select a Table of Contents in OpenOffice Writer and press F9? 
a. The Table of Contents is deleted 
b. The Table of Contents is updated 
c. The Table of Contents is highlighted 
d. None of the above 
Ans: b. The Table of Contents is updated 
 
32. Which of the following formats can a Table of Contents be saved in? 
a. PDF 
b. DOCX 
c. ODT 
d. All of the above 
Ans: d. All of the above 
 
33. What is the purpose of the Level setting in a Table of Contents? 
a. To change the font size of the headings 
b. To specify the heading levels that should be included in the Table of Contents 
c. To change the color of the headings 
d. None of the above 
Ans: b. To specify the heading levels that should be included in the Table of Contents 
 
34. How can you customize the formatting of a Table of Contents in OpenOffice Writer? 
a. By using the Table of Contents dialog box 
b. By using the Page Layout tab of the ribbon 
c. By manually formatting each entry in the Table of Contents 
d. None of the above 
Ans: a. By using the Table of Contents dialog box 
 
35. What is the purpose of the “Protect Against Manual Changes” option in the Table of Contents 
dialog box? 
a. To prevent the Table of Contents from being edited manually 
b. To prevent the headings in the document from being edited 
c. To prevent the page numbers from being edited 
d. None of the above 
Ans: a. To prevent the Table of Contents from being edited manually 
 
36. How can you remove a Table of Contents from a document in OpenOffice Writer? 
a. By selecting the Table of Contents and pressing the Delete key 
b. By selecting the Table of Contents and choosing the Delete option from the context menu 
c. By deselecting the Table of Contents option in the Table of Contents dialog box 
d. None of the above 
Ans: a. By selecting the Table of Contents and pressing the Delete key 
 
37. Which option in the table of contents menu in OpenOffice Writer allows you to customize the 
appearance of the table of contents? 
a. Structure 
b. Entries 
c. Styles 
d. Preview 
Ans: c. Styles 
 
38. In Microsoft Word, what is the keyboard shortcut to update the table of contents? 
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a. Ctrl + U 
b. Ctrl + Shift + U 
c. Ctrl + Shift + F9 
d. Ctrl + Alt + F9 
Ans: d. Ctrl + Alt + F9 
 
39. In OpenOffice Writer, what is the purpose of the “Outline Level” option under the Entries tab in 
the table of contents menu? 
a. To specify which headings should be included in the table of contents 
b. To define the formatting of the entries in the table of contents 
c. To group similar entries together in the table of contents 
d. To set the indentation level of each entry in the table of contents 
Ans: a. To specify which headings should be included in the table of contents 
 
40. Which of the following is a benefit of using a table of contents in a digital document? 
a. It makes the document look more visually appealing 
b. It helps the reader navigate the document more easily 
c. It saves paper when printing the document 
d. It increases the word count of the document 
Ans: b. It helps the reader navigate the document more easily 
 
41. What is the purpose of the “From template” option in the table of contents menu in OpenOffice 
Writer? 
a. To apply a pre-existing style to the table of contents 
b. To create a new style for the table of contents 
c. To import a table of contents from another document 
d. To customize the structure of the table of contents 
Ans: a. To apply a pre-existing style to the table of contents 
 
42. Which of the following is not a recommended practice when creating a table of contents in a 
digital document? 
a. Using automatic numbering for headings 
b. Including every heading in the document in the table of contents 
c. Updating the table of contents before printing or sharing the document 
d. Using a consistent style for all headings in the document 
Ans: b. Including every heading in the document in the table of contents 
 
43. In Microsoft Word, which option in the table of contents menu allows you to change the font and 
size of the table of contents entries? 
a. Show Levels 
b. Formats 
c. Styles 
d. Options 
Ans: b. Formats 
 
44. In OpenOffice Writer, which option in the table of contents menu allows you to add or remove 
hyperlinks from the table of contents entries? 
a. Entries 
b. Structure 
c. Styles 
d. Preview 
Ans: a. Entries 
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45. What is the purpose of the “Update page numbers only” option in the table of contents menu in 
Microsoft Word? 
a. To update the page numbers in the table of contents without changing the formatting 
b. To update the formatting of the table of contents without changing the page numbers 
c. To add or remove entries from the table of contents without affecting the page numbers 
d. To create a new table of contents with updated page numbers and formatting 
Ans: a. To update the page numbers in the table of contents without changing the formatting 
 
46. Which of the following is true about a Table of Contents in a digital document? 
a. It is used to list all the tables in the document. 
b. It is used to list all the figures in the document. 
c. It is used to list all the headings and subheadings in the document. 
d. It is used to list all the footnotes in the document. 
Ans: c. It is used to list all the headings and subheadings in the document. 
 
47. What is the purpose of a Table of Contents in a digital document? 
a. To provide a list of all the tables in the document. 
b. To provide a list of all the figures in the document. 
c. To provide a list of all the headings and subheadings in the document. 
d. To provide a list of all the footnotes in the document. 
Ans: c. To provide a list of all the headings and subheadings in the document. 
 
48. Which of the following is a benefit of using a Table of Contents in a digital document? 
a. It makes the document more visually appealing. 
b. It allows the reader to quickly locate specific sections of the document. 
c. It increases the length of the document. 
d. It improves the grammar and spelling in the document. 
Ans: b. It allows the reader to quickly locate specific sections of the document. 
 
49. How is a Table of Contents created in a digital document? 
a. It is automatically generated based on the headings and subheadings in the document. 
b. It is manually created by the author of the document. 
c. It is automatically generated based on the figures in the document. 
d. It is automatically generated based on the footnotes in the document. 
Ans: a. It is automatically generated based on the headings and subheadings in the document. 
 
50. Which of the following is a common feature of a Table of Contents in a digital document? 
a. Each section is numbered and corresponds to a page number. 
b. Each section is highlighted with a different color. 
c. Each section contains a footnote. 
d. Each section is accompanied by a photograph. 
Ans: a. Each section is numbered and corresponds to a page number. 
 
51. What is the purpose of adding hyperlinks to a Table of Contents in a digital document? 
a. To make the document more visually appealing. 
b. To allow the reader to navigate directly to a specific section of the document. 
c. To increase the length of the document. 
d. To improve the grammar and spelling in the document. 
Ans: b. To allow the reader to navigate directly to a specific section of the document. 
 
52. Which of the following is a disadvantage of using a Table of Contents in a digital document? 
a. It can make the document more difficult to navigate. 
b. It can make the document more visually unappealing. 
c. It can decrease the length of the document. 
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d. It can decrease the readability of the document. 
Ans: a. It can make the document more difficult to navigate. 
 
53. What is the difference between a Table of Contents and an Index in a digital document? 
a. A Table of Contents is used to list all the tables in the document, while an Index is used to list all 
the headings and subheadings in the document. 
b. A Table of Contents is used to list all the figures in the document, while an Index is used to list all 
the footnotes in the document. 
c. A Table of Contents is used to list all the headings and subheadings in the document, while an 
Index is used to list all the tables and figures in the document. 
d. A Table of Contents and an Index are the same thing. 
Ans: c. A Table of Contents is used 
 
54. What is a template in digital document? 
a. A pre-designed document with placeholders for text, graphics, and other elements 
b. A type of font used in digital documents 
c. A tool to organize a digital document 
d. A way to convert digital documents into other file formats 
Ans: a. A pre-designed document with placeholders for text, graphics, and other elements 
 
55. Which of the following is NOT an advantage of using templates in digital documents? 
a. Saves time and effort in document creation 
b. Ensures consistency and branding across documents 
c. Helps to organize and structure information effectively 
d. Limits creativity and flexibility in document design 
Ans: d. Limits creativity and flexibility in document design 
 
56. Which of the following software programs offers a variety of templates for digital documents? 
a. Adobe Photoshop 
b. Microsoft Excel 
c. Google Docs 
d. All of the above 
Ans: c. Google Docs 
 
57. Which of the following is NOT a type of template available for digital documents? 
a. Business card template 
b. Resume template 
c. Newsletter template 
d. Spreadsheet template 
Ans: d. Spreadsheet template 
 
58. Which of the following is NOT a step in using a template for a digital document? 
a. Customizing the template with personal information and details 
b. Saving the customized template as a new document 
c. Printing the template for distribution 
d. Uploading the customized template to a cloud storage service 
Ans: c. Printing the template for distribution 
 
59. Which of the following is an example of a digital document template? 
a. A blank sheet of paper 
b. A resume with pre-defined sections for work experience and education 
c. A list of bullet points 
d. A spreadsheet with formulas for calculations 
Ans: b. A resume with pre-defined sections for work experience and education 
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60. Templates in digital documents are typically created by: 
a. Professional designers 
b. Software developers 
c. End-users 
d. None of the above 
Ans: a. Professional designers 
 
65. Which of the following is an advantage of creating custom templates for digital documents? 
a. Ensures consistency and branding across documents 
b. Saves time and effort in document creation 
c. Increases creativity and flexibility in document design 
d. All of the above 
Ans: d. All of the above 
 
66. Which of the following is a benefit of using templates in digital documents for businesses? 
a. Reduces the need for professional graphic designers 
b. Helps to maintain a consistent brand image 
c. Increases creativity and flexibility in document design 
d. None of the above 
Ans: b. Helps to maintain a consistent brand image 
 
67. Which of the following is NOT a type of template available in Microsoft Word? 
a. Newsletter template 
b. Invoice template 
c. Resume template 
d. Database template 
Ans: d. Database template 
 
68. Which of the following is NOT an advantage of using templates for digital documents in 
education? 
a. Saves time and effort in creating lesson plans and assignments 
b. Helps to maintain consistency in grading criteria and rubrics 
c. Facilitates collaboration and sharing of materials among educators 
d. Limits creativity and flexibility in lesson planning and design 
Ans: d. Limits creativity and flexibility in lesson planning and design 
 
69. Which of the following is NOT a type of template available in Google Docs? 
a. Business card template 
b. Invoice template 
c. Presentation template 
d. Timeline template 
Ans: a. Business card template 
 
70. What is a template in digital documents? 
a. A pre-designed document format that can be used as a starting point 
b. A software program used for creating digital documents 
c. A type of font used in digital documents 
d. A tool for creating tables in digital documents 
Ans: a. A pre-designed document format that can be used as a starting point 
 
71. Which of the following file formats can be used to save a template in OpenOffice Writer? 
a. .odt 
b. .doc 
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c. .pdf 
d. .txt 
Ans: a. .odt 
 
72. Which of the following is an advantage of using templates in digital documents? 
a. Saves time and effort in creating documents from scratch 
b. Increases the file size of the document 
c. Makes the document harder to read 
d. Requires more technical knowledge to use 
Ans: a. Saves time and effort in creating documents from scratch 
 
73. Can templates be edited and customized according to user requirements? 
a. Yes, templates can be edited and customized 
b. No, templates are fixed and cannot be changed 
c. It depends on the file format of the template 
d. It depends on the software used to create the template 
Ans: a. Yes, templates can be edited and customized 
 
74. Which of the following is a common use of templates in digital documents? 
a. Creating resumes and cover letters 
b. Writing blogs and articles 
c. Creating presentations 
d. Editing and manipulating images 
Ans: a. Creating resumes and cover letters 
 
75. Which of the following is not a type of template in digital documents? 
a. Style template 
b. Format template 
c. Layout template 
d. Sound template 
Ans: d. Sound template 
 
76. Can templates be shared and used by multiple users? 
a. Yes, templates can be shared and used by multiple users 
b. No, templates are restricted to a single user 
c. It depends on the software used to create the template 
d. It depends on the file format of the template 
Ans: a. Yes, templates can be shared and used by multiple users 
 
77. Which of the following is a disadvantage of using templates in digital documents? 
a. Limitations in customization options 
b. Increased file size of the document 
c. Requires more technical knowledge to use 
d. Decreases the overall quality of the document 
Ans: a. Limitations in customization options 
 
78. Which of the following software programs does not support the use of templates in digital 
documents? 
a. OpenOffice Writer 
b. Microsoft Word 
c. Google Docs 
d. Adobe Photoshop 
Ans: d. Adobe Photoshop 
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79. Which of the following is not a benefit of using templates in digital documents? 
a. Consistency in document formatting 
b. Saves time and effort in creating documents 
c. Increases the overall file size of the document 
d. Enhances the professional look of the document 
Ans: c. Increases the overall file size of the document 
 
80. Which menu option is used to insert an image in a digital document? 
a. Insert 
b. Format 
c. File 
d. Tools 
Ans: a. Insert 
 
81. Which of the following image formats is NOT supported in digital documents? 
a. JPG 
b. PNG 
c. PDF 
d. BMP 
Ans: c. PDF 
 
83. Which of the following is NOT a way to insert an image in a digital document? 
a. Drag and drop 
b. Copy and paste 
c. Insert from file 
d. Type the image URL 
Ans: d. Type the image URL 
 
84. Which of the following is a way to adjust the size of an image in a digital document? 
a. Dragging the corners of the image 
b. Changing the image format 
c. Inserting a new image 
d. Deleting the image and re-inserting it 
Ans: a. Dragging the corners of the image 
 
85. What is the purpose of the “Wrap” option when inserting an image in a digital document? 
a. To adjust the size of the image 
b. To add a border around the image 
c. To align the image with the text 
d. To apply a filter to the image 
Ans: c. To align the image with the text 
 
86. Which of the following is an advantage of inserting images in a digital document? 
a. Images take up less storage space than text 
b. Images can convey information more effectively than text alone 
c. Images cannot be copied or manipulated 
d. Images do not require any special formatting or editing 
Ans: b. Images can convey information more effectively than text alone 
 
87. What is the purpose of the “Alt Text” option when inserting an image in a digital document? 
a. To provide a description of the image for visually impaired readers 
b. To adjust the size of the image 
c. To align the image with the text 
d. To apply a filter to the image 
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Ans: a. To provide a description of the image for visually impaired readers 
 
88. Which of the following is NOT a way to adjust the position of an image in a digital document? 
a. Drag and drop 
b. Cut and paste 
c. Use the arrow keys on the keyboard 
d. Use the mouse scroll wheel 
Ans: b. Cut and paste 
 
89. Which of the following is a way to crop an image in a digital document? 
a. Use the “Crop” tool in the image editor 
b. Delete the part of the image that is not needed 
c. Adjust the image size 
d. None of the above 
Ans: a. Use the “Crop” tool in the image editor 
 
90. Which of the following is NOT a reason to use images in a digital document? 
a. To break up large blocks of text 
b. To illustrate a point or idea 
c. To make the document more visually appealing 
d. To save storage space 
Ans: d. To save storage space 
 
91. Which of the following file formats is commonly used for inserting images in digital documents? 
a. .docx 
b. .pdf 
c. .jpg 
d. .txt 
Ans: c. .jpg 
 
92. Which toolbar is used for inserting images in Microsoft Word? 
a. Drawing 
b. Formatting 
c. Insert 
d. View 
Ans: c. Insert 
 
94. Which of the following options is used to resize an image in Microsoft Word? 
a. Resize handle 
b. Right-click and select “Resize” 
c. Image toolbar 
d. All of the above 
Ans: d. All of the above 
 
95. Which of the following options is used to adjust the brightness and contrast of an image in 
Microsoft Word? 
a. Format Picture 
b. Crop Picture 
c. Recolor Picture 
d. Compress Pictures 
Ans: c. Recolor Picture 
 
96. Which of the following options is used to wrap text around an image in Microsoft Word? 
a. Text Wrapping 

 



                 Page - 13 - 

b. Format Picture 
c. Wrap Text 
d. None of the above 
Ans: a. Text Wrapping 
 
97. Which of the following options is used to add alternative text to an image in Microsoft Word? 
a. Alt Text 
b. Image Description 
c. Caption 
d. Title 
Ans: a. Alt Text 
 
98. Which of the following options is used to rotate an image in Microsoft Word? 
a. Crop Picture 
b. Format Picture 
c. Rotate 
d. Both A and C 
Ans:  
d. Both A and C 
 
99. Which of the following options is used to add a border to an image in Microsoft Word? 
a. Picture Border 
b. Text Box Border 
c. Page Border 
d. All of the above 
Ans: a. Picture Border 
 
100. Which of the following options is used to remove the background of an image in Microsoft 
Word? 
a. Crop Picture 
b. Format Picture 
c. Remove Background 
d. All of the above 
Ans: c. Remove Background 
 
101. Which of the following options is used to insert an image in Google Docs? 
a. Insert Image 
b. Add Image 
c. Insert Picture 
d. Add Picture 
Ans: a. Insert Image 
 

OBJECTIVE QUESTIONS (SET 02) 
 
1. ___________ is a set of formats that you can apply to selected pages, text, frames, and other 
elements in your document. 
a. Style 
b. Format 
c. Design 
d. None of the above 
Ans: a. Style 
 
2. You can apply a whole group of formats at the same time using ___________. 
a. Style 
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b. Format 
c. Design 
d. None of the above 
Ans: a. Style 
 
3. Give the example of style in OpenOffice.org __________. 
a. Page Style 
b. Paragraph Style 
c. Character Style 
d. All of the above 
Ans: d. All of the above 
 
4. How you can apply style in the digital documentation _________. 
a. Using the styles and formatting windows 
b. Using fill format mode 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
5. ___________affect the font and size of chosen text within a paragraph, as well as bold and italic 
forms. 
a. Page styles 
b. Paragraph styles 
c. Character styles 
d. Graphic styles 
Ans: c. Character styles 
 
6. Which style includes headers and footers, as well as borders and margins? 
a. Character Style 
b. Page Style 
c. Frame style 
d. Presentation Style 
Ans: b. Page Style 
 
7. Which style affects the font size, boldness, and italics format of the selected text? 
a. Cell Styles 
b. Numbering Styles 
c. Character Styles 
d. Frame Styles 
Ans: c. Character Styles 
 
8. How you can create a new style in digital documentation _____________. 
a. Creating a new style from a selection 
b. Dragging and dropping to create a style 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
9. How you can modify style in digital documentation ___________. 
a. Updating a style from a selection 
b. Load or copy styles from another document or template 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
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20. Styles and Formatting Window is available in ______ menu. 
a. Format 
b. Insert 
c. Tools 
d. View 
Ans: a. Format 
 
21. Images can be added to a document in several ways by inserting _____________. 
a. From Graphics Program 
b. From Scanner 
c. Form Open Office Gallery 
d. All of the above 
Ans: d. All of the above 
 
22. Krishna wants to create a flowchart in Word for his applications. Which option should he choose 
in order to do this work quickly? 
a. Drawing/Shapes 
b. Symbols 
c. Pictures 
d. All of these 
Ans: c. Pictures 
 
23. Using the ____________ option in a word processor, the user can insert lines, simple geometric 
forms, arrows, stars, banners, and callouts into the manuscript. 
a. Pictures 
b. Chart 
c. Symbol 
d. Shapes 
Ans: d. Shapes 
 
24. By selecting the ______ option, you can copy Styles from a template or another document. 
a. New Style from selection. 
b. Update Style. 
c. Load Style. 
d. None of the Above 
Ans: c. Load Style. 
 
25. How many resize handles will be there around the image? 
a. Six 
b. Eight 
c. Ten 
d. Five 
Ans: b. Eight 
 
26. Fatima has added a photograph to a document. She wishes to cut a portion of the image. Which 
method should she use to complete the task? 
a. Cut 
b. Copy 
c. Crop 
d. Layout 
Ans: c. Crop 
 
27. To insert hyperlink in digital document you have to use the following shortcut key: 
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a. Ctrl+K 
b. Ctrl+H 
c. Ctrl+L 
d. Ctrl+P 
Ans: a. Ctrl+K 
 
28. Area where cut and copied image stored is _________________ 
a. Clipboard 
b. RAM 
c. ROM 
d. Imageboard 
Ans: a. Clipboard 
 
29. Which of the following is not a Graphic filter component in digital documents? 
a. Invert 
b. Smooth 
c. Sharpen 
d. Wrapping 
Ans: d. Wrapping 
 
30. You can change color images to grayscale by selecting the image and then selecting Grayscale 
from the ____________. 
a. Graphics mode 
b. Filter 
c. Flip 
d. None of the above 
Ans: a. Graphics mode 
 
31. __________ helps to transport the image vertically or horizontally. 
a. Graphics mode 
b. Filter 
c. Flip 
d. None of the above 
Ans: b. Filter 
 
32. _________ options are used to convert the color values of a color image or the brightness values 
of a grayscale image. 
a. Smooth 
b. Invert 
c. Sharper 
d. Remove noise 
Ans: b. Invert 
 
33. __________ helps to mimic the effects of too much light in a picture. 
a. Smooth 
b. Invert 
c. Solarization 
d. Remove noise 
Ans: c. Solarization 
 
34. ___________ makes a picture appear like a painting by reducing the number of colors used. 
a. Smooth 
b. Posterize 
c. harper 
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d. Remove noise 
Ans: b. Posterize 
 
35. __________ joins groups of pixels into a single area of one color. 
a. Smooth 
b. Invert 
c. Mosaic 
d. Remove noise 
Ans: c. Mosaic 
 
36. _____________ helps to make the image transparent. 
a. Smooth 
b. Invert 
c. Transparency 
d. Remove noise 
Ans: c. Transparency 
 
37. ___________ helps to cut off the parts of the image without changing the scale of image. 
a. Smooth 
b. Cropping 
c. Invert 
d. Remove noise 
Ans: b. Cropping 
 
38. _________ helps to change the size of the image in a digital document. 
a. Smooth 
b. Invert 
c. Keep Scale 
d. None of the above 
Ans: c. Keep Scale 
 
39. The size of the image changes when you specify in percentages __________. 
a. Scale Width and Height 
b. Resize 
c. Nosize 
d. None of the above 
Ans: a. Scale Width and Height 
 
40. You can resize the image by selecting one of the corner handles and keep the _______ key 
pressed while dragging the handle to its new position. 
a. Ctrl 
b. Shift 
c. Alt 
d. None of the above 
Ans: b. Shift 
 
41. Color toolbar allow us to change 
a. RGB Color Components 
b. Brightness 
c. Gamma effect of image 
d. All of the above 
Ans: d. All of the above 
 
42. Rotate option available on ________ toolbar. 
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a. Picture 
b. Art 
c. Drawing 
d. None of the above 
Ans: c. Drawing 
 
43. Which of the following is the correct method for opening the Picture toolbar? 
a. View—> Tools—> Picture 
b. Insert—> Tools—> Picture 
c. View—> Toolbars—> Picture 
d. Insert—> Toolbars—> Picture 
Ans: c. View—> Toolbars—> Picture 
 
44. In the Graphics mode of the picture toolbar, which of the following options is not available? 
a. Grayscale 
b. Black/White 
c. Watermark 
d. Original 
Ans: d. Original 
 
45. We can create temples in __________. 
a. Writer 
c. Spreadsheet 
d. Impress 
e. All of the above 
Ans: d. All of the above 
 
46. A __________ is a model that you use to create other documents. 
a. Document 
b. Template 
c. Design 
d. None of the above 
Ans: b. Template 
 
47. Which of the following does not allow the Templates dialogue to appear? 
a. File>New>Template 
b. File>Template>Manage Template 
c. File>New>Text Document 
Ans: c. File>New>Text Document 
 
48. In Writer, you can make a Template by saving a document with the _____ extension. 
a. .odt 
b. .ott 
c. .dbm 
d. .ods 
Ans: b. .ott 
 
49. Document templates can contain ____________. 
a. Text 
b. Graphics 
c. Style 
d. All of the above 
Ans: d. All of the above 
 

 



                 Page - 19 - 

50. The ___________ is used to create a list of chapter names and page numbers at the beginning of a 
content. 
a. Index 
b. Heading 
c. Table of content 
d. None of the above 
Ans: c. Table of content 
 
51. To create a table of content automatically you have to give ___________ style. 
a. Index 
b. Content 
c. Heading 
d. None of the above 
Ans: c. Heading 
 
52. Which options help to protect the table of content ____________. 
a. Protected any time 
b. Protected against manual changes 
c. Always Protect the changes 
d. None of the above 
Ans: b. Protected against manual changes 
 
53. E#, E, T, #, LS,ES belong to which feature? 
a. Mail Merge. 
b. Indexes and Tables 
c. Tables. 
d. None of these. 
Ans: b. Indexes and Tables 
 
54. Which of the following tabs is not available in the insert Index/Table dialog box? 
a. Entries 
b. Styles 
c. Background 
d. None of the above 
Ans: d. None of the above 
 
55. In Writer, which of the following levels of headers can be indexed? 
a. H1 
b. H2 
c. H3 
d. All of the above 
Ans: d. All of the above 
 
56. __________ button represents the chapter number in the table of content. 
a. E# 
b. E 
c. T 
d. # 
Ans: a. E# 
 
57. ___________ button represents the entry text in the table of content. 
a. E# 
b. E 
c. T 
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d. # 
Ans: b. E 
 
58. ___________ button represents the tab stop in the table of content. 
a. E# 
b. E 
c. T 
d. # 
Ans: c. T 
 
59. ___________ button represents the page number in the table of content. 
a. E# 
b. E 
c. T 
d. # 
Ans: d. # 
 
60. ___________ button represents the start of a hyperlink in the table of content. 
a. E# 
b. E 
c. LS 
d. # 
Ans: c. LS 
 
61. ___________ button represents the end of a hyperlink in the table of content. 
a. E# 
b. E 
c. LE 
d. # 
Ans: c. LE 
 
62. A _______________ is a method of sending a single letter to a large group of recipients. 
a. Table of content 
b. Mail Merge 
c. Style 
d. None of the above 
Ans: b. Mail Merge 
 
63. Which help us to send the same letter to different persons? 
a. Macros 
b. Mail Merge 
c. Template 
d. None of above 
Ans: b. Mail Merge 
 
64. Amrita has just turned 14 years old. She intends to invite her friends and family to the gathering. 
Which function will she employ to send the same invitation to a large number of individuals with 
various addresses without having to type it over and again? 
a. Mail Merge 
b. Letter wizard 
c. Document Type 
d. None of these 
Ans: a. Mail Merge 
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65. Which type of data format we can add in mail merge ____________. 
a. .txt 
b. .csv 
c. .mdb 
d. All of the above 
Ans: d. All of the above 
 
66. A Cyber Awareness brochure must be created. Which of the Office Suite components should be 
used to complete this task: 
a. Spreadsheet 
b. Digital Documentation 
c. Database Management 
d. Mail Merge 
Ans: b. Digital Documentation 
 
67. What is a style in a digital document? a. A collection of formatting attributes that can be applied 
to text in a digital document 
a. A collection of formatting attributes that can be applied to text in a digital document 
b. The layout of a digital document 
c. The content of a digital document 
d. The size of a digital document 
Ans: a. A collection of formatting attributes that can be applied to text in a digital document 
 
68. Which of the following is not a formatting attribute that can be included in a style? 
a. Font 
b. Size 
c. Shape 
d. Spacing 
Ans: c. Shape 
 
69. How can styles help create a consistent look throughout a digital document? 
a. They allow you to format text in the same way throughout the document 
b. They ensure that headings and subheadings are formatted consistently 
c. They make it easy to modify formatting throughout the document 
d. All of the above 
Ans: d. All of the above 
 
70. How do you apply a style to text in a digital document? 
a. Right-click on the text and select the desired style from the style gallery 
b. Use the formatting dialog box to apply the style 
c. Select the text and press the “Style” button in the formatting toolbar 
d. All of the above 
Ans: d. All of the above 
 
71. How can you modify an existing style in a digital document? 
a. Right-click on the style in the style gallery and select “Modify” 
b. Use the “Styles” pane to make changes to the style 
c. Apply the style to a portion of text, make the desired changes, and save the changes to the style 
d. All of the above 
Ans: d. All of the above 
 
72. Which of the following is not a way to create a new style in a digital document? 
a. Right-click on a portion of text and select “New Style” 
b. Use the “Styles” pane to create a new style 
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c. Copy an existing style and modify it to create a new style 
d. All of the above 
Ans: d. All of the above 
 
73. How can you remove a style from a digital document? 
a. Delete the style from the style gallery 
b. Remove all instances of the style from the document 
c. Select the text with the style applied and choose “Clear Formatting” 
d. All of the above 
Ans: d. All of the above 
 
74. How can you view all of the styles in a digital document? 
a. Use the “Styles” pane to view all of the styles 
b. Use the “Styles” menu in the formatting toolbar to view all of the styles 
c. Right-click on a portion of text and select “View Styles” 
d. All of the above 
Ans: a. Use the “Styles” pane to view all of the styles 
 
75. What is the purpose of the “Update Style” feature in a digital document? 
a. To update the formatting of all instances of a specific style in the document 
b. To update the formatting of all styles in the document 
c. To update the content of a specific style in the document 
d. To update the content of all styles in the document 
Ans: a. To update the formatting of all instances of a specific style in the document 
 
76. How can you create a table of contents in a digital document using styles? 
a. Apply heading styles to the sections of the document, and then use the “Table of Contents” feature 
to generate the table of contents 
b. Manually create the table of contents using text boxes and hyperlinks 
c. Use the “Index” feature to create the table of contents 
d. All of the above 
Ans: a. Apply heading styles to the sections of the document, and then use the “Table of Contents” 
feature to generate the table of contents 
 
77. Which of the following is a benefit of using styles in a digital document? 
a. It makes it easier to collaborate with others 
b. It saves time by allowing you to format multiple sections of text at once 
c. It ensures consistency in formatting throughout the document 
d. All of the above 
Ans: d. All of the above 
 
78. Which of the following is not a type of style in a digital document? 
a. Paragraph 
b. Character 
c. Page 
d. Font 
Ans: d. Font 
 
79. How can you apply a style to a numbered or bulleted list in a digital document? 
a. Apply the style to each item in the list individually 
b. Apply the style to the entire list 
c. Styles cannot be applied to numbered or bulleted lists 
d. None of the above 
Ans: b. Apply the style to the entire list 
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80. How can you customize the formatting of a style in a digital document? 
a. Use the “Modify Style” feature to change the formatting attributes 
b. Apply the style to a portion of text, make the desired changes, and save the changes to the style 
c. Copy an existing style and modify it to create a new style with the desired formatting 
d. All of the above 
Ans: d. All of the above 
 
81. How can you rename a style in a digital document? 
a. Use the “Rename Style” feature in the style gallery 
b. Right-click on the style in the style gallery and choose “Rename” 
c. Apply the style to a portion of text, change the name in the “Styles” pane, and save the changes to 
the style 
d. All of the above 
Ans: b. Right-click on the style in the style gallery and choose “Rename” 
 
82. How can you apply a style to all instances of a specific type of formatting in a digital document? 
a. Use the “Find and Replace” feature to find all instances of the formatting and apply the style to 
each one 
b. Use the “Select All” feature to select all instances of the formatting, and then apply the style to the 
selection 
c. Styles cannot be applied to all instances of a specific type of formatting 
d. None of the above 
Ans: b. Use the “Select All” feature to select all instances of the formatting, and then apply the style 
to the selection 
 
83. How can you change the order of styles in the style gallery in a digital document? 
a. Drag and drop the styles to rearrange them 
b. Use the “Sort Styles” feature in the style gallery 
c. Apply the styles in the desired order, and they will be automatically rearranged in the style gallery 
d. Styles cannot be rearranged in the style gallery 
Ans: a. Drag and drop the styles to rearrange them 
 
84. How can you customize the appearance of a style in the style gallery in a digital document? 
a. Right-click on the style in the style gallery and choose “Customize” 
b. Use the “Styles” pane to modify the appearance of the style 
c. Use the “Style Options” feature in the style gallery 
d. Styles cannot be customized in the style gallery 
Ans: c. Use the “Style Options” feature in the style gallery 
 
85. How can you delete a custom style in a digital document? 
a. Right-click on the style in the style gallery and choose “Delete” 
b. Apply the style to a portion of text, and then choose “Delete” from the “Styles” pane 
c. Styles cannot be deleted once they have been created 
d. None of the above 
Ans: a. Right-click on the style in the style gallery and choose “Delete” 
 
86. Which of the following is NOT a font style in digital documents? 
a. Bold 
b. Italic 
c. Regular 
d. Underline 
Ans: d. Underline 
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87. What is the shortcut key to make selected text bold in OpenOffice Writer? 
a. Ctrl + B 
b. Ctrl + U 
c. Ctrl + I 
d. Ctrl + K 
Ans: a. Ctrl + B 
 
88. Which of the following is NOT a type of paragraph alignment in digital documents? 
a. Left-aligned 
b. Right-aligned 
c. Center-aligned 
d. Top-aligned 
Ans: d. Top-aligned 
 
89. What is the shortcut key to center align selected text in Microsoft Word? 
a. Ctrl + C 
b. Ctrl + E 
c. Ctrl + R 
d. Ctrl + L 
Ans: b. Ctrl + E 
 
90. Which of the following is NOT a type of bullet point style in digital documents? 
a. Round 
b. Square 
c. Triangle 
d. Star 
Ans: d. Star 
 
91. Which of the following is a type of page orientation in digital documents? 
a. Landscape 
b. Portrait 
c. Square 
d. Vertical 
Ans: a. Landscape 
 
92. What is the shortcut key to undo the last action in digital documents? 
a. Ctrl + Z 
b. Ctrl + X 
c. Ctrl + C 
d. Ctrl + V 
Ans: a. Ctrl + Z 
 
93. Which of the following is a type of line spacing in digital documents? 
a. Single 
b. Double 
c. Triple 
d. Quadruple 
Ans: b. Double 
 
94. What is the shortcut key to save a digital document in Microsoft Word? 
a. Ctrl + S 
b. Ctrl + P 
c. Ctrl + O 
d. Ctrl + N 
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Ans: a. Ctrl + S 
 
95. Which of the following is NOT a type of font size in digital documents? 
a. 8pt 
b. 12pt 
c. 16pt 
d. 20pt 
Ans: c. 16pt 
 
96. Which of the following is a type of font family in digital documents? 
a. Arial 
b. Bold 
c. Italic 
d. Underline 
Ans: a. Arial 
 
97. What is the shortcut key to select all text in a digital document? 
a. Ctrl + A 
b. Ctrl + X 
c. Ctrl + C 
d. Ctrl + V 
Ans: a. Ctrl + A 
 
98. Which of the following is a type of page border style in digital documents? 
a. Solid 
b. Dashed 
c. Dotted 
d. All of the above 
Ans: d. All of the above 
 
99. What is the shortcut key to change the font size of selected text in OpenOffice Writer? 
a. Ctrl + Shift + > 
b. Ctrl + Shift + < 
c. Ctrl + Shift + + 
d. Ctrl + Shift + – 
Ans: b. Ctrl + Shift + < 
 
100. Which of the following is NOT a type of font color in digital documents? 
a. Blue 
b. Red 
c. Green 
d. Yellow 
Ans: d. Yellow 
 

QUESTIONS AND ANSWERS (SET 01) 
 
1. What are Styles ?. What are the advantages of using styles. 
Answer – Styles are pre-defined formatting attributes in digital document processing that can be used 
to apply consistent formatting to text and other elements. The advantages of using styles include – 

 Consistency throughout the document 
 Efficiency in formatting the document 
 Flexibility in making changes to the document 
 Improved accessibility for users with assistive technologies. 
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2. Give any four styles supported by OpenOffice.org 
Answer – OpenOffice.org supports various styles, including: 

 Paragraph Styles: Used to format paragraphs, including indentation, line spacing, and 
font size. 

 Character Styles: Used to format individual characters, including font type, size, color, 
and style. 

 Page Styles: Used to format the overall appearance of a page, including margins, 
headers, and footers. 

 List Styles: Used to format bulleted or numbered lists, including the type of bullet or 
number, indentation, and spacing. 

 
3. What is the best way to load styles from a template or another document? 
Answer – 
You can copy styles by loading them from a template or another document, for example: 

1. Open the document into which you wish to paste the styles. 
2. In the Styles and Formatting window, click on Load Styles after long-clicking on the 

arrow next to the New Style from Selection symbol. 
3. Locate and choose the template you wish to copy styles from in the Load Styles 

window 
4. Choose the style categories you want to copy. If you want the copied styles to 

overwrite any styles with the same names in the document you’re putting them into, 
select Overwrite. 

5. To copy styles from another document, click the From File button to bring up a box 
where you may choose the required file. 

 
4. How can you modify the style? 
Answer – Styles can be changed in a variety of ways in OpenOffice.org. 
• Load or copy styles from another document or template 
• Update a style from a selection 
 
5. How can we create our own styles? 
Answer – There are two different ways to create a style – 

 Creating a new style from a selection – You can copy a new style from an existing 
style. This new style will only be applied to this document and will not be saved in the 
template. 

 Dragging And Dropping To Create A Style – You can drag and drop a text selection 
into the Styles and Formatting window to create a new style. 

 
6. Explain any five Graphic filters. 
Answer – The following are four graphic filters: 
a. Invert – Changing the color in the color image, and giving brightness in grayscale image. 
b. Solarization – Increasing the effects of excessive light in a photograph. 
c. Posterize – Reduces the number of colours in a picture to make it look like a painting. 
d. Charcoal – The image is displayed as a charcoal sketch. 
e. Mosaic – Combines groupings of pixels into a single colour area. 
 
7. Explain Image Cropping 
Answer – Image cropping is the process of removing unwanted parts of an image by selecting and 
keeping a specific portion of the image while discarding the rest. Method for cropping image are 
right-click the image and choose Picture from the pop-up menu to begin cropping it. Select the Crop 
page in the Picture dialogue box. 
The following parameters can be controlled on the Crop page: 
Keep scale / Keep image size – 
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1. When Keep scale is chosen (the default), cropping the image has no effect on the 
image’s scale. 

2. Cropping creates enlargement (for positive cropping values), shrinking (for negative 
cropping values), or distortion of the image when Keep image size is selected, so the 
image size remains constant. 

Left, Right, Top, and Bottom – 
You can crop the image using the dialog box, you can enter left, right, top and bottom margins to crop 
the image. 

1. Keep scale – using this option you can crop the image without changing the size of the 
image. 

2. Keep image size – Without changing the height and width of the image you can crop 
the image using keep image size. 

 
8. List any three methods of inserting images in a text document. 
Answer – The three methods for inserting images in digital documents are – 

 Drag and Drop 
 Inserting image from clipboard 
 Insert image from Scanner 

 
9. What do you understand by the terms: 
a. Text Wrapping 
b. Anchoring 
Answer – 
a. Text Wrapping – Text wrapping describes the relationship between graphics and the surrounding 
text, which may wrap around the graphic on one or both sides, be overprinted behind or in front of the 
graphic, or be overprinted behind or in front of the graphic. 
b. Anchoring – The graphics’ reference point is referred to as IT. This point could represent the 
object’s location on the page or in the frame. An anchor point is always present in an image. 
 
10. What are templates? What are the advantages of using templates? 
Answer – A template is a type of document that you can use to make a similar type of document. 
Templates can contain text, graphics, style, design. 
Advantage of template are – 
a. Document creation is made easier with templates. 
b. It save time to giving style in document 
c. The use of templates helps to keep the audience’s interest. 
11. What is the difference between styles and templates? 
Answer – 
a. Style – Styles ensure that your formatting is consistent throughout a document. 
b. Template – Templates allow you to reuse text and maintain a consistent look and feel across many 
projects. 
 
12. Explain different ways of creating a template. 
Answer – There are two ways to create templates in a document. 
Creating a template from a document – 
1. Create or edit a new or existing document of the type you wish to use as a template. 
2. Fill in the blanks with the content and styles you desire. 
3. Select File > Templates > Save from the main menu. 
Creating a template using a wizard – 
Wizards can be used to construct letter, fax, agenda, presentation, and Web page templates. The Fax 
Wizard, for example, walks you through the following options: 
1. Fax machine type (business or personal) 
2. Document components such as the date, topic line (for business faxes), salutation, and closing 
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3. Information about the sender and receiver options (business fax) 
4. Inclusion of text in the footer (business fax) 
 
13. What do you mean by table of content? 
Answer – The table of contents tool in Writer allows you to create an automated table of contents 
from your document’s headings. 
Many of the elements are used in table of content – 
a. E# – It indicate chapter number 
b. E – It represents the entry text 
c. T – It represents tab stop 
d. LS – It represents start of a hyperlink 
e. LE – It represents End of a hyperlink 
 
14. Explain Mail Merge. 
Answer – A mail merge is a method of personalizing a message you’ve written and sending it to a 
large group of people, giving the impression that you prepared the letter specifically for them. 
 
15. What are the advantages of Mail Merge? 
Answer – Advantages of mail merge are – 
a. It’s simple to send the same mail to a big group of recipients using the Mail Merge tool. 
b. We don’t have to type each recipient’s name separately in each letter when we use Mail Merge. 
c. It’s one of the most efficient ways to mass-produce hundreds of personalized letters in a short 
amount of time. 
d. It is simple to amend the letter because any change made in the main letter will be reflected in all 
other recipients’ letters. 
 
16. Give examples of databases in which the Data Source can be created. 
Answer – Any database that supports Open Database Connectivity (ODBC) can be utilized as a data 
source. They can also be made in spreadsheets using Excel, or other similar software. 
For example – 
a. Spreadsheet 
b. Text file 
c. CSV file 
d. OpenOffice base or Access 
 
17. Explain the concept of styles in digital documents and how they are useful for formatting 
text and paragraphs. 
Answer – Styles in digital documents are a useful feature that enables users to apply a predefined set 
of formatting options to text and paragraphs in a single click. A style can encompass font size, 
typeface, color, paragraph spacing, alignment, and other formatting options. Consistent use of styles 
throughout a document can help ensure a consistent and polished appearance, enhance readability, 
and save time by avoiding manual formatting changes. Overall, styles are a powerful tool that can 
significantly improve the efficiency and effectiveness of digital document processing. 
 
18. How can styles be used to create a table of contents in a digital document? 
Answer – To create a table of contents in a digital document, styles can be utilized by assigning 
particular styles to headings and subheadings throughout the document. By applying the “Heading 1” 
style to primary section headings and the “Heading 2” style to subheadings, users can generate an 
automatic table of contents that lists all of the document’s sections and subsections in a structured and 
organized manner. 
This saves time and effort since users don’t have to manually create a table of contents, and it also 
ensures that the document is consistent and easy to navigate for the reader. In short, using styles to 
create a table of contents is a powerful feature of digital documents that improves the overall 
readability and usability of the document. 
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19. How can the use of styles help to improve the accessibility of a digital document? 
Answer – Styles are an effective means of enhancing the accessibility of digital documents as they 
provide a consistent structure and formatting that is easy for users with visual impairments to 
navigate. By utilizing styles to define headings and subheadings, document creators can establish a 
clear hierarchy of information that can be interpreted effectively by screen readers. 
This results in a document that is more user-friendly and inclusive, as it enables individuals with 
visual impairments to easily access and understand the content. Ultimately, incorporating styles into 
digital documents can have a positive impact on the overall accessibility and usability of the 
document, which is a crucial consideration in today’s increasingly diverse and inclusive society. 
 
20. How can the use of styles improve the efficiency of document creation and editing? 
Answer – Styles can enhance the efficiency of document creation and editing by enabling users to 
quickly and easily apply formatting options to text and paragraphs. By defining a set of styles that 
reflect the formatting options commonly used in the document, users can swiftly apply those styles to 
text and paragraphs with a single click, streamlining the process and saving time. 
This feature allows for consistency in formatting, reduces the possibility of errors, and improves the 
overall productivity of document creation and editing. In summary, using styles is a powerful tool 
that significantly enhances the efficiency of digital document processing. 
21. How can styles be used to ensure consistency in a collaborative digital document? 
Answer – Using styles in a collaborative digital document can ensure consistency by defining a set of 
agreed-upon formatting options. This allows all collaborators to use the same styles throughout the 
document, resulting in a consistent appearance and better readability. 
 
22. How can styles be used to format text or paragraphs in a way that reflects the document’s 
purpose or audience? 
Answer – Users can use styles to ensure that the digital document effectively communicates its 
message by applying styles that reflect its purpose or target audience. Furthermore, they can modify 
existing styles or create new ones to satisfy the document’s unique requirements. This approach 
results in a more readable and engaging document that is tailored to its intended purpose. 
 
23. What is a table of contents in a digital document, and how can it benefit the reader? 
Answer – A table of contents in a digital document is a list of the document’s sections or chapters 
with corresponding page numbers or hyperlinks. It provides an overview of the document’s structure 
and helps the reader navigate the document quickly and easily. By using a table of contents, the 
reader can locate specific sections of the document without having to manually search for them, 
saving time and improving the reading experience. 
 
24. How can a table of contents be created and formatted in a digital document? 
Answer – To create and format a table of contents in a digital document, users can follow these steps: 

 Assign unique heading styles to each section or chapter of the document. 
 Insert a table of contents using the appropriate option from the menu or toolbar. 
 Customize the table of contents by choosing the desired style and formatting options to 

match the document’s design and layout. 
 Update the table of contents whenever changes are made to the document’s structure 

or content to ensure its accuracy and usefulness to the reader. 
 
25. What are some best practices for creating a table of contents in a digital document? 
Answer – When creating a table of contents in a digital document, it is important to use descriptive 
and accurate section or chapter headings, update the table of contents as changes are made to the 
document, use accurate hyperlinks or page numbers, customize the formatting to match the 
document’s design, and test the table of contents to ensure it is user-friendly and easy to navigate. 

 



                 Page - 30 - 

 
26. How can the use of a table of contents benefit the author of a digital document? 
Answer – Using a table of contents can be advantageous for the writer of a digital document in 
various ways. By presenting a structured and well-organized summary of the document’s content, the 
writer can ensure that the document is easily comprehensible and coherent. Consequently, this can 
save time and minimize the possibility of mistakes that may arise when the reader has to search for 
particular sections or chapters manually. 
 

QUESTIONS AND ANSWERS (SET 02) 
 

Multiple Choice Questions 
 
1. Which among the following is not a valid type of alignment ? 
a. Middle     b. Right     c. Justify     d. None of these 
 
2. On which tab does the paragraph dialog box launcher exist ? 
a.  Page Tab      b. View Tab     c. Home Tab     d. Insert Tab 
 
3. The process of increasing or decreasing the space between the left and right margin 
of a paragraph is known as …  a. Alignment     b. Indentation     c. Spacing     d. None 
of these 
 
4. The default tab space is ……………………. . 
a. 0.5      b. 1.25     c. 1.50     d. 1.15 
 
5. Name the Key which on pressing closes the header section . 
a. Esc      b. Shift     c. Alt     d. None of these 
 
6. Which option on the Design tab helps in exiting from the header section ? 
a. Exit Header/ Footer     b. Close Header/ Footer 
c. Close Header and Footer     d.Exit Header and Footer 
 
7. Which option insert the date in the header section as a field so that it always reflects 
the current date? 
a. Update current date     b. Update automatically     c.Auto-update     d. None of these 
 
8. The ………………….. option on the Design tab helps in inserting page numbers in the 
header section . 
a. Insert Page Number       b. Page Number     c. Add page Number     d. None of these 
 
9. ………………… option contains predefined footer styles .  
a. Footer     b. Insert     c. Style     d. None of these 
 
10. Which tab contain the Close Header and Footer option ? 
a. Home     b. Design     c.  Page Layout     d. Insert 
 
11. The …………………… option in the styles task pane creates any style with the 
formatting of your choice . 
a. New Style     b.  Create New Style     c. Create Style     d. None of these 
 
12. The ……………………… button in Manage Style dialog box helps in editing any 
predefined style. 
a. Edit     b. Edit Style     c. Modify     d. Modify Style 
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Fill in the Blanks : 
 
1. A ……………………… is a predefined combination of various formatting features 
and types.  
Ans: Style  
 
2. ……………. are used to describe the location at which the cursor stops after the Tab 
Key is pressed .  
Ans:  Tab Stop 
 
3. ………………… type of alignment places the text evenly between the left and the 
right margins . 
Ans: Justify  
 
4. ………………… indent controls how the text of a paragraph lines up below the first 
line . 
Ans: First Line Indent 
 
5. …………………… can be used to insert the title at the top of each page.  
Ans: Header  
 
6. Header option is available under the ………………. Group on the Insert tab . 
Ans: Header & Footer 
 
7. To insert a picture in a header, click on the …………………. Option on the 
……………………. Tab . 
Ans: Picture, Design  
 
8. ………………… can be used to insert page numbers at the bottom of each page. 
Ans: Footer  
 
9. Footer option is available under the Header & Footer group on the 
………………………. Tab. 
Ans : Insert  
 
Multiple Choice Questions : 
 
1. By default, the …………………… option is selected when we click on the File > New 
option. 
a. Blank document     b. Document     c. New document     d. None of these 
 
2. While saving a document as template, what option needs to be selected in the save as 
type list box ? 
a.Template     b.Word Template     c. Save Template     d. None of these 
 
3. Which option helps in creating a template based on the existing template ? 
a.Template from existing     b. New from existing     c.New template from existing     
d.None of these 
 
Fill in the Blanks : 
 
1. Microsoft Word provides a feature of using the predefined ……………………… that 
are formatting in someway with the sample content, themes, etc. 
Ans : Template  
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2. A template can be created in word by saving a document as a ………………….. file. 
Ans : Word Template  
 
3. Clicking on the ……………………… option displays the recently used templates .  
Ans : Recent Templates 
 
Multiple Choice Questions : 
 
1. Which type of alignment places the text evenly between the left and the right margins 
? 
a. Justify     b.Even     c. Center     d. None of these 
 
2. Which tab in the paragraph dialog box is selected by default when paragraph dialog 
box launcher is clicked on ? 
a.Line and page     b. Indents and Spacing     c.Page Layout     d.None of these 
 
3. How many types of indents are there in Word ? 
a.2     b.3     c. 4      d. 5 
 
4. ………………………. Is the vertical distance between successive lines of the text in a 
document . 
a.Paragraph Spacing     b.Word Spacing     c.Text Spacing     d.Line Spacing 
 
5. You can close the Header section by ……………………………. 
a.Double-Clicking in the main document     b.Pressing the Esc Key     c.Both a and 
b      d.None of these 
 
6. By which option can we insert date in the Header section so that it always reflects the 
current date ? 
a.Insert current Date/Time     b.Update date automatically     c.Update automatically     
d.None of these 
 
7.Which option is used to exit from the Header section ? 
a.Close Header and Footer     b.Close Header     c.Exit Header and Footer     d.Exit 
Header 
 
8. On which tab does the Footer option exist ? 
a.Insert     b.Header and Footer     c. Home     d. None of these 
 
9. which option in the styles task pane allows the user to edit any style based on the 
specific requirement for the document ? 
a.Manager Styles     b.Edit style     c. Modify   d. None of these 
 
10. With which extension does a template gets saved in Word ? 
a. .dotx     b. .dott     c. Both a and b     d. None of these 
 
Fill in the Blanks : 
 
1. ………………… are used to break continuous text to one or more sentences. 
Ans: Text Wrapping  
 
2. Information like the title of a book or chapter can be placed in 
………………………….. area of a document 
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Ans: Header  
 
3. The shortcut key combination to close the Word document is ……………………… . 
Ctrl+F4 
 
4. The term ……………………… refers to a preset format for a document or file. 
Ans: Template  
 
State True or False : 
 
1. By default , there is one-line gap between paragraphs. ( ) False 
2. Microsoft Word provides five types of alignment. ( ) False 
3. Hanging indent indents the first line of a paragraph. ( ) True 
4. Header and Footer are the identifiers that respectively run across the top and bottom 
of the document. ( ) True 
5. Word does not allow to add page numbers in the Header section of a document. ( 
) False 
6. Different paragraph styles grab and hold the attention of the readers. ( ) True 
7. Create New style option allows you to create any style with the formatting of your 
choice. ( ) True 
8. A template can be created in two ways. ( ) True 
9. New from existing option is present in the Available templates section. ( ) True 
 
Multiple Choice Questions : 
 
1. If you would like to start a new page in a document, you can use the option 
……………… . 
a. Line Break     b.Section Break     c. Page Break     d. Paragraph 
 
2. You can use the ……………………………….. key combination to create a page break 
at the pointed location. 
a. Shift +Enter     b. Ctrl +Enter     c. Alt +Enter     d. None of these 
 
3. To insert a column break, select the breaks button on the ………………………. Tab. 
a. Insert     b. Home     c. Page Layout     d. Design 
 
4. This feature facilitates the organization of the text around the objects embedded on a 
page. 
a. Word Wrap      b. Column Break     c. Next page     d. Text Wrapping 
 
5. To show a section / page breaks, select the ……………………….. option on the Home 
tab. 
a. View     b. Display     c. Show / Hide     d. None of these 
 
Fill in the Blanks : 
1 .By using page break , you can create different ………………………… . 
Ans: Pages 
 
2. The shortcut key for page break is ………………………… . 
Ans: Ctrl+Enter  
 
3. To create a new page, you can keep on pressing the ……………………… key till the 
cursor moves from line to line and a new page starts .  

 



                 Page - 34 - 

Ans: Enter  
 
4. To show a section / page break, click on the …………………… option on the Home 
tab. 
Ans:  Show/Hide  
 
5. To remove the section Break / Page break on a text , press ………………………. On 
your keyboard. 
Ans: Delete  
 
Multiple Choice Questions : 
1. The …………………. Option is used to change the background colour of the text . 
a. Font color     b. Text Highlight Color     c. Both a or b     d. None of the above 
 
2. The ……………… option places the text slightly lower than the normal text position.  
a. Subscript     b. Superscript     c. Strikethrough     d. Font Size 
 
3. On selecting the ……………………. ,the first character in all the words of the 
selected sentence will be converted to capital letters . 
a. Uppercase     b.Sentence case     c. Toggle case     d. Capitalize Each Word 
 
4. The change case option is present under the home tab in the ………………………… 
group. 
a. Paragraph     b.Styles     c. Font     d. Insert 
 
Fill in the Blanks : 
 
1. …………………………. Option is used to change the style of the text.  (Font) 
2. ………………………….. option is used to change the background colour of the 
text. (Text Highlight Color) 
3. After selecting the text, click on the ………………………… icon in the Font group to 
make the font size smaller than the current font size by the specified point. (Font Size) 
4. To remove the character formatting, select the text and click on …………………… in 
the font group.(Clear Formatting) 
5. In …………………….. case, the first character of the selected sentence will be 
converted to capital letter . (Sentence Case) 
6. On the home tab in the font group , select the …………………………. Icon to make 
the selected text higher than the normal text position. (Superscript)  
 
Multiple Choice Questions : 
1. To insert an image from a file, click on the Insert tab and select the 
………………………. Button in the illustrations group. 
a. Image     b.Picture     c. Shapes     d. Screenshot 
 
2. Word can import ……………………………… types of image file formats. 
a.GIF     b.JPEG     c. BMP     d. All of these 
 
3. To copy and paste the image in MS word , the ……………………… option is used .  
a.Ctrl X + Ctrl V     b.Ctrl X + Ctrl C     c. Ctrl C + Ctrl V     d. Ctrl V + Ctrl C 
 
4. The Clip Art option is present under the ………………………. Tab in the illustrations 
group. 
a.Insert     b.Home     c. Text     d. Design 
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Fill in the Blanks : 
1 . …………………….. is a collection of picture or images that can be imported into a 
document . (ClipArt) 
2.  Clip Art option is available in the ……………………………. Group . (Illustrations) 
3. …………………….. is a process of reducing the file size of the digital image while 
maintaining the image .(Compress Picture)  
 
Multiple Choice Questions : 
1. The Wrap text option is present under the …………………….. tab in the Arrange 
group . 
a. Format / Page Layout     b. Design / Format     c. Review / Page Layout     d.View / 
Page Layout 
 
2. …………………… enlarges the first character of a line to on extent that it drop-down 
by two or more line. 
a. Wrap Text     b. Drop Text     c. Word Text     d. None of these 
 
3. The Word Art gallery has …………….. font styles to choose from . 
a. 10     b. 20     c. 30     d. 40 
 
4. The default text wrapping for a picture is the following. 
a. In front of text     b. Behind Text     c. In line with text     d. Top and Bottom 
 
Fill in the Blanks : 
1. ……………………. Is a text formatting feature, which enlarges the first character of a 
line to an extent that it drops down by two or more lines. (Drop Text) 
 
2. After you have inserted the picture , you can wrap the text by using the 
…………………. Option in the Arrange group under the ……………………… tab. (Text 
Wrapping, Format) 
 
3. The default text wrapping for a picture is …………………………… . (Inline with 
Text) 
 
Multiple Choice Questions : 
1. You can insert ……………….. file formats within a Word processor document. 
a. PDF File     b.Excel Spreadsheet     c. Power Point Presentation    d. All of these  
 
2. To embed an Excel spreadsheet in a word document , select the insert tab and click 
on the ……………………………… . 
a. Text Box     b.Quick Parts     c. Drop Cap     d. Object 
 
3. If you like to edit an embedded document, you have to ………………………. On it. 
a. Right –click     b. Double- Click     c. Left- click     d. Single –click 
 
Fill in the Blanks : 
 
1. You can insert a PDF file or a spreadsheet within the Word processor , using the 
……………………….. option. (Object) 
 
2. To insert an object, go to the insert tab and click on the object option present in the 
………………………. Group . (Text) 
 
3. To open an embedded document, ……………………………. On it. (Double  Click) 
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Multiple Choice Questions : 
1. To insert stars, banners, callouts, connectors, etc., click on the ……………………….. 
option in the Insert tab. 
a. Symbols     b.Pictures     c. Shapes     d. All of these 
 
2. You can insert a symbol by clicking on the Symbol option present under the 
……………………….. tab. 
a. Home     b.Design     c. Illustration     d. Insert 
 
3. The 3-D rotation button is present under the …………………………… drop- down 
menu. 
a. 3D Effects     b. Shape Fill     c. Shape Outline     d. Shape Styles 
 
Fill in the Blanks : 
1. You can insert , basic geometric shapes, arrows, equation shapes, flowchat shapes, 
stars, banners, and callouts, using the shapes option in the ………………….. 
group. (Illustrations)  
 
2. Symbol option is available in the …………………………. Group on the Insert 
tab.(Symbols) 
 
3. If you like to view more symbols and special characters to insert into a document, 
click on the ……………………… option . (Symbol) 
 
Multiple choice Questions : 
1. The ………………………. Option is used to change the style of the text . 
a. Font Color     b. Font Style     c. Font Size     d. Font Face 
 
2. The default text wrapping for a picture is : 
a. Tight     b. In Line with Text     c. Through     d. Square 
 
3. In …………………. , the first character in all the words of the selected sentence will 
be converted to capital letters.  
a.Uppercase     b.Lowercase     c.Capitalize Each Word     d. Sentence 
 
4.You can use the ………………………… Key combination to create a page break at the 
pointed location. 
a. Ctrl+Shift+Enter     b. Shift+Enter     c. Ctrl+Enter     d.Ctrl+Shift+F1 
 
5. Word 2010 offers which of the following page break options ? 
a. Page     b. Text Wrapping     c. Next page     d. Both a and b 
 
6. Image compression is a process of ……………………….. the file size of the digital 
image and maintaining the image quality. 
a. Increasing     b.Brightening     c. Reducing     d. Maintaining 
 
7. Word process allows the user to insert lines, basic geometric shapes, arrows, stars, 
banners, and callouts in the document by using the option. 
a. Pictures     b. Chart     c. Symbol     d. Shapes 
 
8. Some of the options present under shape Fill are : 
a. Pictures     b.Texture     c. Gradient     d. All of these above  
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9. If you embed an object, the size of your document …………………………… 
significantly and this may cause problems in e- mailing the documentas an attachment.  
a. Increase     b. Decrease     c. Remains the same     d. None of the above 
 
Fill in the Blanks : 
 
1. In ………………………… case, the first character in all the words of the selected 
sentence will be converted to capital letter. (Capitalize each word)  
 
2. The ……………………… icon on the Home tab in the Font group is used to make the 
selected text higher than the normal text position. (Superscript) 
 
3. ………………………. Case is used to convert the small letters in the selected text to 
capital letters and vice versa (Toggle case) 
 
4. …………………………. Allows you to place text behind an image, in front of an 
image or around an image. (Text Wrapping) 
 
5 ………………………….. feature enlarges the first character of a line to an extent that 
it drops down by two or more lines. (Drop Cap) 
 
6. …………………………. An object in Microsoft Word, rather than simply inserting or 
pasting it, ensures that the object retain its original format.  (Embed) 
 
7. To insert different shapes in a word document, click on the shapes button in the 
……………………… group on the insert tab. (Illustrations)  
 
8. To insert a picture in a word document, select the Insert tab> 
……………………………. Option. (Picture) 
 
9. ……………………… is a process of reducing the file size of the digital image while 
maintaining the image quality. (Image Compression)  
 
State True or False : 
1. You can insert a PDF file, Excel spreadsheet, power point presentation , or a sound 
file within the Word processor. ( ) True 
2. You cannot embed objects created in other programs into a Word documents.( ) False 
3. The Grow Font option is used to make the font size smaller than the current font size 
by the specified point.( ) False 
4 Odd page option is the category of section breaks. ( ) True 
5. You can only insert the images from the clip art gallery built-in-within the word 
processor. ( ) False 
6. Some of the Wrap Text options available MS word are square, Tight, and Through. ( 
) True 
7. The continuous category of section breaks starts the new section on the next page. ( 
) False 
8. You can add text inside the shapes by right-clicking on them and selecting the Add 
text option.( ) True 
9. The default text wrapping for a picture is Through. ( ) False 
10. A person opening your document must have the relevant software loaded on his 
computer to operate the embedded file. ( ) True  
11. Paragraphs are used to break continuous text to one or more sentences. This 
enhances the readability of the content.True 
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12. Paragraph formatting is the most important factor in the overall appearance of a 
document. True  
13. Alignment is the systematic placement of text within a section of a document to 
enhance its readability. It determines the appearance and orientation of the edges of the 
paragraphs. True  
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DIGITAL DOCUMENTATION (ADVANCED)  
 

REVISION NOTES 
 
CREATE AND APPLY STYLE IN THE DOCUMENT 
 
Style refers to a pre-defined set of formatting attributes that can be applied to text, paragraphs, pages, 
and other elements of a document. Styles help to ensure consistency in formatting throughout the 
document and make it easier to manage and modify the document’s formatting. 

 
Advantages of Style 

 Provides consistency throughout the document 
 Saves time and increases efficiency 
 Allows for easy updates and modifications 
 Makes document management simpler and more organized 
 Enhances accessibility for readers who use assistive technologies. 

 
There are several types of styles in OpenOffice, including: 

 Character styles: These are used to apply formatting to specific characters or words 
within a paragraph. For example, you might use a character style to make a particular 
word bold or italicized. 

 Paragraph styles: These are used to apply formatting to entire paragraphs, including 
text alignment, spacing, and indentation. 

 Page styles: These are used to define the layout and formatting of individual pages, 
including margins, headers, and footers. 

 List styles: These are used to define the formatting of bulleted or numbered lists. 
 Frame styles: These are used to define the formatting of frames, which are used to 

hold graphics or other elements within a document. 
 Table styles: These are used to define the formatting of tables, including cell borders, 

backgrounds, and text alignment. 
 Graphics styles: These are used to define the formatting of graphics or images within 

a document, including borders, backgrounds, and text wrapping. 
 
How to Apply Style in OpenOffice.org 
Step 1 : Select the text, paragraph, or other element where you want to apply the style. 
Step 2 : Click Format > Style and Formatting or press F11 
Step 3 : Select any one of the style (e.g., Paragraph, Character, etc.) 
 
What is Fill Format Mode and How to apply 
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Fill Format Mode is a feature in OpenOffice that allows you to copy the formatting from one element 
of a document and apply it to another element. This can be useful when you want to quickly apply 
consistent formatting to multiple elements within a document. 
How to Apply Fill Format Mode 
Step 1 : Select the element that contains the formatting you want to copy. 
Step 2 : Click on the “Fill Format mode” icon in the Style and Formatting window. 
Step 3 : Select the element or elements that you want to apply the formatting to. 
Step 4 : Click on the element that you want to apply the formatting. 
 

 
 
Creating New Custom Style in OpenOffice.org 
There are two diffierent ways to create a Style 
1) Creating a new Style from a selection 
2) Dragging and Dropping to Create A Style 
 
Create New Style from Selection 
By replicating an existing manual format, you can make a new style. This new style will only be 
applied to this document and will not be saved in the template.  

 
Step 1 : Select the formatted text or paragraph. 
Step 2 : From the top menu, select “Styles” > “New Style” (or press F11). 
Step 3 : In the New Style window, enter a name for the new style and select the type of style you 
want to create. 
Step 4 : Make any additional changes to the style options. 
Step 5 : Click “OK” to save the new style.  
 

Drag and Drop to create New Style 
You can drag and drop a text selection into the Styles and Formatting window to create a new style. 
Step 1 : Open the Styles and Formatting window. 
Step 2 : Select text and drag it to the Styles and Formatting window. 
Step 3 : In the Create Style dialog box, type a name for the new style. The list shows the names of 
existing custom styles of the selected type, if any. Click OK to save the new style. 
Step 4 : If the Paragraph Styles list is showing in the Styles and Formatting window, a new paragraph 
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style will be added to the list. If Character Styles are active, the character style will be added to the 
list. 
 
Modifying Custom or Pre defined Styles 
There are two different ways to modify Style in OpenOffice –   

 Updating a style from a selection • 
 Load or copy styles from another document or template 

 
Updating a Style from a selection  
To update a style from a selection: 
Step 1 : Open the Styles and Formatting window. 
Step 2 : In the document, select an item that has the format. 
Step 3 : In the Styles and Formatting window, select the style you want to update (singleclick, not 
double-click), then long-click on the arrow next to the New Style from Selection icon and click on 
Update Style. 

 
Load or copy styles from another document or template 
You can copy styles by loading them from a template or another document:  
Step 1 : Open the document into which you wish to paste styles. 
Step 2 : Long-click on the arrow next to the New Style from Selection symbol in the Styles and  
 
Formatting window, and then select Load Styles.  
Step 3 : Locate and choose the template you wish to copy styles from on the Load Styles box. 
Step 4 : Decide which style categories should be duplicated. 
Step 5 : Click OK to copy the styles. 

 
 
How to Insert and use Image in Digital Document 
There are various ways to insert images into a document, including via the Drag and Drop, Insert 
Image from File, Insert Image from Clipboard, Open Office Gallery, and a scanner. 

1. Drag and Drop 
2. Insert Image from Dialog Box 
3. Insert Image from Clipboard  
4. Insert Image from Gallery  
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5. Insert Image from Scanner 
 

Drag and Drop  
To drag an image file into a digital document, follow these steps: – 
Step 1 : Open a File browser window and locate the image you want to insert. 
Step 2 : Drag the image into the Writer document and drop  it where you want. 
 
Insert Image from Dialog Box 
To insert an image file into a digital document, follow these steps – 
Step 1: Click in the Open Office document in the first step to place the image there. 
Step 2: From the menu bar, select Insert > Picture > From File. 
Step 3: Navigate to the file that needs to be inserted on the Insert Picture dialogue, select it, and click 
Open. 
 
Insert Image from Clipboard 
Step 1 : Open the document in which you want to insert the image. 
Step 2 : Place the cursor where you want the image to be inserted. 
Step 3 : Press “Ctrl+V” or right-click and select “Paste” to insert the image from the clipboard. 
Step 4 : Resize or move the image as necessary. 
 
Insert Image from Gallery  
Step 1 : Open the document in which you want to insert the image. 
Step 2 : From the top menu, select “View” > “Gallery” (or press F6). 
Step 3 : In the Gallery window that appears, browse through the categories to find the image you 
want to insert. 
Step 4 : Click on the image to select it. 
Step 5 : Click and drag the selected image into the document where you want it to appear. 
 
Insert Image from Scanner 
If your computer has a scanner attached, Open Office may access the scanning software and enter the 
scanned item as an image into the Open Office document. To insert image  
Click the area where the image to be placed, then choose Insert > Picture > Scan > Select Source to 
begin the process. 
 
Modifying Image in OpenOffice.org 
You might need to edit a new image you include so that it matches the document. Here, we’ll go 
through how to use the Picture toolbar, as well as how to resize, crop, and rotate a photo using a 
workaround. 
 
Picture Toolbar  
The Picture toolbar displays when you insert a picture or choose one that is already in the page. View 
> Toolbars > Picture allows you to set it to always be visible. 
 
Graphics mode 
You can change color images to grayscale by selecting the image and then selecting Grayscale from 
the Graphics mode list. 
Flip vertically or horizontally 
Select the image, then click the corresponding icon to turn it vertically or horizontally. 
 
Filters 
The filters are briefly described in the following table, but the best way to comprehend them is to use 
them. Try around with the various filters and their settings.  
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Transparency 
To make a picture more transparent, change the percentage value in the Transparency box on the 
Picture toolbar. When making a watermark or enclosing the image in the background. 
 
Using The Formatting Toolbar And Picture Dialog  
a. Cropping Images  
You could want to crop (cut off) a portion of the image if you’re only interested in it for your 
document. Right-click the image and choose Picture from the pop-up menu to begin cropping it. 
 
b. Keep scale / Keep image size 
When the Keep scale option is used (the default), cropping an image does not alter its scale. 
When the option to Keep Picture Size is used, cropping results in either an increase in image size (for 
positive cropping values), a decrease in image size (for negative cropping values), or an image 
distortion. 
 
c. Width and Height  
As you input values in the Left, Right, Top, and Bottom fields under Scale or Image size, the Width 
and Height fields change. To find the precise amount to crop by, use the thumbnail next to these 
fields. 
 

d. Resizing an Image  
If the inserted image is too big or too small, it might not fit into the paper completely.  You can resize 
the image in Writer. 
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e. Rotating a Picture  
With the aid of the rotation option in digital documentation, you can rotate the image. 
 
f. Creating Drawing Objects  
Display the Drawing toolbar by selecting View > Toolbars > Drawing to start utilising the drawing 
tools. 
 
CREATE AND USE TEMPLATE 
A template is a sample that you can follow while writing new documents. Documents that have 
previously been designed are called templates. Simply substitute your own text for the sample text. 
 
Creating a Template 
You can create your own templates in two ways:  

 from a document,  
 and using a wizard.  

 
Creating A Template From A Document 
Step 1 : Open a new or existing document of the type you want to make into a template (text 
document, spreadsheet, drawing, presentation). 
Step 2 : Add the content and styles that you want. 
Step 3 : From the main menu, choose 
File > Templates > Save. 
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Creating A Template Using A Wizard  
Step 1 :  Choose File > Wizards >[type of template required] 
Step 2 : Follow the instructions on the pages of the wizard like the date, subject line , salutation, and 
complimentary close 
Step 3 : In the last section of the wizard, you can specify the name and location for saving the 
template. 
Step 4 : Finally, you have the option of creating a new document from your template immediately, or 
manually changing the template. 

 
 

CREATE AND CUSTOMIZE TABLE OF CONTENTS 
A table of contents (TOC) is a list of the main sections or chapters in a document, a table of contents 
gives readers a quick summary of the document’s content and a mechanism to quickly search for a 
specific piece of information within it. The table of contents typically includes section or chapter 
titles and the corresponding page numbers. 
 
Advantages of Table of Content 

 Provides quick navigation 
 Efficient organization 
 Improved comprehension 
 Professional appearance 
 Accessibility for readers with disabilities 

 
What is the purpose of Table of Content 

1. It provides users with a summary of the contents and structure of the document.  
2. It enables users to jump right to a certain area of a document. 

How to Insert Table of Content in Digital Documentation 
To insert table of Content in Digital Document follow the following link –  
 
Insert > Indexes and Tables > Indexes and Tables. 
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Basic Setting in Table of Content 
Adding A Title 
Put a title in the Title area if you want one for the table of contents. (If Writer automatically entered a 
title in this field, you may edit it by typing over the value.) Clear the Title field to remove the title. 
 
Protecting Against Manual Changes 
Select the Protected against manual changes checkbox to prevent accidental changes to the table of 
contents. 

 If this box is checked, the context menu or the Insert Table/Index window are the only 
ways to modify the table of contents. 

 If this box is unchecked, The table of contents can be modified immediately on the 
document page, just like regular text.. 

 
Changing The Number Of Levels 
When creating the table of contents, Writer by default considers 10 levels of headings. Enter the 
required number in the “Evaluate up to level” spin box to adjust the number of levels examined. 
Assigning Custom Styles 
All paragraphs created using the default heading styles are automatically assigned to the table of 
contents by Writer (Heading 1, Heading 2, and so on). 
 
Using The Entries Tab 
Entries table help to customize the formatting of the TOC entries. This tab allows you to specify how 
the headings and subheadings in the document should appear in the TOC, including the font, style, 
indentation, and page number formatting. 
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 E# – The chapter number is indicated by the E# button. 
 E – The entered text is represented by the E button. 
 T – A tab stop is represented by the T button. 
 # – The page number is indicated by the # button. 
 LS – The beginning of a hyperlink is indicated by the LS button. (This button is absent 

from the Structure line by default.) 
 LE – A hyperlink’s conclusion is indicated by the LE button. (This button is absent 

from the Structure line by default.) 
Deleting Elements 
Click the button next to the element you want to remove from the Structure line, and then press the 
Delete key on your computer. For instance, click the T button and then press the Delete key to 
remove a tab stop. 
 
Using The Background Tab 
To add colour or a graphic to the table backdrop, use the Background tab. 
 
Saving The Table Of Contents 
Click OK to save the table of contents and have it display in your document. The table of contents is 
displayed in your document once the Insert Index/Table window closes. 
 
IMPLEMENT MAIL MERGE 
 
Using a mail merge, you can personalise a letter you’ve already written and send it to a large group of 
recipients, giving the impression that you wrote it specifically for them. A mail merge can also be a 
rapid technique to create labels or envelopes with the addresses for various persons on each label or 
envelope using a list of people’s mailing addresses.  
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Anyone or any business that interacts frequently with customers, partners, parents, or other 
individuals must use the mail merge. 
 
How to create Mail Merge in Digital Documentation  
Step 1: Select starting document 
Step 2: Select document type 
Step 3: Insert address block or Selecting the data source 
Step 4: Create salutation 
Step 5: Adjust layout 
Step 6: Edit document and insert extra fields 
Step 7: Personalize documents 
Step 8: Save, print or send 
 
What is Data Source 
During the mail merge process, data from another document referred to as the data source, Data 
Source connects to the main document and retrieves the information like names, addresses, and phone 
numbers can be found in a document, spreadsheet, or database that serves as the data source. 
 
What are the different type of Data Source available in Mail Merge 
OpenOffice.org allows data sources to be accessed and then linked into OOo documents. For 
example, a mail merge links an external document containing a list of names and addresses into a 
letter, with one copy of the letter being generated for each entry. 
 
Different type of File which support to insert data in Mail merge are –  

1. Spreadsheet 
2. Text File 
3. Access or Base Database  
4. Address Book 
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ELECTRONIC SPREADSHEET (ADVANCED) 
 

OBJECTIVE QUESTIONS (SET 01) 
 
1. ______________ allows you to combine data from multiple worksheets into a single master 
worksheet. 
a. Data Consolidation 
b. Multiple Data 
c. Scenarios 
d. Goal Seek 
Ans: a. Data Consolidation 
 
2. _______________series of worksheets or workbooks summarizes it into a single worksheet. 
a. Multiple Data 
b. Data Consolidation 
c. Scenarios 
d. Goal Seek 
Ans: b. Data Consolidation 
 
3. Which function cannot be performed through Subtotal in a Spreadsheet? 
a. Sum 
b. Product 
c. Average 
d. Percentage 
Ans: d. Percentage 
 
4. Scenarios are a tool to test questions. 
a. Auto 
b. Goal Seek 
c. What-if 
d. Drop Down 
Ans: c. What-if 
 
5. When making a watermark or putting an image in the backdrop of a document, __________ comes 
in useful. 
a. Transparency 
b. Fill 
c. Filters 
d. Crop 
Ans: a. Transparency 
 
6. It refers to a cell or a range of cells on a worksheet and can be used to find the values or data that 
you want a formula to calculate. 
a. Row 
b. Column 
c. Autosum 
d. Cell Reference 
Ans: d. Cell Reference 
 
7. __________, totals/adds data arranged in an array—that is, a group of cells with labels for columns 
and/or rows Which step one must follow before using the Subtotal option? 
a. Consolidate 
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b. Rename Data 
c. Filter Data 
d. Subtotal 
Ans: d. Subtotal 
 
8. A ______ hyperlink contains the full address of the destination file or web page. 
a. Relative 
b. Absolute 
c. Mixed 
d. Address 
Ans: b. Absolute 
 
9. Which of the following reflects the importance of Goal Seek? 
a. Subtotal 
b. Scenario 
c. Solver 
d. Consolidate 
Ans: c. Solver 
 
10. _________ means combining data in a spreadsheet from different worksheets into master 
worksheet 
a. Hyperlinks 
b. Consolidating 
c. Linking 
d. Filter 
Ans: b. Consolidating 
 
11. An __________ link will stop working only if the target is moved while a__________ link will 
stop working only if the start and target locations change relative to each other. 
a. absolute, fixed 
b. Relative, Absolute 
c. absolute, relative 
d. permanent, absolute 
Ans: c. absolute, relative 
 
12. Hema holds the title of chartered accountant. On a daily basis, she used to keep track of the 
accounts on a spreadsheet. There are a number of steps that she must follow at all times. Can you 
recommend a spreadsheet feature that will allow her to complete these activities quickly and without 
having to repeat the processes each time? 
a. Record Changes 
b. Track Changes 
c. Goal Seek 
d. Using Macros 
Ans: d. Using Macros 
 
13. Raj has produced a worksheet in which he has entered all of his employees’ details. He wants 
each employee to look over the spreadsheet and, if necessary, change their address and phone 
number. He’d also like to know what modifications his employees have made. Which aspect of the 
spreadsheet should he enable so that he can view the changes that his staff have made? 
a. Macro 
b. Link Workbook 
c. Change Worksheet 
d. Track Changes 
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Ans: d. Track Changes 
 
14. Sunita is working on a spreadsheet project. Her friend taught her how to rename a spreadsheet, 
which will make it easier for her to identify the worksheet data. She was excited and told her brother 
about it. A worksheet in spreadsheets can be renamed in ________different ways, according to her 
brother. 
a. 2 
b. 3 
c. 4 
d. 1 
Ans: b. 3 
 
15. _________is a spreadsheet function that is designed to minimize or maximize a result based on a 
set of rules that you describe. 
a. Goal Seek 
b. Scenario 
c. Solver 
d. Subtotal 
Ans: c. Solver 
 
16. The intersection point between a row and column is called _______. 
a. Row 
b. Column 
c. Table 
d. Cell 
Ans: d. Cell 
 
17. Formulas in a Spreadsheet must begin with a __________ sign. 
a. $ 
b. @ 
c. # 
d. = 
Ans: d. = 
 
18. ___________ is a tool to test “what-if” questions. 
a. Scenario 
b. Solver 
c. Macro 
d. Average 
Ans: a. Scenario 
 
19. Rohit received a 25 out of 30 grade in English and a 22 out of 30 grade in Math. In order to 
calculate the score in IT, he needs to acquire an overall score of 85 percent. Provide him with the best 
selection from the list below. 
a. Macro 
b. Solver 
c. Goal Seek 
d. Sub Total 
Ans: c. Goal Seek 
 
20. As a school project, Krish and Kritika conducted a survey of their neighborhood’s literacy rates 
by age, which they recorded in a spreadsheet. They both want to work on it at the same time to finish 
it on time. Which option should they use to access the same Spreadsheet in order to save time? 
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a. Consolidate Worksheet 
b. Shared Worksheet 
c. Link Worksheet 
d. Lock Worksheet 
Ans: b. Shared Worksheet 
 
21. You can use ________ to combine data from multiple worksheets into a master worksheet. 
a. Data Consolidation 
b. Goal Seek 
c. Solver 
d. Total data 
Ans: a. Data Consolidation 
 
22. The Consolidated option is available under _________ menu. 
a. View 
b. Tool 
c. Insert 
d. Data 
Ans: d. Data 
 
23. We can consolidate data by ________ 
a. Row Label 
b. Column Label 
c. Both of the above 
d. None of the above 
Ans: c. Both of the above 
 
24. In the consolidate window, which of the following functions are available? 
a. Max 
b. Min 
c. Count 
d. All of the above 
Ans: d. All of the above 
 
25. Which option should we use to define the target range? (Where we want the result to be 
displayed) 
a. Source data range 
b. Copy results to 
c. Need result at 
d. target range 
Ans: b. Copy results to 
 
26. Which option is used to name a range of cells? 
a. Range name 
b. Cell Range 
c. Define Range 
d. Select Range 
Ans: c. Define Range 
 
27. Define range option is available under the ________ menu. 
a. Insert 
b. View 
c. Developer 
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d. Data 
Ans: d. Data 
 
28. SUBTOTALS _________ data arranged in an array (that is, a group of cells ) 
a. Add 
b. Average 
c. Find 
d. Clear 
Ans: a. Add 
 
29. Subtotals are available in __________ menu. 
a. Tools 
b. Format 
c. Insert 
d. Data 
Ans: d. Data 
 
30. In Subtotals we can select up to _______ groups of arrays. 
a. 3 
b. 2 
c. 4 
d. Infinite 
Ans: a. 3 
 
31. Scenario option is available in ___________________ menu. 
a. Data 
b. Tools 
c. Insert 
d. Windows 
Ans: b. Tools 
 
32. We can shift from one scenario to another by _____________ 
a. Navigator 
b. Find and Replace 
c. Data Source 
d. None of the above 
Ans:a. Navigator 
 
33. Which option is suitable to calculate the effect of different interest rates on an investment. 
a. Scenario 
b. Subtotal 
c. Consolidate 
d. None of the above 
Ans: a. Scenario 
 
34. Default name of first scenario created in Sheet1 of Calc is ________ 
a. Sheet1_Scenario1 
b. Sheet1_Scenario_1 
c. Sheet_1_Scenario1 
d. Sheet_1_Scenario_1 
Ans: b. Sheet1_Scenario_1 
 
35. To select a random multiple cell hold down ________ key as you click on each cell. 
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a. Alt 
b. Shift 
c. Ctrl 
d. All of the above 
Ans: c. Ctrl 
 
36. Goal Seek Option available in __ menu. 
a. Tools 
b. Format 
c. Data 
d. Insert 
Ans: a. Tools 
 
37. ____________ is a more elaborate form of Goal Seek. 
a. Scenario 
b. Subtotal 
c. Solver 
d. All of the above 
Ans: c. Solver 
 
38. Solver option is available under _________ menu 
a. Tools 
b. Format 
c. Edit 
d. Insert 
Ans: a. Tools 
 
39. Which feature of Calc helps to see the changes made in the shared worksheet? 
a. Record Changes 
b. Solver 
c. Subtotal 
d. None of the above 
Ans: a. Record Changes 
 
40. Record Changes feature of Calc help 
a. Authors and other reviewers to know which cells were edited. 
b. to record the screen 
c. to make changes permanent 
d. None of the above 
Ans: a. Authors and other reviewers to know which cells were edited. 
 
41. How can you consolidate data in SpreadSheet? 
a. By Column Label 
b. By Row Label 
c. Both a) and b) 
d. None of the above 
Ans: c. Both of the above 
 
42. Subtotals refer to the process of _________ data arranged in an array (a group of cells). 
a. finding 
b. adding 
c. clearing 
d. averaging 
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Ans: b. adding 
 
43. Is it true or false that when you print a spreadsheet, only the content of the active scenario is 
printed? 
a. True 
b. False 
Ans: a. True 
 
44. To select multiple random cells, what key should you hold down as you click on each cell? 
a. Alt 
b. Ctrl 
c. Shift 
d. All of the above 
Ans: b. Ctrl 
 
45. Can we link one worksheet to another worksheet? 
a. True 
b. False 
Ans: a. True 
 
46. Where are the sheet tabs located by default in a spreadsheet? 
a. Top 
b. Bottom 
c. Middle 
d. None of the above 
Ans: b. Bottom 
 
47. What is the formula to refer to cell A3 in sheet named S1? 
a. =S1.A3 
b. =”S1″.A3 
c. =S1A3 
d. None of the above 
Ans: a. =S1.A3 
 
48. If you have two spreadsheets in the same folder linked to each other and you move the entire 
folder to a new location, a relative hyperlink will: 
a. may work 
b. not work 
c. work 
d. None of the above 
Ans: c. work 
 
49. How many options are shown on the left-hand side of the Hyperlink dialog box in Calc? 
a. New Document 
b. Internet 
c. Document 
d. All of the above 
Ans: d. All of the above 
 
50. How can Suman and her friends work together in a spreadsheet? 
a. By linking workbooks 
b. By sharing a workbook 
c. Both a) and b) 
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d. None of the above 
Ans: b. By sharing a workbook 
 
51. What color border appears around a cell where changes were made in a shared worksheet? 
a. Green 
b. Red 
c. Blue 
d. Yellow 
Ans: b. Red 
 
52. What kind of colored bar marks a deleted column or row in a shared worksheet? 
a. Line 
b. Solid 
c. Light 
d. Heavy 
Ans: d. Heavy 
 
53. How can Calc find the changes made to a shared worksheet? 
a. Comparing worksheets 
b. Duplicating worksheets 
c. Checking worksheets 
d. None of the above 
Ans: a. Comparing worksheets 
 
54. Where should one go to edit a macro in Calc? 
a. View > Macros > Edit Macros 
b. Format > Macros > Edit Macros 
c. Tools > Macros > Edit Macros 
d. None of the above 
Ans: c. Tools > Macros > Edit Macros 
 
55. Which of the following modifications is not recorded in a shared worksheet? 
a. Changes to any text 
b. Cell formatting 
c. Changes to any number 
d. None of the above 
Ans: b. Cell formatting 
 
56. In which menu is the “Share Document” option available? 
a. Edit 
b. File 
c. Tools 
d. View 
Ans: c. Tools 
 
57. How can we register a data source in OpenOffice.org? 
a. Choose View > Options > OpenOffice.org Base > Databases 
b. Choose Format > Databases > Options > OpenOffice.org Base 
c. Choose Tools > Options > OpenOffice.org Base > Databases 
d. None of the above 
Ans: c. Choose Tools > Options > OpenOffice.org Base -> Databases 
 
58. Hyperlink option is available in which menu in Calc? 
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a. Insert 
b. Edit 
c. File 
d. Format 
Ans: a. Insert 
 
59. When a new spreadsheet is opened, what is the default name of the first sheet? 
a. Sheet1 
b. Sheet 1 
c. Sheet_1 
d. None of the above 
Ans: a. Sheet1 
 
60. Is the Comment in the Create Scenario dialog box optional? 
a. True 
b. False 
Ans: a. True 
 
61. Do each scenario in SpreadSheet have a name? 
a. True 
b. False 
Ans: a. True 
 
62. What option is used to give a name to a range of cells in SpreadSheet? 
a. Define Range 
b. Target name 
c. Select Range 
d. Cell Range 
Ans: a. Define Range 
 
63. Where can you find the Consolidate option in SpreadSheet? 
a. Insert 
b. View 
c. Data 
d. Tool 
Ans: c. Data 
 
64. What is the correct sequence to apply Subtotals? 
a. Choose the data first, then launch the Subtotals window. 
b. Open the Subtotals window first, and then choose the data to which subtotals should be applied. 
c. Both a) and b) 
d. None of the above. 
Ans: a. Choose the data first, then launch the Subtotals window. 
 
65. Which option is appropriate to determine how different interest rates will affect an investment? 
a. Scenario 
b. Consolidate 
c. Subtotal 
d. None of the above 
Ans: a. Scenario 
 
66. In which menu is the Solver option available? 
a. Edit 
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b. Format 
c. Insert 
d. Tools 
Ans: d. Tools 
 
67. What elements are present in the “Insert Sheet” dialog box? 
a. After Current Sheet 
b. No. of Sheets 
c. Before Current Sheet 
d. All of the above 
Ans: d. All of the above 
 
68. How can hyperlinks in Calc be used? 
a. to jump from one sheet to a website 
b. to jump from one section to another section of the same sheet 
c. to jump from one sheet to another sheet 
d. All of the above 
Ans: d. All of the above 
 
69. Where is the Hyperlink icon present in Calc? 
a. Standard Toolbar 
b. Format Toolbar 
c. Menu Bar 
d. None of the above 
Ans: a. Standard Toolbar 
 
70. Can spreadsheet software allow users to share a workbook? 
a. True 
b. False 
Ans: a. True 
 
71. After sharing a worksheet, what word is displayed on the title bar after the worksheet’s title? 
a. Shared 
b. Sharing Sheet 
c. Sharing 
d. None of the above 
Ans: a. Shared 
 
72. How can users activate the Record Changes feature in a shared worksheet? 
a. Edit > Changes > Record from the menu bar. 
b. View > Changes > Record from the menu bar. 
c. File > Changes > Record from the menu bar. 
d. Insert > Changes > Record from the menu bar. 
Ans: a. Edit > Changes > Record from the menu bar. 
 
73. From which menu can worksheets be merged in Calc? 
a. View 
b. Tools 
c. Edit 
d. File 
Ans: c. Edit 
 
74. Which option should be used to start the macro recorder in Calc? 
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a. Tools > Record > Record Macro 
b. Tools > Macros > Record Macro 
c. Data > Macros > Record 
d. None of the above 
Ans: b. Tools > Macros > Record Macro 
 
75. What is the name of the library automatically included in a Calc document when it is created and 
saved? 
a. Macro Library 
b. Standard 
c. Module Library 
d. None of the above 
Ans: b. Standard 
 
76. Which of the following features are disabled in a shared spreadsheet? 
a. Insert > Names 
b. Insert > Comment 
c. Edit > Changes, except for Merge Document 
d. All of the above 
Ans: d. All of the above 
 
77. In Calc, which menu can open the “Share Document” dialog box? 
a. Edit 
b. View 
c. File 
d. Tools 
Ans: d. Tools 
 
78. A relative hyperlink will stop working only if the target is moved. 
a. True 
b. False 
Ans: b. False 
 
79. How can an existing sheet be renamed in Calc? 
a. Right click on existing sheet and then choose rename 
b. Double click on one of the existing sheet 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
80. In which menu is the Goal Seek option available? 
a. Insert 
b. Tools 
c. Data 
d. Format 
Ans: b. Tools 
 
81. How many groups of arrays can you select in Subtotals? 
a. 3 
b. 4 
c. 5 
d. 6 
Ans: a. 3 
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82. Which option allows you to specify where you want the result to be displayed when consolidating 
data in SpreadSheet? 
a. Source data range 
b. Target result at 
c. Copy results to 
d. Delete range 
Ans: c. Copy results to 
 
83. What feature allows you to collect data from different worksheets and combine it into a single 
master worksheet? 
a. Solver 
b. Goal Seek 
c. Data Consolidation 
d. Total data 
Ans: c. Data Consolidation 
 
84. If you select this option, any values modified in the source range are automatically updated in the 
target range in SpreadSheet. 
a. Link to original data 
b. Link to source data 
c. Link to source range 
d. Link to sheet data 
Ans: b. Link to source data 
 
85. In which menu can you find the Scenarios option in SpreadSheet? 
a. Windows 
b. Data 
c. Insert 
d. Tools 
Ans: d. Tools 
 
86. What is the default name of the first scenario created in Sheet1 of Calc? 
a. Sheet_1_Scenario_1 
b. Sheet1_Scenario1 
c. Sheet_1_Scenario1 
d. Sheet1_Scenario_1 
Ans: d. Sheet1_Scenario_1 
 
87. Which menu is used to insert a new sheet in Calc? 
a. Insert 
b. Tool 
c. Format 
d. Edit 
Ans: a. Insert 
 
88. How many types of hyperlinks are shown on the left-hand side of the Hyperlink dialog box in 
Calc? 
a. 1 
b. 2 
c. 3 
d. 4 
Ans: d. 4 
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89. What feature in Calc allows users to view changes made in a shared worksheet? 
a. Solver 
b. Subtotal 
c. Record Changes 
d. None of the above 
Ans: c. Record Changes 
 
90. How can users add a comment regarding any changes made in a shared worksheet? 
a. File > Changes > Comments 
b. View > Changes > Comments 
c. Edit > Changes > Comments 
d. None of the above 
Ans: c. Edit > Changes > Comments 
 
91. What is the main purpose of using macros in Calc? 
a. To simplify a task 
b. To complicate a task 
c. To do a task 
d. To repeat a task 
Ans: d. To repeat a task 
 
92. Are function names in Calc case sensitive? 
a. True 
b. False 
Ans: b. False 
 
93. To compare an edited worksheet with the original worksheet, which option should be selected? 
a. File –> Compare Document 
b. View –> Compare Document 
c. Tools –> Compare Document 
d. Edit –> Compare Document 
Ans: d. Edit –> Compare Document 
 
94. In Calc, where is the link to external data option present in the menu? 
a. Insert 
b. View 
c. File 
d. Edit 
Ans: a. Insert 
 
95. Can hyperlinks in Calc be either relative or absolute? 
a. True 
b. False 
Ans: a. True 
 
96. Which option is a more elaborate form of Goal Seek? 
a. Subtotal 
b. Solver 
c. Scenario 
d. All of the above 
Ans: b. Solver 
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97. How can you shift from one scenario to another in SpreadSheet? 
a. Navigator 
b. Data Source 
c. Find and Replace 
d. None of the above 
Ans: a. Navigator 
 
98. Is it true or false that you can only consolidate data from two sheets? 
a. True 
b. False 
Ans: b. False 
 
99. In which menu can you find the Subtotals option? 
a. Data 
b. Tools 
c. Insert 
d. Format 
Ans: a. Data 
 
100. Can we give different colors to different scenarios? 
a. True 
b. False 
Ans: a. True 
 
101. Can a new sheet be renamed in Calc? 
a. While inserting a new sheet 
b. After inserting a new sheet 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
102. Which functions can you use in the Consolidate window in SpreadSheet? 
a. Count 
b. Max 
c. Min 
d. All of the above 
Ans: d. All of the above 
 
103. In which menu can you find the Define Range option in SpreadSheet? 
a. Developer 
b. View 
c. Insert 
d. Data 
Ans: d. Data 
 
104. Scenarios are a tool to test __________ questions. 
a. if 
b. what else 
c. if else 
d. what if 
Ans: d. what if 
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105. Is it true or false that you can create only three scenarios for a given range of cells in 
SpreadSheet? 
a. True 
b. False 
Ans: b. False 
 
106. Can we add/insert more sheets in a spreadsheet? 
a. True 
b. False 
Ans: a. True 
 
107. How many sheets are present in a spreadsheet by default? 
a. 2 
b. 3 
c. 4 
d. 5 
Ans: b. 3 
 
108. An absolute hyperlink will stop working only if the target is moved. 
a. True 
b. False 
Ans: a. True 
 
109. Can we link a text in a spreadsheet to any web URL in Calc? 
a. True 
b. False 
Ans: a. True 
 
110. Can multiple users access a shared workbook simultaneously? 
a. True 
b. False 
Ans: a. True 
 
111. Once a spreadsheet is shared, can it be unshared? 
a. True 
b. False 
Ans: b. False 
 
112. What is the purpose of the Record Changes feature in Calc? 
a. To record the screen. 
b. To make changes permanent. 
c. To allow authors and reviewers to know which cells were edited. 
d. None of the above. 
Ans: c. To allow authors and reviewers to know which cells were edited. 
 
113. What is a saved sequence of commands or keystrokes in Calc called? 
a. Solver 
b. Macro 
c. Autosum 
d. Consolidate 
Ans: b. Macro 
 
114. What option should be clicked to stop the macro recorder in Calc? 
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a. End Recording 
b. Close Recording 
c. Stop Recording 
d. None of the above 
Ans: c. Stop Recording 
 

OBJECTIVE QUESTIONS (SET 02) 
 
Q1. _________ allows you to gather data from different worksheets into a master worksheet. 
a. Data Consolidation 
b. Goal Seek 
c. Solver 
d. Total data 
Ans: a. Data Consolidation 
 
Q2. Consolidate option is available under _________ menu. 
a. View 
b. Tool 
c. Insert 
d. Data 
Ans: d. Data 
 
Q3. Data can be consolidated from two sheets only.(T/F) 
a. True 
b. False 
Ans: b. False 
 
Q4. We can consolidate data by ________ 
a. Row Label 
b. Column Label 
c. Both of the above 
d. None of the above 
Ans: c. Both of the above 
 
Q5. Which of the following functions are available in consolidate window? 
a. Max 
b. Min 
c. Count 
d. All of the above 
Ans: d. All of the above 
 
Q6. In which option we have to specify the target range(Where we want the result to be displayed) 
a. Source data range 
b. Copy results to 
c. Need result at 
d. target range 
Ans: b. Copy results to 
 
Q7. If you select ________ then any values modified in the source range are automatically updated in 
the target range. 
a. Link to source data 
b. Link to sheet data 
c. Link to original data 
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d. Link to source range 
Ans: a. Link to source data 
 
Q8. Which option is used to name a range of cells? 
a. Range name 
b. Cell Range 
c. Define Range 
d. Select Range 
Ans: c. Define Range 
 
Q9. Define range option is available under ________ menu. 
a. Insert 
b. View 
c. Developer 
d. Data 
Ans: d. Data 
 
Q10. The text in the row label or column label must be identical, otherwise, new row or column will 
be inserted.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q11. SUBTOTALS _________ data arranged in an array (that is, a group of cells ) 
a. Add 
b. Average 
c. Find 
d. Clear 
Ans: a. Add 
 
Q12. Subtotals is available in __________ menu. 
a. Tools 
b. Format 
c. Insert 
d. Data 
Ans: d. Data 
 
Q13. In Subtotals we can select up to _______ groups of arrays. 
a. 3 
b. 2 
c. 4 
d. Infinite 
Ans: a. 3 
 
Q14. Identify the correct sequence 
a. First open subtotals window and then select the data where we need to apply subtotals. 
b. First Select data and then open subtotals window. 
c. Both of the above are correct 
d. None of the above 
Ans: b. First Select data and then open subtotals window. 
 
Q15. Scenarios are tool to test _________ questions. 
a. if else 
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b. what else 
c. what if 
d. if 
Ans: c. what if 
 
Q16. Each scenario has a name.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q17. Scenario option is available in ___________________ menu. 
a. Data 
b. Tools 
c. Insert 
d. Windows 
Ans: b. Tools 
 
Q18. When we print a spreadsheet, only content of active scenario is printed.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q19. We can shift from one scenario to another by _____________ 
a. Navigator 
b. Find and Replace 
c. Data Source 
d. None of the above 
Ans: a. Navigator 
 
Q20. We can create only 3 scenario for a given range of cells.(T/F) 
a. True 
b. False 
Ans: b. False 
 
Q21. Which option is suitable to calculate the effect of different interest rates on an investment. 
a. Scenario 
b. Subtotal 
c. Consolidate 
d. None of the above 
Ans: a. Scenario 
 
Q22. Default name of first scenario created in Sheet1 of Calc is ________ 
a. Sheet1_Scenario1 
b. Sheet1_Scenario_1 
c. Sheet_1_Scenario1 
d. Sheet_1_Scenario_1 
Ans: b. Sheet1_Scenario_1 
 
Q23. To select random multiple cell hold down ________ key as you click on each cell. 
a. Alt 
b. Shift 
c. Ctrl 
d. All of the above 
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Ans: c. Ctrl 
 
Q24. Goal Seek Option available in __ menu. 
a. Tools 
b. Format 
c. Data 
d. Insert 
Ans: a. Tools 
 
Q25. Comment in Create Scenario dialog box is Optional(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q26. We can give different colors to different scenario?(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q27. ____________ is more elaborate form of Goal Seek. 
a. Scenario 
b. Subtotal 
c. Solver 
d. All of the above 
Ans: c. Solver 
 
Q28. Solver option is available under _________ menu 
a. Tools 
b. Format 
c. Edit 
d. Insert 
Ans: a. Tools 
 
Q29. We can link one worksheet to another worksheet.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q30. We can not add/insert more sheets in a spreadsheet.(T/F) 
a. True 
b. False 
Ans: b. False 
 
Q31. When you open a new spreadsheet, by default it has sheet named ______________. 
a. Sheet1 
b. Sheet_1 
c. Sheet 1 
d. None of the above 
Ans: a. Sheet1 
 
Q32. By default sheets tab are present at the _____________ of the spreadsheet. 
a. Top 
b. Bottom 
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c. Both of the above 
d. None of the above 
Ans: b. Bottom 
 
Q33. We can insert the new sheet in Calc by clicking on __ menu. 
a. Format 
b. Edit 
c. Insert 
d. Tool 
Ans: c. Insert 
 
Q34. Which of the following elements are present in “Insert Sheet” dialog box. 
a. After Current Sheet 
b. Before Current Sheet 
c. No. of Sheets 
d. All of the above 
Ans: d. All of the above 
 
Q35. By default ________________ sheets are present in Spreadsheet. 
a. 1 
b. 2 
c. 3 
d. 4 
Ans: c. 3 
 
Q36. We can rename a new sheet in Calc. 
a. After inserting a new sheet 
b. While inserting a new sheet 
c. Both of the above 
d. None of the above 
Ans: c. Both of the above 
 
Q 37. We can rename an existing sheet in Calc by 
a. Double click on one of the existing sheet 
b. Right click on existing sheet and then choose rename 
c. Both of the above 
d. None of the above 
Ans: c. Both of the above 
 
Q 38. Formula to refer a cell A3 in sheet named S1 is 
a. =S1A3 
b. =S1.A3 
c. =”S1″.A3 
d. None of the above 
Ans: b. =S1.A3 
 
Q 39. Hyperlink in Calc can be used 
a. to jump from one sheet to another sheet. 
b. to jump from one sheet to website 
c. to jump from one section to another section of same sheet 
d. All of the above 
Ans: d. All of the above 
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Q 40. Hyperlink in Calc can be either relative or absolute.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 41. Absolute link will stop working only if the target is moved(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 42. A relative link will stop working only if the target is moved.(T/F) 
a. True 
b. False 
Ans: b. False 
 
Q 43. If you have two spreadsheets in the same folder linked to each other and you move the entire 
folder to a new location, a relative hyperlink will _____________ 
a. not work 
b. work 
c. may work 
d. None of the above 
Ans: b. work 
 
Q 44. Hyperlink option is available in ______ menu. 
a. File 
b. Edit 
c. Format 
d. Insert 
Ans: d. Insert 
 
Q 45. Hyperlink icon is present on _________________ 
a. Format Toolbar 
b. Standard Toolbar 
c. Menu Bar 
d. None of the Above 
Ans: b. Standard Toolbar 
 
Q 46. Hyperlink dialog box shows ___________ types of hyperlinks on left hand side. 
a. 1 
b. 2 
c. 3 
d. 4 
Ans: d. 4 
 
Q 47. We can link a text in spreadsheet to any Web URL.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 48. Hyperlink dialog box in Calc shows ________ options on left hand side. 
a. Internet 
b. Document 
c. New Document 
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d. All of the above 
Ans: d. All of the above 
 
Q 49. In Calc link to external data is present in _____________ menu. 
a. File 
b. Edit 
c. Insert 
d. View 
Ans: c. Insert 
 
Q 50. To register a data source in OpenOffice.org 
a. Choose Tools -> Options -> OpenOffice.org Base -> Databases 
b. Choose Tools -> Options -> Databases-> OpenOffice.org Base 
c. Choose Tools -> Databases-> Options -> OpenOffice.org Base 
d. None of the above 
Ans: a. Choose Tools -> Options -> OpenOffice.org Base -> Databases 
 
Q 51. Spreadsheet software allows the user to share the workbook.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 52. Several users can access shared workbook simultaneously.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 53. Suman and her friends wants to work together in a spreadsheet. They can do so by 
a. Sharing Workbook 
b. Linking Workbook 
c. Both of the above 
d. None of the above 
Ans: a. Sharing Workbook 
 
Q 54. In Calc “Share Document” dialog box can open by clicking on ______________ menu. 
a. File 
b. Edit 
c. View 
d. Tool 
Ans: d. Tool 
 
Q 55. We can not unshare a spreadsheet, once it is shared.(T/F) 
a. True 
b. False 
Ans: b. False 
 
Q 56. After sharing the worksheet, the word ___________ is then shown on the title bar after the 
worksheet’s title 
a. Sharing 
b. Shared 
c. Sharing Sheet 
d. None of the above 
Ans: b. Shared 
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Q 57. Share document option available in _____ menu 
a. Tools 
b. View 
c. Edit 
d. File 
Ans: a. Tools 
 
Q 58. The following features are known to be disabled in a shared spreadsheet 
a. Edit > Changes, except for Merge Document 
b. Insert > Names 
c. Insert > Comment 
d. All of the above 
Ans: d. All of the above 
 
Q 59. Which of the following buttons are present on “Resolve Conflict” dialog box which appear 
during saving shared worksheet. 
a. Keep Mine 
b. Keep Other 
c. Keep All Mine 
d. All of the above 
Ans: d. All of the above 
 
Q 60. Any cells modified by the other user in shared worksheet are shown with a ________ border. 
a. Blue 
b. Green 
c. Red 
d. Yellow 
Ans: c. Red 
 
Q 61. Which feature of Calc help to see the changes made in the shared worksheet? 
a. Record Changes 
b. Solver 
c. Subtotal 
d. None of the above 
Ans: a. Record Changes 
 
Q 62. To activate the record changes feature in shared worksheet ___________ 
a. Select File > Changes > Record from the menu bar. 
b. Select Edit > Changes > Record from the menu bar. 
c. Select View > Changes > Record from the menu bar. 
d. Select Insert > Changes > Record from the menu bar. 
Ans: b. Select Edit > Changes > Record from the menu bar. 
 
Q 63. A __ colored border, appears around a cell where changes were made in shared worksheet. 
a. Blue 
b. Yellow 
c. Green 
d. Red 
Ans: d. Red 
 
Q 64. A deleted column or row in shared worksheet is marked by a ______________ colored bar. 
a. Light 
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b. Line 
c. Solid 
d. Heavy 
Ans: d. Heavy 
 
Q 65. Record Changes feature of Calc help 
a. Authors and other reviewers to know which cells were edited. 
b. to record the screen 
c. to make changes permanent 
d. None of the above 
Ans: a. Authors and other reviewers to know which cells were edited. 
 
Q 66. Which of the following changes are not recorded in shared worksheet? 
a. Changes any number 
b. Changes any text 
c. Cell Formatting 
d. None of the above 
Ans: c. Cell Formatting 
 
Q 67. We can add a comment regarding any changes made in shared worksheet by 
a. Edit > Changes > Comments 
b. File > Changes > Comments 
c. View > Changes > Comments 
d. None of the above 
Ans: a. Edit > Changes > Comments 
 
Q 68. After adding comment to a changed cell of shared worksheet, we can see it by hovering the 
mouse pointer over the cell(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 69. Anil is the author of shared worksheet so he has the right to accept or reject changes made by 
the reviewers.(T/F) 
a. True 
b. False 
Ans: a. True 
 
Q 70. “Accept or Reject Changes” dialog box (for shared worksheet) can be opened by clicking on 
a. File > Changes > Accept or Reject. 
b. Edit > Changes > Accept or Reject. 
c. View > Changes > Accept or Reject. 
d. None of the above 
Ans: b. Edit > Changes > Accept or Reject. 
 
Q 71. Worksheets can be merged from ____________________ menu. 
a. Edit 
b. File 
c. View 
d. Tools 
Ans: a. Edit 
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Q 72. When sharing worksheets authors may forget to record the changes they make. Calc can find 
the changes by __________ worksheets 
a. duplicating 
b. comparing 
c. checking 
d. None of the above 
Ans: b. comparing 
 
Q 73. Edited worksheet can be compared with the original worksheet by selecting. 
a. File –> Compare Document 
b. Edit –> Compare Document 
c. View –> Compare Document 
d. Tools –> Compare Document 
Ans: b. Edit –> Compare Document 
 
Q 74. A _____________ is a saved sequence of commands or keystrokes that are stored for later use 
a. Solver 
b. Autosum 
c. Consolidate 
d. Macro 
Ans: d. Macro 
 
Q 75. Macros are especially useful to ___________ a task. 
a. do 
b. repeat 
c. simplify 
d. complicate 
Ans: b. repeat 
 
Q 76. Use ___________ Macro to start the macro recorder. 
a. Tools > Macros > Record Macro 
b. Tools > Record > Record Macro 
c. Data > Macros > Record 
d. None of the above 
Ans: a. Tools > Macros > Record Macro 
 
Q 77. Click _____________ to stop the macro recorder 
a. Close Recording 
b. End Recording 
c. Stop Recording 
d. None of the above 
Ans: c. Stop Recording 
 
Q 78. To edit macro, go to 
a. Tools –> Macros — > Edit Macros 
b. Edit –> Macros — > Edit Macros 
c. View –> Macros — > Edit Macros 
d. None of the above 
Ans: a. Tools –> Macros — > Edit Macros 
 
Q 79. Function names in Calc are not case sensitive.(T/F) 
a. True 
b. False 
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Ans: a. True 
 
Q 80. When a document is created and saved, it automatically contains a library named ___ 
a. Module Library 
b. Macro Library 
c. Standard 
d. None of the above 
Ans: c. Standard 
 

QUESTIONS AND ANSWERS (SET 01) 
 
1. What is Consolidating data? 
Answer – The Data Consolidation tool summarises data from multiple worksheets or workbooks into 
a single worksheet that you can simply update. Consolidate has a graphical interface for copying data 
from one set of cells to another and then performing one of a dozen operations on it. Consolidation 
allows the contents of cells from many sheets to be consolidated in one location. 
 
2. What is Subtotal? 
Answer – SUBTOTAL: totals/adds data in an array—that is, a collection of cells with column and/or 
row labels. You can choose arrays and then apply a statistical function (sum, average, max, min) to 
them using the Subtotals dialogue. To maximise efficiency, a function can be applied to up to three 
sets of arrays. 
 
3. What is Goal Seek? 
Answer – The word “goal seeking” refers to the act of determining your input value based on a 
previously determined output value. The method entails the use of a certain operator in a formula that 
may be calculated with computer software. 
Example: Set Cell: This specifies the cell whose value will be changed to the desired value after the 
Goal Seek operation is completed. 
For instance, Jack received a 25 out of 30 in English and a 22 out of 30 in Math. In order to calculate 
the score in IT, he needs to acquire an overall score of 85 percent. As a result, a goal has been 
established, and according to it, Jack will discover one unknown variable, IT marks. 
 
4. What is Scenario? 
Answer – Scenarios are a tool to test “what-if” questions. Each scenario is given a unique name and 
can be changed and presented independently. Only the content of the currently active scenario is 
printed when you print the spreadsheet. A scenario is essentially a set of saved cell values that you 
may use in your calculations. Using the Navigator or a dropdown list displayed beside the changing 
cells, you may simply switch between these sets. 
 
5. What is Solver? 
Answer – The Solver option in the Tools menu is essentially a more advanced version of Goal Seek. 
The Solver, on the other hand, deals with equations involving several unknown variables. It is meant 
to minimise or maximise the result based on a set of rules that you specify. 
 
6. Differentiate between relative and absolute hyperlinks. 
Answer – An absolute hyperlink will stop working only if the target is moved. A relative hyperlink 
will stop working only if the source and target locations change relative to each other. 
Suppose, if you have two spreadsheets in the same folder linked to each other and you move the 
entire folder to a new location, a relative hyperlink will not break a link. 
 
7. How can we rename a worksheet in Spreadsheet? 
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Answer – There are three ways you can rename a worksheet, and the only difference between them is 
the way in which you start the renaming process. You can do any of the following: Double-click on 
one of the existing worksheet names. Right-click on an existing worksheet name, then choose 
Rename from the resulting Context menu. Select the worksheet you want to rename (click on the 
worksheet tab) and then select the Sheet option from the Format menu. This displays a submenu from 
which you should select the Rename option. 
 
8. How can we rename a worksheet in Spreadsheet? 
Answer – You can rename a worksheet in three different ways, with the only difference being how 
you begin the renaming process. You can choose from the following options: 
Select one of the existing worksheet names with a double-click. 
Right-click an existing worksheet name, then select Rename from the Context menu that appears. 
Select the worksheet you want to rename (by clicking on the worksheet tab), then choose Sheet from 
the Format menu. This brings up a submenu, from which you should choose Rename. 
 
8. What is the advantage of sharing worksheet data? 
Answer – 
Enhance the speed of data entering 
To facilitate collaboration, make things easy. 
 
9. Explain features and use of Record changes. 
Answer – Calc offers a feature that allows you to keep track of what data was modified, when it was 
updated, who performed the modification, and which cell it happened in. 
A coloured border appears around a cell where changes were made, with a dot in the upper left-hand 
corner. Other reviewers will easily notice which cells have been changed. A strong coloured bar 
indicates a deleted column or row. 
 
10. What is the purpose of adding comments? 
Answer – Comments from reviewers and authors can be added to explain their changes. 
11. How can we add comments to the changes made? 
Answer – To add a remark to a modification, use the following syntax: 
Make the necessary changes to the spreadsheet. 
2. Select the cell that has been changed. 
3. Select Edit > Changes > Comments from the drop-down menu. The following dialogue box 
appears. Calc’s automatically added comment displays in the title bar of this dialogue and is not 
editable. 
4. Click OK after typing your own comment. 
 
12. Explain features of accepting or rejecting changes. 
Answer – The beauty of the recording changes mechanism becomes apparent when you receive a 
worksheet with changes. You can now go through each change like the original author and decide 
how to proceed. To get started, do the following: 
1. Open the worksheet that has been changed. 
2. Select Edit > Changes > Accept or Reject from the drop-down menu. The dialogue box displayed 
below will appear. 
3. Calc goes through each modification one by one. As you go through the process, you can accept or 
reject each adjustment. If you wish to, you can also pick Accept all and reject all. 
 
13. What are Macros? How can we record a Macro? 
Answer – When the same set of operations must be completed repeatedly, such as formatting or 
applying a similar formula to a similar piece of data, macros can save time. It can be used to name 
and track a sequence of events. 
To record a macro, follow these steps: 
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1. Input data 
2. Before performing any operation, go to tools->macro->record macro. 
3. Now repeat the motion you just did. 
4. Select “Stop Recording” from the drop-down menu. Now save the macro by giving it a name. 
 

QUESTIONS AND ANSWERS (SET 02) 
 
Define and Explain the usage of the following terms with Reference to OpenOffice Calc. 
(a) Consolidating data (b) Subtotals (c) Goal seek (d) Scenario (e) Solver 
Answer: 
(a) Consolidating data 
Data Consolidation allows you to gather together your data from separate worksheets into a master 
worksheet. 
OR 
The Data Consolidation function takes data from a series of worksheets or workbooks and 
summarizes it into a single worksheet that you can update easily. Consolidate provides a graphical 
interface for copying data from one range of cells to another, then running one of a dozen functions 
on the data. During consolidation, the contents of cells from several sheets can be combined in one 
place. 
(b) Subtotals 
SUBTOTAL: totals/add data arranged in an array—that is, a group of cells with labels for columns 
and/or rows. Using the Subtotals dialog, you can select arrays, and then choose a statistical function 
(sum, average, max, min) to apply to them. . For efficiency, one must choose up to three groups of 
arrays to which to apply a function. 
( c) Goal seek 
Using the Goal Seek option under the Tools menu, you can discover what values will produce the 
result that you want. 
OR 
Goal seeking is a general term used to describe the process involved in figuring out your input value 
based on an already known output value. The process involves using a specific operator in a formula, 
which can be calculated using computer software. 
Example: Set Cell: It specifies the cell whose value will be changed to the desired value after the 
result of the Goal Seek operation. 
Example: Jack scored 25 out of 30 in English, 22 out of 30 in Maths. He wants to calculate the score 
in IT he needs to achieve 85 percent in aggregate. So here goal is set and according to it Jack will find 
one unknown variable IT marks. 
(d) Scenario 
Scenarios are a tool to test “what-if” questions. Each scenario is named, and can be edited and 
formatted separately. When you print the spreadsheet, only the content of the currently active 
scenario is printed. A scenario is essentially a saved set of cell values for your calculations. You can 
easily switch between these sets using the Navigator or a drop-down list which can be shown beside 
the changing cells. 
For example, if you wanted to calculate the effect of different interest rates on an investment, you 
could add a scenario for each interest rate, and quickly view the results. Formulas that rely on the 
values changed by your scenario are updated when the scenario is opened. If all your sources of 
income used scenarios, you could efficiently build a complex model of your possible income. 
(e) Solver 
The solver option under the Tools menu amounts to a more elaborate form of Goal Seek. The 
difference is that the Solver deals with equations with multiple unknown variables. It is specifically 
designed to minimize or maximize the result according to a set of rules that you define. 
Each of these rules sets up whether an argument in the formula should be greater than, lesser than, or 
equal to the value you enter. 
For example, you can set the constraint that one of the variables or cells must not be bigger than 
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another variable, or no bigger than a given value. You can also define the constraint that one or more 
variables must be integers (values without decimals), or binary values (where only 0 and 1 are 
allowed). Once you have finished setting up the rules, you can adjust the argument and the results by 
clicking the Solve button. 
 
Explain how to create a reference to (a) Other worksheets within the same workbook (b) 
worksheet of another workbook with keyboard and mouse. 
OR 
What are the two ways of referencing cells in other worksheets? 
Answer: 
a) Other worksheets within the same workbook 

1. Click on the = icon next to the formula bar. 
2. Now, click on the sheet tab for the sheet containing the cell to be referenced. (eg. Sheet2) 
3. Click on cell F3 (where the balance is) in sheet2. The phrase ‘Sheet2’.F3 should appear in the 
formula bar. With the help of a keyboard, you have to type down the above formula in the formula 
bar. 
b) Worksheet of another workbook 
Mouse: 

1. Click the = icon next to the formula bar. 
2. Switch to the other spreadsheet (the process to do this will vary depending on which 
operating system you are using). 
3. Select the sheet (Savings account or any) and then the reference cell (F3). 
Keyboard: 
Creating The Reference With The Keyboard 

Referencing within the 
Spreadsheet! 
Typing the reference is simple once you know the format the reference takes. Thereference has three 
parts to it: 

 Path and file name 
 Sheet name 
 Cell 

Looking at the figure above, you can see the general format for the reference is 
=’file:///Path &File Name’#$SheetName.cell name. 
 
Differentiate between relative and absolute hyperlinks. 
Answer: 
An absolute hyperlink will stop working only if the target is moved. A relative hyperlink will stop 
working only if the source and target locations change relative to each other. Suppose, if you have 
two spreadsheets in the same folder linked to each other and you move the entire folder to a new 
location, a relative hyperlink will not break a link. 
 
How can we rename a worksheet in Spreadsheet? 
Answer: 
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There are three ways you can rename a worksheet, and the only difference between them is the way 
in which you start the renaming process. You can do any of the following: 

 Double-click on one of the existing worksheet names. 
 Right-click on an existing worksheet name, then choose Rename from the resulting 

Context menu. 
 Select the worksheet you want to rename (click on the worksheet tab) and then select 

the Sheet option from the Format menu. This displays a submenu from which you 
should select the Rename option. 

 
What is the advantage of sharing worksheet data? 
Answer: 

 Speed up data entry 
 Make things easier for collaboration purposes. 

 
Explain features and use of Record changes. 
Answer: 
Calc has the feature to track what data was changed when the change was made, who made the 
change, and in which cell the change has occurred. 
A colored border, with a dot in the upper left-hand corner, appears around a cell where changes were 
made. Other reviewers then quickly know which cells were edited. A deleted column or row is 
marked by a heavy-colored bar. 
Example: If you are the sponsor of a youth baseball team. The coach has submitted a budget to you 
for the season and you need to edit the costs and return them to her. You are concerned that if you just 
make the changes, then the coach won’t see the changes you made. You decide to use Calc with the 
record changes feature turned on so that the coach can easily see the changes you have made. 
 
What is the purpose of adding comments? 
Answer: 
Reviewers and authors can add their comments to explain their changes. 
 
How can we add comments to the changes made? 
Answer: 
To add a comment to a change: 
1. Make the change to the spreadsheet. 
2. Select the cell with the change. 
3. Choose Edit > Changes > Comments. The dialog shown below appears. The automatically-added 
comment provided by Calc appears in the title bar of this dialog and cannot be edited. 4. Type your 
own comment and click OK. 
 
Explain the feature of accepting or reject changes. 
Answer: 
When you receive a worksheet back with changes, the beauty of the recording changes system 
becomes evident. Now, as the original author, you can step through each change and decide how to 
proceed. To begin this process: 
1. Open the edited worksheet. 
2. Select Edit > Changes > Accept or Reject. The dialog shown below opens. 
3. Calc steps through the changes one at a time. You can choose to accept or reject each change as 
you go through it.  or you can also select Accept all and reject all if you want to do so. 
 
What are Macros? How can we record a Macro? 
Answer: 
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Macros help in saving time in cases when the same set of tasks are to be done repeatedly like 
formatting or applying a similar formula in a similar range of data. It can be used to name and record 
a set of actions. 
Procedure to record a macro: 

1. input data 
2. before you do any action click on tools->macro->record macro 
3. now perform the action you want to repeat 
4. click on stop recording. now save macro by giving name to macro 

 
QUESTIONS AND ANSWERS (SET 03) 

 
Q1. How can we rename a worksheet? 
Ans. There are three ways you can rename a worksheet 
a. Double-click on one of the existing worksheet names. 
b. Right-click on an existing worksheet name, then choose Rename from the resulting Context menu. 
c. Select the worksheet you want to rename (click on the worksheet tab) and then select the Sheet 
option from the Format menu. This displays a submenu from which you should select the Rename 
option. 
 
Q2. What are the two ways of referencing cells in other worksheets? 
Ans. Two ways to reference cells in other sheets: by entering the formula directly using the keyboard 
or by using the mouse. 
 
Q3. Differentiate between Relative and absolute hyperlinks. 
Ans. Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet. An 
absolute link will stop working only if the target is moved. A relative link will stop working only if 
the start and target locations change relative to each other. For instance, if you have two spreadsheets 
in the same folder linked to each other and you move the entire folder to a new location, a relative 
hyperlink will not break. 
 
Q4. List the procedure involved in Linking HTML Tables to Calc Worksheet. 
Ans. You can insert tables from HTML documents, and data located within named ranges from an 
OpenOffice.org Calc or Microsoft Excel spreadsheet, into a Calc spreadsheet. 
We can do this in two ways: using the External Data dialog or using the Navigator. 
Using the External Data dialog 
a. Open the Calc worksheet where the external data is to be inserted. This is the target worksheet. 
b. Select the cell where the external data is to be inserted. 
c. Choose Insert -> Link to External Data. 
d. On the External Data dialog, type the URL of the source worksheet or click the […] button to open 
a file selection dialog. Press Enter to get Calc to load the list of available tables. 
e. In the Available tables/range list, select the named ranges or tables you want to insert. You can also 
specify that the ranges or tables are updated every (number of) seconds. 
f. Click OK to close this dialog and insert the linked data. 
 
Q5. What is the purpose of adding comments? 
Ans. Comments are mostly used in shared Calc sheet which is used to explain the changes made in 
the sheet to the author of the sheet. 
 
Q6. How can we add comments to the changes made? 
Ans. Comments can be added as follows: 
1. Make the change to the spreadsheet. 
2. Select the cell with the change. 
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3. Choose Edit > Changes > Comments. The automatically-added comment provided by Calc appears 
in the title bar of this dialog and cannot be edited. 
4. Type your own comment and click OK. 
After you have added a comment to a changed cell, you can see it by hovering the mouse pointer over 
the cell. 
 
Q7. What are Macros? 
Ans. A macro is a saved sequence of commands or keystrokes that are stored for later use. Macros are 
especially useful to repeat a task the same way over and over again. 
 
Q8. How can we record a Macro? 
Ans. Steps to record macro are as follows 
a. Use Tools > Macros > Record Macro to start the macro recorder. The Record Macro dialog is 
displayed with a stop recording button. 
b. Perform the actions you want to be recorded in the document. 
c. Click Stop Recording. 
d. The Macro dialog appears, in which you can save and run the macro. 
 
Fill in the blanks (Electronic Spreadsheet (Advanced)) 
1. At the bottom of each worksheet window is a small tab that indicates the name of the worksheets 
in the workbook. 
2. A cell reference refers to a cell or a range of cells on a worksheet and can be used to find the 
values or data that you want formula to calculate. 
3. Spreadsheet software allows the user to share the workbook and place it in the Network location 
where several users can access. 
4. Spreadsheet software can find the changes by Comparing Sheets. 
5. Macros are useful to repeat a task the same way over and over again. 
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ELECTRONIC SPREADSHEET (ADVANCED) 
 

REVISION NOTES 
 
ANALYZE DATA USING SCENARIOS AND GOAL SEEK 
 
Data Consolidation 
In OpenOffice, data consolidation refers to the combining of data from various sources or sheets into 
a single area for easy analysis and manipulation. It helps when working with data that is spread across 
multiple files or sheets and enhances productivity, accuracy, and decision-making abilities. 
 
Advantages of using Consolidation Data – 

 Saves time by combining information from various sources into one document. 
 reduces the possibility of errors that could happen when manually copying data, which 

increases accuracy. 
 allows you to examine and interact with the combined data in one place, which 

improves efficiency. 
 improves decision-making by giving a thorough perspective of the data. 
 Having all the data in one location makes it simpler to share it with other people. 

 
 
Consolidation Data Window 
To use the Consolidate tool in OpenOffice, follow these steps: 

1. Open a new or existing spreadsheet in OpenOffice. 
2. Select the cell where you want the consolidated data to appear. 
3. Click on Data > Consolidate from the menu bar. 
4. In the Consolidate dialog box, select the range of cells or sheets you want to 

consolidate. 
5. Choose the function you want to use to consolidate the data (such as sum or average). 
6. Specify any additional settings, such as whether to include labels or empty cells. 
7. Click OK to consolidate the data. 

 
Creating Subtotal in Electronic Spreadsheet 
Subtotal in OpenOffice electronic spreadsheet refers to a function that calculates the subtotal of a 
range of values within a list or table. This function can be used to summarize data by category or 
group, allowing you to quickly see the total for each group. 
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Advantages of using Subtotal in OpenOffice electronic spreadsheet: 

 Easy data analysis by grouping and summarizing data based on criteria. 
 Improved accuracy by automating subtotal calculations and reducing errors. 
 Increased efficiency by saving time and effort. 
 Enhanced organization by grouping data into categories and subcategories. 
 Customizable grouping and calculation criteria for flexibility in data analysis. 

 
 
SubTotal Window 
To use the Subtotal function in OpenOffice, follow these steps: 

1. Open a new or existing spreadsheet in OpenOffice. 
2. Select the range of data you want to subtotal. 
3. Click on Data > Subtotals from the menu bar. 
4. In the Subtotals dialog box, select the column you want to group by and the function 

you want to use (such as sum or count). 
5. Click OK to apply the subtotals. 

 
Using “What-if” Scenarios in Electronic Spreadsheet 
Scenarios in OpenOffice electronic spreadsheet refer to a feature that allows you to create and 
compare different sets of data to explore different outcomes or possibilities. Scenarios are useful 
when you want to explore how changes in data will affect your calculations, such as in financial 
modeling or forecasting. 
 
What is use of What-if in scenario 
“what-if” analysis in scenarios, you can test different possibilities and explore the potential impact of 
changes to your data, helping you make more informed decisions. 
Advantages of using Scenarios in OpenOffice electronic spreadsheet: 

 Allows you to explore different outcomes or possibilities based on changes to your 
data. 

 Helps you to better understand your data and make more informed decisions. 
 Particularly useful in financial modeling, forecasting, and other areas where you need 

to explore the impact of different variables on your data. 
 Provides a way to compare and contrast different sets of data and their potential 

impact. 
 Can save time by allowing you to easily create and test different scenarios. 
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To use Scenarios in OpenOffice, follow these steps: 

1. Open a new or existing spreadsheet in OpenOffice. 
2. Enter the original data that you want to use as the basis for your scenarios. 
3. Click on Tools > Scenarios from the menu bar. 
4. In the Scenarios dialog box, click on Add to create a new scenario. 
5. Give your scenario a name and select the cells you want to vary in your scenario. 
6. Enter the new values for each cell in your scenario. 
7. Click OK to save your scenario. 
8. Repeat steps 4-7 to create additional scenarios. 
9. To compare scenarios, click on Tools > Scenarios and select the scenarios you want to 

compare.  
 
Goal Seek in Electronic Spreadsheet 
Goal Seek in electronic spreadsheet refers to a feature that allows you to find the input value needed 
to achieve a specific output value. This can be useful when you know the desired result of a 
calculation, but you are not sure what input value is needed to achieve that result. 
For example, you might use Goal Seek to determine what interest rate is needed to pay off a loan in a 
specific amount of time, or what sales volume is needed to achieve a certain profit margin. 

 
To use Goal Seek in an electronic spreadsheet, follow these steps: 

1. Enter the formula that you want to use in the cell where you want the output value to 
appear. 

2. Enter an initial value for the input cell that you want to change. 
3. Click on Tools > Goal Seek from the menu bar. 
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4. In the Goal Seek dialog box, enter the output value you want to achieve and select the 
cell containing the input value you want to change. 

5. Click OK to run the Goal Seek analysis. 
6. The Goal Seek feature will calculate the value needed to achieve the desired output 

and update the input cell with the new value. 
 
Solver in Electronic Spreadsheet 
The Solver is a more advanced version of Goal Seek. While Goal Seek is designed to find a single 
variable solution, Solver can handle equations with multiple unknown variables. It is used to find the 
best possible outcome that meets a set of defined conditions, such as minimizing or maximizing a 
particular result based on a set of rules or constraints that you define. 
 
Solver example 
Consider investing $10,000 over the course of a year in two mutual funds. Fund X is a lower risk 
fund with an interest rate of 8%, whereas Fund Y has a greater risk interest rate of 12%. How much 
should be put into each fund in order to generate a total interest of $1,000? 

 
Difference between goal seek and solver 
 Goal Seek Solver 

Purpose Find a single variable solution to 
a problem 

Find an optimal solution to a problem 
with multiple variables 

Input 
variables One input variable Multiple input variables 

Output 
Finds the value of the input 
variable that produces a specific 
output 

Finds the best combination of input 
variable values that meet a set of 
conditions or constraints 

Problem 
complexity 

Simple problems with one 
unknown variable 

Complex problems with multiple 
unknown variables and constraints 

Algorithm Iterative method Optimization algorithm 

Optimization None Minimize, maximize, or target a specific 
value 

Constraints None Multiple constraints can be added 
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LINK DATA AND SPREADSHEETS 
You may also link cells from several worksheets and spreadsheets to summarise data from numerous 
sources using spreadsheets. This allows you to build formulas that combine data from several sources 
and perform computations using both linked and local data.  
 
Inserting New Sheet 
When you open a new spreadsheet, it usually contains three sheet named Sheet1, Sheet2 and Sheet3. 
If you want to insert a new sheet into the spreadsheet, there are different methods you can use. 
Steps for Creating New Sheet – 

1. Choose Insert > Sheet from the menu bar,  
2. Insert the sheet by right-clicking on the tab,  
3. Click in the empty area at the end of the sheet tabs. 

 
Renaming Sheets 

 Step 1 : Double-click on the name of a current worksheet. 
 Step 2 : Use the context menu that appears when you right-click on the name of an 

existing worksheet to select Rename. 
 Step 3 : Click on the worksheet tab to choose the worksheet you want to rename, and 

then choose the Sheet option from the Format menu. The Rename option should be 
chosen from the submenu that is displayed when you do this. 

 
Cell Reference 
Cell referencing in a spreadsheet is the process of referring to a specific cell or range of cells within a 
worksheet by using a unique identifier. This unique identifier is called a cell reference and it is made 
up of a combination of a column letter and a row number that identifies the location of a particular 
cell. 
There are two ways to reference cells in other sheets –  

1. Creating The Reference With The Mouse  
2. Creating The Reference With The Keyboard. 

 
Creating The Reference With The Mouse 
Both spreadsheets must be open in order to construct the reference with the mouse. Choose the cell 
where the formula will be entered. 
 
Creating The Reference With The Keyboard 
Referencing It’s easy to enter a cell reference using the keyboard in a formula. The reference consists 
of three parts: 

 Path and file name 
 Sheet name 
 Cell 

Example – =’file:///Path &File Name’#$SheetName.CellName. 
 
Working with Hyperlinks 
In Calc, you can utilise hyperlinks to navigate between spreadsheet cells and to other areas of the 
same or different files, websites, or even other spreadsheets. 
Hyperlinks can be stored within your file as either relative or absolute. 
 
Relative And Absolute Hyperlinks 
Relative and absolute hyperlinks are used in spreadsheet applications, such as OpenOffice Calc, to 
create links between cells or other resources within the same spreadsheet or to external files and web 
pages. 
 
a. Relative Hyperlinks – Relative hyperlinks are links that are specified in relation to the current 
cell’s location. They typically use a path that is relative to the current file’s location. For example, if 

 



                 Page - 6 - 

you are currently on cell A1 and you want to link to cell B1 in the same sheet, you can use the 
relative hyperlink “B1”. 
 
b. Absolute Hyperlinks – Absolute hyperlinks, on the other hand, specify the full path or URL of the 
resource being linked to. For example, to link to a web page located at 
“https://cbseskilleducation.com/information-technology-class-10-notes/”, you can use the absolute 
hyperlink “https://cbseskilleducation.com/information-technology-class-10-notes/”. 
 
Linking to External Data 
To insert external data, such as tables from HTML documents or named ranges from other 
spreadsheets, into OpenOffice Calc, you can use the External Data dialog or the Navigator. 

1. Using the External Data dialog: Go to “Data” > “External Data”, select the source of 
the data, and choose the specific data to insert. You can link to the external data or 
copy it into your spreadsheet. 

2. Using the Navigator: Click on the “Navigator” icon or press F5, expand the “Data 
Sources” section, select the source of the data, and drag and drop the table or named 
range into your spreadsheet. 

 
SHARING WORKSHEET DATA 
Spreadsheet software gives users the option to share and store workbooks in a network location so 
that numerous users can view the same workbook at once. This function helps users collaborate more 
effectively by increasing the efficiency of data entering. 
 
Setting up a Spreadsheet for Sharing 
You can create a spreadsheet at any moment and share it with others. Open the spreadsheet document 
and select Tools > Share Document to enable the document’s collaborative features. You can choose 
whether to activate or disable sharing from a dialogue that appears. 

 
 
 
Record Changes 
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You may track changes made to a spreadsheet by yourself or other users using the “Record Changes” 
option in OpenOffice Calc. When working on a spreadsheet with others, reviewing and editing data, 
and keeping track of multiple people’s edits, this capability comes in handy. 
Any changes you make to the spreadsheet are noted in the document and recorded when the “Record 
Changes” option is turned on in OpenOffice Calc. 
Turned on Record Changes featue ON 

 Open the Spreadsheet 
 Click on Edit > Changes > Record 
 Now, You can start Editing the worksheet 

 
Viewing Changes 
Calc gives the control over the spread sheet to view the changes you or other have done in 
Worksheet. To change the available filters, select Edit > Changes > Show. The following dialog 
opens. 

 
In OpenOffice Calc, you can view changes made to a spreadsheet using the “Record Changes” 
feature. 

 Date filter: Shows only the changes made within a specified time range. 
 Author filter: Displays changes made by a specific person, which is useful when 

multiple reviewers are working on the worksheet. 
 Range filter: Shows only changes made within a specific range of cells, helpful for 

large spreadsheets. 
 Comment filter: Displays changes that have comments matching the search criteria. 
 Show accepted changes: Displays only the changes that you have accepted. 
 Show rejected changes: Displays only the changes that you have rejected. 

 
Accepting or Rejecting Changes 
You have the choice to accept or reject the changes once you’ve done editing the document. When 
changes are accepted, they are made permanent parts of the document; when changes are rejected, the 
document returns to the way it was before the changes were made. 

1. Go to the “Edit” menu and select “Changes” followed by “Accept or Reject.” 
2. In the Accept or Reject Changes dialog box, you can either accept or reject changes 

one-by-one or all at once. 
 
Merging Worksheets 
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Merging worksheets in OpenOffice Calc is a feature that allows you to combine two or more 
worksheets into a single worksheet. This is useful when you have data spread across multiple 
worksheets that you want to consolidate into a single worksheet for analysis or reporting purposes. 

 Open the Worksheet 
 Select Edit > Changes > Merge Document 
 Select the file from selection dialog box 
 Use Accept or Reject changes 

 
Comparing Document 
You can compare two or more spreadsheets in OpenOffice Calc using a feature called “Document 
Comparison” to find discrepancies between them. This can be helpful when you want to evaluate 
edits made to a spreadsheet by another person or when you want to compare two spreadsheet versions 
for inconsistencies or errors. 

 Open worksheet 
 Select Edit > Compare Document 
 Select the original worksheet 
 Now, You can find the changes 

 
CREATE AND USE MICROS IN SPREADSHEET 
Using Micors 
A macro in OpenOffice is a set of commands or keystrokes that are stored for later usage. Macro 
might be simple, like inputting an address automatically, or sophisticated, like automating a sequence 
of calculations. Because the OpenOffice macro language is so flexible, users can automate a variety 
of processes. When repetitive actions need to be carried out repeatedly in the same manner, macros 
are especially helpful. 
 
Advantages of Micro 

 The repetitive and routine processes are automated by macros. 
 Macros save your time 

 
Creating Macro in Spreadsheet 

 Open Worksheet 
 Click on Tools > Macros > Record Macro 
 Click on Start/Stop recording 
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DATABASE MANAGEMENT SYSTEM 
 

NCERT/CBSE TEXTBOOK QUESTIONS 
 
A. Fill in the Blanks 
1. A database is an organized collection of data. 
2. A DBMS is a software package that can be used for creating and managing databases. 
3. A RDBMS is a database management system that is based on the relational model. 
4. Three popular DBMS software are Microsoft Access, OpenOfficeBase & MySQL. 
5. A Primary Key is a unique value that identifies a row in a table. 
6. Composite Key is a combination of one or more columns. 
7. A table is a set of data elements that is organized using a model of vertical columns and 

horizontal rows. 
8. A column is a set of data values of a particular type, one for each row of the table. 
9. A row represents a single, data item in a table. 
10. Datatypes are used to identify which type of data we are going to store in the database. 
11. Create table DDL command is used to create a table. 
12. Common DDL statements are create, alter and drop. 
13. The types of languages used for creating and manipulating the data in the Database are DDL & 

DML. 
14. A DDL is a standard for commands that define the different structures in a database. 
15. A DML is a language that enables users to access and manipulate data in a database. 
16. A Select is a part of DML involving information retrieval only. 
17. A popular data manipulation language is SQL. 
18. Tables are the basic building blocks of a database. 
19. There are three types of Relationships in a table. 
20. A form helps the user to systematically store information in the database. 
 
B. Subjective Questions 
1. In how many ways tables can be created in Base? 
Ans. Tables can be created in two ways. 

1. In Design view 
2. Using Wizard 

 
2. List datatypes available in Numeric Datatype? 
Ans. The different types of numeric data types are: 

Boolean   Numeric  
Tinyint   Decimal  
Smallint   Real  
Integer   Float  
Bigint   Double 

  
3. List datatypes available in Alphanumeric Data Type? 
Ans. The different types of Alphanumeric Data Type are: 
 Longvarchar  
 Char  
 Varchar 
 Varchar_Ignore Case 

 
4. Define the structure of a table. 
Ans. A table is a set of data elements (values) that  is  organized  in vertical columns and horizontal 
rows. A table has a defined number of columns, but can have any number of rows. 
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5. Differentiate between Tuples and Attributes of a table 
Ans. A row also called a Record or Tuple represents a single,  data item in a table. Whereas A 
column is a set of data values  of  a particular simple type, one for each row of the table. 
 
6. Name different Binary data types. 
Ans. The different Binary data types are: 
 Longvarbinary  
 Binary  
 Varbinary 

 
7. How many types of relationships can be created in Base? Explain each of them. 
Ans. There are three types of relationship in OpenOffice Base. 
 ONE to ONE: In this relationship, both the tables must have primary key columns. Example: In 

the given tables EMP and DEPT, EMP_ID in EMP table and DEPT_ID in DEPT table are the 
primary keys. 

 ONE to MANY: In this relationship, one of the table must have primary key column. It signifies 
that  one  column  of primary  key  table  is associated with all the columns of associated table. 

 MANY to MANY: In this relationship, no table has the primary key column. It signifies that all 
the columns of primary key table are associated with all the columns of associated table. 

 
8. What do you mean by Sorting? In how many ways it can be done? 
Ans. Sorting means arranging elements in particular sequence. It can be done in two ways. 
 Increasing order 
 Decreasing Order 

 
 

OBJECTIVE QUESTIONS (SET 01) 
 
1. What is the purpose of a form in a database? 
a. Form is systematic way of storing information into the table. 
b. Form is used to display information. 
c. Both a) and b) 
d. None of the above. 
Ans: a. Form is systematic way of storing information into the table. 
 
2. Which SQL command will increase the salary of all employees by 5000? (Table name is emp and 
column name is salary). 
a. UPDATE emp SET sal = salary + 5000; 
b. UPDATE SET sal = salary + 5000; 
c. UPDATE emp SET salary = 5000; 
d. None of the above. 
Ans: a. UPDATE emp SET sal = salary + 5000; 
 
3. What is the purpose of the SQL query: “SELECT * FROM Stud ORDER BY Rollno ASC;”? 
a. Display all record in ascending order followed by Rollno 
b. To display all the records of the table. 
c. Both of the above. 
d. None of the above. 
Ans: a. Display all record in ascending order followed by Rollno 
 
4. What does DML stand for? 
a. Database Manipulation Language 
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b. Data Modification Language 
c. Data Manipulation Language 
d. None of the above 
Ans: a. Data Manipulation Language 
 
5. What does SQL stand for? 
a. Structured Query Language 
b. Structured Quality Language 
c. Structural Query Language 
d. None of the above 
Ans: b. Structured Query Language 
 
6. Which language is used to extract/fetch data from a table? 
a. HTML 
b. MySQL 
c. OOBase 
d. Python 
Ans: b. MySQL 
 
7. In Base, how can data be linked between two or more tables? 
a. Foreign key 
b. Primary key 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
8. In which view can the structure of a table be changed? 
a. Design view 
b. Structure view 
c. Data view 
d. All of the above 
Ans: a. Design view 
 
9. What data type is the Auto Value property used for? 
a. Date 
b. Character 
c. Numeric 
d. Binary 
Ans: c. Numeric 
 
10. Which data type is appropriate for storing information such as salary, fees, and price? 
a. Binary data type 
b. Alphanumeric data type 
c. Date Time 
d. Numerical data type 
Ans: d. Numerical data type 
 
11. In what ways can a table be created? 
a. Using a Wizard 
b. Using design view 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
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12. What kind of field is a primary key? 
a. Duplicate Data 
b. Unique Data 
c. Any Data 
d. None of the above 
Ans: b. Unique Data 
 
13. Does data integrity mean that data is accurate and consistent in the database? 
a. Yes 
b. No 
Ans: a. Yes 
 
14. Which of the following is not a database program? 
a. MySQL 
b. Writer 
c. Oracle 
d. OpenOffice base 
Ans: b. Writer 
 
15. What is a database? 
a. A collection of attributes 
b. A collection of field 
c. An organized collection of data 
d. None of the above 
Ans: c. An organized collection of data 
 
16. Which field in the “Student” table can act as the primary key? 
a. Roll_No 
b. Fee 
c. Student_name 
d. Marks 
Ans: a. Roll_No 
 
17. Is Open Office base an open source software? 
a. True 
b. False 
Ans: b. False 
 
18. What is the default name of a table? 
a. 1 Table 
b. Table 1 
c. Untitled 1 
d. Tab 1 
Ans: b. Table 1 
 
19. Which of the following data types will occupy more space in computer memory? 
a. Bigint 
b. Smallint 
c. Tinyint 
d. Integer 
Ans: a. Bigint 
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20. In which view can data be entered in a table? 
a. Data view 
b. Datasheet view 
c. Both a) and b) 
d. None of the above 
Ans: b. Datasheet view 
 
21. Can relationships be created between _________ tables in Base? 
a. One table only 
b. Two or more tables 
c. Both a) and b) 
d. None of the above 
Ans: b. Two or more tables 
 
22. Are queries commands that are used to define the structure and modify the data in a table? 
a. True 
b. False 
Ans: a. True 
 
23. Which SQL query will retrieve the details of all students whose favorite color is blue? 
a. SELECT all FROM Stud WHERE fav_Color = ‘Blue’; 
b. SELECT all FROM Stud WHERE fav_Color is ‘Blue’; 
c. SELECT name FROM Stud WHERE fav_Color = ‘Blue’; 
d. SELECT * FROM Stud WHERE fav_Color = ‘Blue’; 
Ans: d. SELECT * FROM Stud WHERE fav_Color = ‘Blue’; 
 
24. By default, data is arranged in _____ order using the ORDER BY clause. 
a. Descending 
b. Ascending 
c. Both a) and b) 
d. None of the above. 
Ans: b. Ascending. 
 
26. Which of the following is NOT a SQL command? 
a. DELETE 
b. UPDATE 
c. SELECT 
d. CREATE 
Ans: d. CREATE 
 
27. What is a foreign key? 
a. A key that can contain null values 
b. A key that can contain Zero 
c. A key that references another table’s primary key 
d. A key that uniquely identifies in table 
Ans: c. A key that references another table’s primary key 
 
28. Which of the following field properties is for the Numeric data type in Base? 
a. Default Value 
b. AutoValue 
c. Length 
d. All of the above 
Ans: d. All of the above 

 



                Page - 6 - 

 
29. What is the default length of the Integer data type in Base? 
a. 20 
b. 40 
c. 10 
d. 50 
Ans: c. 10 
 
30. We can create a relationship between any two tables by selecting which option from the which 
menu? 
a. Relationships 
b. Filter 
c. Sort 
d. All of the above 
Ans: a. Relationships 
 
31. In which relationship, both the tables must have primary key columns? 
a. One to Many 
b. One to One 
c. Many to Many 
d. Many to All 
Ans: b. One to One 
 
32. What are the commands that define the data structure and manipulate the data in a database? 
a. Reports 
b. Queries 
c. Forms 
d. Tables 
Ans: b. Queries 
 
33. Which operators are used to perform simple calculations in Base? 
a. Arithmetic Operators 
b. Membership Operators 
c. Logical Operators 
d. Relational Operators 
Ans: a. Arithmetic Operators 
 
34. Can ‘Where’ and ‘Order by’ clauses be used together in a single query? 
a. True 
b. False 
Ans: a. True 
 
35. What is the purpose of the Update command in a database? 
a. It is used to modify the data of the table. 
b. It is used to delete the table. 
c. It is used to modify the structure of the table. 
d. It is used to insert data in the table. 
Ans: a. It is used to modify the data of the table. 
 
36. Which statement is used to remove one or more records from a database? 
a. Erase 
b. Delete 
c. Remove 
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d. Del 
Ans: b. Delete 
 
37. Can we insert records into a table using a form in a database? 
a. True 
b. False 
Ans: a. True 
 
38. Which method is used to create a table step by step? 
a. Use Wizard to Create Table 
b. Create View 
c. Create table in Design View 
d. None of the above 
Ans: a. Use Wizard to Create Table 
 
40. Which of the following is not a Date Time data type? 
a. Date 
b. Stamptime 
c. Time 
d. Timestamp 
Ans: b. Stamptime 
 
41. Binary data types are used for storing data in _________________ formats. 
a. image 
b. sound 
c. boolean 
d. binary 
Ans: d. binary 
 
42. Which of the following is not a category of Open Office data types? 
a. Alphanumeric Types 
b. Date time 
c. Numeric Types 
d. Bool Type 
Ans: d. Bool Type 
 
43. Which feature helps us get summarized data in a database? 
a. Form 
b. Query 
c. Report 
d. Table 
Ans: c. Report 
 
44. Which database feature helps users to systematically store information in a table? 
a. Table 
b. Report 
c. Form 
d. Query 
Ans: c. Form 
 
45. Rajesh wants to display the salary of all the employees after incrementing it by twice the amount 
of the present salary. Which query will help her achieve this task? 
a. Select salary + 2 from employee; 
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b. Select salary / 2 from employee; 
c. Select salary – 2 from employee; 
d. Select salary * 2 from employee; 
Ans: d. Select salary * 2 from employee; 
 
46. Which feature is used to collect specific information from the pool of data? 
a. Form 
b. Query 
c. Table 
d. Report 
Ans: b. Query 
 
47. Which of the following relationships cannot be created in Open Office Base? 
a. One to Many 
b. Many to Many 
c. One to One 
d. Many to All 
Ans: d. Many to All 
 
48. Which property helps to set the value that is automatically inserted in a field when a new record is 
created? 
a. Length 
b. Entry Required 
c. Format 
d. Default Value 
Ans: d. Default Value 
 
49. Which field property in Base can be used to automatically increment the value of a field? 
a. Format 
b. Length 
c. Auto Value 
d. Default Value 
Ans: c. Auto Value 
 
50. In which view can data be entered in a table in Base? 
a. Datasheet View 
b. Design View 
c. Both of the above 
d. None of the above 
Ans: a. Datasheet View 
 
51. Which of the following is NOT a component of a database management system? 
a. Data warehouse 
b. Query language 
c. Data dictionary 
d. Database engine 
Ans: a. Data warehouse 
 
52. Which of the following is NOT a join type in SQL? 
a. Outer join 
b. Full join 
c. Inner join 
d. Circular join 
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Ans: d. Circular join 
 
53. Which element in a table contains data of the same data type? 
a. Column 
b. Tuple 
c. Record 
d. All of the above 
Ans: a. Column 
 
54. A table has a fixed number of ________ but can have any number of ________ 
a. tuple, columns 
b. columns, rows 
c. rows, columns 
d. tuple, degree 
Ans: b. columns, rows 
 
55. Which of the following acts as an interface to view, enter and change data in a database? 
a. Report 
b. Form 
c. Table 
d. Query 
Ans: b. Form. 
 
56. Which SQL command is used to delete data from a table? 
a. INSERT 
b. REMOVE 
c. SELECT 
d. DELETE 
Ans: d. DELETE 
 
57. Which is the most common DML command? 
a. Delete 
b. Select 
c. Update 
d. All of the above 
Ans: b. Select 
 
58. Which software is appropriate for storing data about school students? 
a. Calc 
b. MS-Access 
c. Writer 
d. Impress 
Ans: b. MS-Access 
 
59. What kind of data storage system stores data in a single table? 
a. Only File 
b. Relational 
c. One File 
d. Flat File 
Ans: d. Flat File 
 
60. What kind of computer holds the actual databases and runs only DBMS and related software? 
a. Database Server 
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b. Web Server 
c. SMPT Server 
d. POP Server 
Ans: a. Database Server 
 
61. What is the role of the database server in relation to the GUI? 
a. Back End 
b. Front End 
c. Both a) and b) 
d. None of the above 
Ans: a. Back End 
 
62. What is duplication of data called? 
a. Redundancy 
b. Consistency 
c. Foreign Key 
d. Inconsistency 
Ans: b. Redundancy 
 
63. Which of the following is not an advantage of a database? 
a. Increasing Data Inconsistency 
b. Increasing Data Redundancy 
c. Data Security 
d. Sharing of Data 
Ans: a. Increasing Data Inconsistency 
 
64. Can a database have only one table? 
a. Yes 
b. No 
Ans: b. No 
 
65. Which of the following is used to maintain unique records in a table? 
a. Composite Key 
b. Primary Key 
c. Alternate Key 
d. Foreign Key 
Ans: b. Primary Key 
 
66. What is a primary key made up of two or more columns called? 
a. Composite Primary Key 
b. Alternate Primary Key 
c. Foreign Primary Key 
d. Reference Primary Key 
Ans: a. Composite Primary Key 
 
67. Can duplicate values be entered in a primary key? 
a. Yes 
b. No 
Ans: b. No 
 
68. What is a key that refers to the primary key of another table called? 
a. Alternate Primary Key 
b. Foreign Key 
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c. Primary Key 
d. Alternate Key 
Ans: b. Foreign Key 
 
69. What kind of database software is required when data is stored, maintained, and retrieved from 
multiple tables? 
a. SpreadSheet 
b. RDBMS 
c. DBMS 
d. All of the above 
Ans: b. RDBMS 
 
70. Does every row in a table have the same structure? 
a. True 
b. False 
Ans: a. True 
 
71. What are the basic building blocks of a database? 
a. Records 
b. Tables 
c. Fields 
d. All of the above 
Ans: b. Tables 
 
72. What is the default data type of fields? 
a. Int 
b. Text[Memo] 
c. Memo 
d. Text[Varchar]  
Ans: d. Text[Varchar] 
 
73. Does Base automatically add a column as Primary Key if none is added? 
a. True 
b. False 
Ans: a. True 
 
74. What is the default length of the Varchar data type? 
a. 10 
b. 30 
c. 50 
d. 20 
Ans: c. 50 
 
75. What is used to identify the type of data that will be stored in a database? 
a. Field 
b. Data type 
c. Table 
d. Record 
Ans: b. Data type 
 
76. Which of the following is not a numerical data type? 
a. Varchar 
b. Tinyint 
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c. Boolean 
d. Smallint 
Ans: a. Varchar 
 
77. Which of the following data types cannot store decimal values? 
a. Boolean 
b. Decimal 
c. Numeric 
d. Real 
Ans: a. Boolean 
 
78. Which data type is used for storing photos, music files, and other binary data? 
a. Numeric 
b. Varchar 
c. Binary 
d. Alphanumeric 
Ans: c. Binary 
 
79. Is Char a fixed-length data type and Varchar a variable-length data type? 
a. Yes 
b. No 
Ans: a. Yes 
 
80. What operations can be performed on data in a table? 
a. Insert 
b. Delete 
c. Modify 
d. All of the above 
Ans: d. All of the above 
 
81. After inserting records in a table, can the structure of the table be modified? 
a. True 
b. False 
Ans: b. False 
 
82. What does sorting mean? 
a. Arranging data in decreasing order 
b. Arranging data in increasing order 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
83. Is Referential Integrity used to maintain accuracy and consistency of data in a relationship? 
a. True 
b. False 
Ans: a. True 
 
84. From which menu a relationship can be created in Base? 
a. View 
b. Tools 
c. Insert 
d. Windows 
Ans: b. Tools 
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85. How many types of relationships can be created between tables in Base? 
a. Four 
b. Five 
c. Three 
d. Two 
Ans: c. Three 
 
86. In Open Office Base, in which view can a query be created? 
a. Using wizard 
b. Design view 
c. Both a) and b) 
d. None of the above 
Ans: c. Both of the above 
 
87. Can data be deleted using queries in Base? 
a. True 
b. False 
Ans: b. False 
 
88. Which statement is used to retrieve data from a table? 
a. Print 
b. Select 
c. Delete 
d. Update 
Ans: b. Select 
 
89. What is the purpose of the SQL query: “SELECT empname, salary * 3 FROM emp;”? 
a. Display only name and salary 
b. It will give an error. 
c. Display empname and three times of the salary of all employees. 
d. None of the above. 
Ans: c. Display empname and three times of the salary of all employees. 
 
90. Which SQL command is used to modify data in a table? 
a. SELECT 
b. MODIFY 
c. DELETE 
d. UPDATE 
Ans: d. UPDATE 
 
91. Which of the following SQL commands are considered as DML commands? 
a. UPDATE 
b. DELETE 
c. INSERT 
d. All of the above. 
Ans: d. All of the above. 
 
92. What is another name for a tuple in a table? 
a. Record 
b. Column 
c. Both of the above 
d. Attribute 
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Ans: a. Record 
 
93. Which element in a table represents a single data item? 
a. Rows 
b. Attribute 
c. Columns 
d. Field 
Ans: c. Columns 
 
94. Which of the following is NOT a standard SQL data type? 
a. Float 
b. Boolean 
c. Integer 
d. String 
Ans: b. Boolean 
 
95. Which of the following is NOT a function of a database management system? 
a. Data retrieval 
b. Data manipulation 
c. Data storage 
d. Data transmission 
Ans: d. Data transmission 
 
96. Which of the following is NOT a type of data manipulation language (DML)? 
a. SELECT 
b. UPDATE 
c. INSERT 
d. DELETE 
Ans: a. SELECT 
 
97. What can you do with data in a table created in Base? 
a. Modify it 
b. Insert it 
c. Delete it 
d. All of the above 
Ans: d. All of the above 
 
98. In which view can the structure of a table be changed in Base? 
a. Design View 
b. Datasheet View 
c. Both of the above 
d. None of the above 
Ans: a. Design View 
 
99. Which field property in Base can be used to store data in a specific format, such as a phone 
number? 
a. Auto Value 
b. Length 
c. Default Value 
d. Format 
Ans: d. Format 
 
100. What is the default value of the field property ‘Entry Required’ in Base? 
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a. Yes 
b. No 
Ans: b. No 
 
101. To arrange the data in ascending or descending order, first select the column(s) and then click on 
which button? 
a. View 
b. Save 
c. Arrange 
d. Sort 
Ans: d. Sort 
 
102. When a primary key from one table appears in another table, it is called a ________. 
a. Composite Primary Key 
b. Secondary Key 
c. Foreign Key 
d. Main Key 
Ans: c. Foreign Key 
 
103. In which relationship, one of the table must have primary key column? 
a. One to Many 
b. One to One 
c. Many to Many 
d. Many to All 
Ans: a. One to Many 
 
104. Once the relationships applied on the tables cannot be removed. 
a. True 
b. False 
Ans: b. False 
 
105. To remove the relationship between tables, right-click on the relationship thread and select 
which option? 
a. Delete 
b. Remove 
c. Edit 
d. Clear 
Ans: a. Delete 
 
106. Which language is used to write a query in Open Office Base? 
a. VB 
b. SQL 
c. C 
d. Python 
Ans: b. SQL 
 
107. Which command is used to retrieve data from a table? 
a. Delete 
b. Create 
c. Select 
d. Insert 
Ans: c. Select 
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108. Can SELECT statement retrieve data from multiple tables? 
a. True 
b. False 
Ans: a. True 
 
109. Rajesh wants to display all the records from the table ‘student’. 
a. Select * student; 
b. Select # from student; 
c. Select from student; 
d. Select * from student; 
Ans: d. Select * from student; 
 
110. Which clause can be used with the SELECT SQL command to display records containing the 
same type of values? 
a. Order By 
b. Where 
c. Both a and b 
d. None of the above 
Ans: b. Where 
 
111. Which commands are used to add, modify, and delete records in a database table? 
a. Insert, Update, and Remove 
b. Insert, Update, and Delete 
c. Insert, Modify, and Delete 
d. Add, Update, and Delete 
Ans: b. Insert, Update, and Delete 
 
112. By default, in which order is data arranged using the ORDER BY clause in a database? 
a. Decreasing 
b. Alphabetical 
c. Increasing 
d. Descending 
Ans: c. Increasing 
 
113. Which clause of the SELECT statement helps to display specific data in a database? 
a. Where 
b. Between 
c. Order By 
d. None of the above 
Ans: a. Where 
 
114. What is the name of the interface in a user-specified layout that lets users view, enter, and 
change data directly in database objects such as tables? 
a. Query 
b. Form 
c. Report 
d. Table 
Ans: b. Form 
 
115. Aman created an object ‘X’ in Base to store the value in the form of rows and columns. What is 
‘X’? 
a. Table 
b. Row 
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c. Column 
d. Database 
Ans: a. Table 
 
116. Which of the following contains data of the same data type? 
a. Record 
b. Tuple 
c. Column 
d. All of the above 
Ans: c. Column 
 
117. Give an example of an open-source RDBMS. 
a. Microsoft SQL Server 
b. Microsoft Access 
c. Oracle 
d. OpenOffice Base 
Ans: d. OpenOffice Base 
 
118. What is the default length of the TINYINT data type? 
a. 1 
b. 2 
c. 3 
d. 4 
Ans: c. 3 
 
119. Which data type can store character/data up to the length specified by the user? 
a. Varchar 
b. Char 
c. Varchar_IgnoreCase 
d. All of the above 
Ans: d. All of the above 
 
120. Dhriti wants to store the details of students as well as their pictures in a table named “school”. 
Which data type is suitable for storing pictures? 
a. Boolean 
b. Binary 
c. Memo 
d. Varchar 
Ans: b. Binary 
 
121. Which data type stores hours, minutes, and second information? 
a. Date 
b. Time 
c. Stamptime 
d. Timer 
Ans: b. Time 
 

OBJECTIVE QUESTIONS (SET 02) 
 
1. A _________ is an organized collection of data. 
a. Database 
b. Digital Document 
c. Spreadsheet 
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d. None of the above 
Ans: a. Database 
 
2. A ________ is a software package that can be used for creating and managing databases. 
a. Database Management System 
b. Basedata Management System 
c. Database Manage System 
d. None of the above 
Ans: a. Database Management System 
 
3. A_________________ database management system is referred to as a relational model. 
a. DBMS 
b. RDBMS 
c. DB 
d. None of the above 
Ans: b. RDBMS 
 
4. Example of the database ________. 
a. Microsoft Access 
b. OpenOffice Base 
c. MySQL 
d. All of the above 
Ans: d. All of the above 
 
5. The database concept has evolved since the _______. 
a. 1980 
b. 1960 
c. 1955 
d. 1950 
Ans: b. 1960 
 
6. DBMS Stands for __________. 
a. Database Management System 
b. Database Manage System 
c. Data Manage System 
d. None of the above 
Ans: a. Database Management System 
 
7. A database management system is a software package with computer programs that controls the 
___________. 
a. Creation 
b. Maintenance 
c. Use of Database 
d. All of the above 
Ans: d. All of the above 
 
8. A database is an integrated collection of ___________. 
a. Data records 
b. Files 
c. Objects 
d. All of the above 
Ans: d. All of the above 
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9. A DBMS enables several user application programs to access the ________ database. 
a. Other Database 
b. Same Database 
c. Both a) and b) 
d. None of the above 
Ans: b. Same Database 
 
10. Data can be organized into __________. 
a. Flat File 
b. Relational 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
11. Data stored in a single table is known as __________. 
a. Flat File 
b. Relational 
c. Both a) and b) 
d. None of the above 
Ans: a. Flat File 
 
12. Data is stored in multiple tables, which are connected together via a common field. 
a. Flat File 
b. Relational 
c. Both a) and b) 
d. None of the above 
Ans: b. Relational 
 
13. __________ are dedicated computers that hold the actual databases and run only the DBMS and 
related software. 
a. Database Server 
b. Decided Server 
c. Web Server 
d. None of the above 
Ans: a. Database Server 
 
14. What are the advantages of database __________. 
a. Reduces Data Redundancy 
b. Sharing of Data 
c. Data Integrity 
d. All of the above 
Ans: d. All of the above 
 
15. When the same piece of data is stored in two or more locations, it is called ______________. 
a. Data Redundancy 
b. Data Integrity 
c. Data Consistency 
d. None of the above 
Ans: a. Data Redundancy 
 
16. _________ prevents creating multiple copies in the database. 
a. Data Redundancy 
b. Data Integrity 

 



                Page - 20 - 

c. Data Consistency 
d. None of the above 
Ans: a. Data Redundancy 
 
17. __________ means that the data is accurate and consistent in the database. 
a. Data Redundancy 
b. Data Integrity 
c. Data Consistency 
d. None of the above 
Ans: b. Data Integrity 
 
18. Only authorized users should be allowed to access the database and their identity should be 
authenticated using a username and password known as ________. 
a. Data Redundancy 
b. Data Consistency 
c. Data Security 
d. None of the above 
Ans: c. Data Security 
 
19. Database Management System automatically takes care of ____________. 
a. Data Redundancy 
b. Backup and Recovery 
c. Data Security 
d. None of the above 
Ans: b. Backup and Recovery 
 
20. ___________ prevent multiple mismatching copies of the same data in the database and only 
valid data will be added in the database. 
a. Data Redundancy 
b. Backup and Recovery 
c. Data Consistency 
d. None of the above 
Ans: c. Data Consistency 
 
21. __________ in a table represents a set of information with the same structure in every row. 
a. Tuples 
b. Record 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
22. A __________ is the actual text, number, or date that you enter when adding data to your 
database. 
a. Values 
b. Table 
c. Boolean 
d. None of the above 
Ans: a. Values 
 
23. The unique field present in the table is called __________. 
a. Primary Key 
b. Candidate Key 
c. Foreign Key 
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d. None of the above 
Ans: a. Primary Key 
 
24. When the primary key is applied on multiple columns is known as __________. 
a. Primary Key 
b. Composite Primary Key 
c. Foreign Key 
d. None of the above 
Ans: b. Composite Primary Key 
 
25. By default if the primary key is not defined that column is known as __________. 
a. Primary Key 
b. Candidate Key 
c. Foreign Key 
d. None of the above 
Ans: c. Foreign Key 
 
26. __________ key can store multiple same records in the table. 
a. Primary Key 
b. Candidate Key 
c. Foreign Key 
d. None of the above 
Ans: c. Foreign Key 
 
27. The relationship between two tables where one table has one record and another table has many 
records is known as ___________. 
a. One-to-Many 
b. Many-to-Many 
c. Many-to-One 
d. None of the above 
Ans: a. One-to-Many 
 
28. SQL stands for _____________. 
a. Single Query Language 
b. Structured Query Language 
c. Semantic Query Language 
d. None of the above 
Ans: b. Structured Query Language 
 
29. A ____________ is a collection of data components organized in the form of vertical columns 
and horizontal rows. 
a. Table 
b. Fields 
c. Attributes 
d. None of the above 
Ans: a. Table 
 
30. A row also called a Record or _________ represents a single, data item in a table. 
a. Column 
b. Tuples 
c. Fields 
d. None of the above 
Ans: b. Tuples 
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31. You can create tables in the database using _________. 
a. Wizard 
b. SQL 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
32. ____________ are the basic building blocks of a database. 
a. Table 
b. Query 
c. Database 
d. None of the above 
Ans: a. Table 
 
33. _____________ are used to define the type of data that will be stored in the database. 
a. Data Types 
b. Data field 
c. Key Data 
d. None of the above 
Ans: a. Data Types 
 
34. What are the different types of data type available in OpenOffice base? 
a. Numeric Types 
b. Alphanumeric Types 
c. Binary Types & Date time 
d. All of the above 
Ans: d. All of the above 
 
35. __________ types are used for describing numeric values for the field used in the table of a 
database. 
a. Numeric Type 
b. Alphanumeric Type 
c. Boolean Type 
d. Date & Time 
Ans: a. Numeric Type 
 
36. ___________ data type can store 0 or 1 in the database. 
a. Boolean 
b. TinyInt 
c. Smalint 
d. BigInt 
Ans: a. Boolean 
 
37. What are the different numerical data types? 
a. Boolean 
b. Tinyint & Smallint 
c. Integer & Bigint 
d. All of the above 
Ans: d. All of the above 
 
38. ____________ data type can store UTF 8 Characters in the database. 
a. Longvarchar 
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b. Char 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
39. __________ is case sensitive data type in the database. 
a. Longvarchar 
b. Varchar_Ignorecase 
c. Varchar 
d. All of the above 
Ans: b. Varchar_Ignorecase 
 
40. ___________ data types in a database can be used for storing photos, music, video or any file 
format. 
a. Numerical Type 
b. Alphanumeric Type 
c. Binary Type 
d. Date & Time 
Ans: c. Binary Type 
 
41. Which datatype is used for storing date and time both in the database. 
a. Date 
b. Time 
c. Timestamp 
d. None of the above 
Ans: c. Timestamp 
 
42. A table is a collection of data elements that are organized using a vertical __________ and 
horizontal ___________ model. 
a. Column & Row 
b. Row & Column 
c. Column & Column 
d. Row & Row 
Ans: a. Column & Row 
 
43. A ________ is a collection of data values of a specific type, one for each row of a table. 
a. Column 
b. Row 
c. Cell 
d. None of the above 
Ans: a. Column 
 
44. In a table, a __________ represents a single data item. 
a. Row 
b. Truple 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
 
45. _____________ are used to identify which type of data we are going to store in the database. 
a. Datatype 
b. DataItem 
c. DataValue 
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d. DataCat 
Ans: a. Datatype 
 
46. There are ________ ways to create a table. 
a. 1 
b. 2 
c. 3 
d. 4 
Ans: b. 2 
 
47. Field properties can be set in both the ________ and _________ . 
a. Length & Default Value 
b. Length & Entry 
c. Both a) and b) 
d. All of the above 
Ans: c. Both a) and b) 
 
48. By default the length of the numerical data type is _______. 
a. 05 
b. 10 
c. 20 
d. 30 
Ans: b. 10 
 
49. If the user does not specify a value for a field while putting values into the table, a 
_____________ value can be assigned to it. 
a. Default Value 
b. Length 
c. Format 
d. None of the above 
Ans: a. Default Value 
 
50. ________ means to arrange the data in either ascending order or descending order. 
a. Filter 
b. Sorting 
c. Arrangement 
d. None of the above 
Ans: b. Sorting 
 
51. ____________ is used to maintain accuracy and consistency of data in a relationship. 
a. Referential data 
b. Referential Integrity 
c. Referential Value 
d. None of the above 
Ans: b. Referential Integrity 
 
52. In base, data can be linked between two or more tables with the help of ____________. 
a. Primary Key 
b. Foreign Key 
c. Both a) and b) 
d. None of the above 
Ans: c. Both a) and b) 
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53. Referential Integrity helps to avoid ____________. 
a. If you want to add a record in the related table and if there is no associated record available in the 
primary key table. 
b. Changing values in a primary if there are any dependent records in the related table. 
c. Deleting records from a primary key table if there are any matching related records available in the 
associated table. 
d. All of the above 
Ans: d. All of the above 
 
54. The connection or association between two or more table is known as ____________ 
a. Connection 
b. Relationship 
c. Connector 
d. None of the above 
Ans: b. Relationship 
 
55. Relationships between tables help to __________. 
a. Save time 
b. Reduce data-entry errors 
c. Summarize data from related tables 
d. All of the above 
Ans: d. All of the above 
 
56. What are the different types of relationships which can be created in table___________. 
a. One to One 
b. One to Many or Many to One 
c. Many to Many 
d. All of the above 
Ans: d. All of the above 
 
57. ___________ is the relationship, where both the tables must have primary key columns. 
a. One to One 
b. One to Many or Many to One 
c. Many to Many 
d. All of the above 
Ans: a. One to One 
 
58. ____________ in this relationship, one of them must have a primary key column. 
a. One to One 
b. One to Many or Many to One 
c. Many to Many 
d. All of the above 
Ans: b. One to Many or Many to One 
 
59. A ____________________ is a standard for commands that define the different structures in a 
database. 
a. Data Manipulation Language (DML) 
b. Data Definition Language (DDL) 
c. Both a) and b) 
d. None of the above 
Ans: b. Data Definition Language (DDL) 
 
60. A ______________ is a language that enables users to access and manipulate data in a database. 
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a. Data Manipulation Language (DML) 
b. Data Definition Language (DDL) 
c. Both a) and b) 
d. None of the above 
Ans: a. Data Manipulation Language (DML) 
 
61. A ____________ is a subset of DML that just deals with information retrieval. 
a. Query Language 
b. Structure Language 
c. Both a) and b) 
d. None of the above 
Ans: a. Query Language 
 
62. A popular data manipulation language is _________________. 
a. Structured Query Language 
b. Machine Level language 
c. Low level language 
d. None of the above 
Ans: a. Structured Query Language 
 
63. There are __________ types of Relationships in a table. 
a. 2 
b. 3 
c. 4 
d. 5 
Ans: b. 3 
 
64. _________ means that the query hides certain data and displays only what you want to see based 
on the criteria you provided. 
a. Filtering 
b. Sort 
c. Query 
d. All of the above 
Ans: a. Filtering 
 
65. A __________ statement used to display the zero record or multiple record from the database. 
a. Select 
b. Order By 
c. Where 
d. None of the above 
Ans: a. Select 
 
66. To retrieve all the columns in a table the syntax is ___________. 
a. Select $ from <tablename>; 
b. Select * <tablename>; 
c. Select * from <tablename>; 
d. Select % <tablename>; 
Ans: c. Select * from <tablename>; 
 
67. To display the records containing the same type of values _________ clause can be used with the 
Select SQL Command. 
a. Where 
b. More 

 



                Page - 27 - 

c. Order 
d. None of the above 
Ans: a. Where 
 
68. Shortcut key for executing query in OpenOffice base. 
a. F2 
b. F3 
c. F4 
d. F5 
Ans: d. F5 
 
69. To view records in ascending order from a database. 
a. Unorder by 
b. Order by 
c. Acc by 
d. Decc by 
Ans: b. Order by 
 
70. ___________ statement is used for modifying records in a database. 
a. Modify 
b. Update 
c. Delete 
d. Select 
Ans: b. Update 
 
 
71. The syntax of the update statement is _____________. 
a. Update <tablename> set <columnname = value> where <condition>; 
b. Update <tablename> set <condition> where <condition>; 
c. Modify <tablename> set < value> where <condition>; 
d. Modify <tablename> set <columnname = value> where <condition>; 
Ans: a. Update <tablename> set <columnname = value> where <condition>; 
 
72. A _______ helps the user to systematically store information in the database. 
a. Form 
b. Table 
c. Report 
d. None of the above 
Ans: a. Form 
 
73. A ________ enables users to view, enter, and change data directly in database objects such as 
tables. 
a. Table 
b. Form 
c. Report 
d. None of the above 
Ans: b. Form 
 
74. _________ statement retrieves zero or more rows from one or more database tables or database 
views. 
a. Select 
b. Update 
c. Delete 
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d. None of the above 
Ans: a. Select 
 
75. By default, data is arranged in _______ order using ORDER BY clause. 
a. Ascending 
b. Descending 
c. Both a) and b) 
d. None of the above 
 
Ans:  
a. Ascending 
76. __________ statement is used for modifying records in a database. 
a. Select 
b. Update 
c. Delete 
d. None of the above 
Ans: b. Update 
 
77. To remove one or more records from a database, use the _________ statement. 
a. Select 
b. Update 
c. Delete 
d. None of the above 
 
Ans:  
c. Delete 
Session 5: Create Forms and Reports using Wizard 
78. A __________ provides the user a systematic way of storing information into the database. 
a. Query 
b. Form 
c. Table 
d. None of the above 
Ans: b. Form 
 
79. __________ will help you to display summarized data from the database. 
a. Report 
b. Form 
c. Table 
d. None of the above 
Ans: a. Report 
 
80. To create a form you need to select the _________ option available under the Database section. 
a. Form 
b. Query 
c. Report 
d. All of the above 
Ans: a. Form 
 
81. A ______ helps to collect specific information from the pool of data in the database. 
a. Form 
b. Query 
c. Report 
d. All of the above 
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Ans: b. Query 
 
82. ________ is used to display the summary of data. 
a. Form 
b. Query 
c. Report 
d. All of the above 
Ans: c. Report 
 
83. _________ are the interfaces with which the user interacts. 
a. Form 
b. Query 
c. Report 
d. All of the above 
Ans: a. Form 
 
84. Data from multiple tables can be stored in _______. 
a. Data system 
b. Database 
c. Datatype 
d. None of the above 
Ans: b. Database 
 
85. Which data type is suitable for storing values for ‘date of birth’ field? 
a. Time 
b. Date 
c. Both of the above 
d. Timestamp 
Ans: b. Date 
 
86. Which data type is most suitable for storing a very large amount of data? 
a. LongVarchar or Memo 
b. Char 
c. Varchar 
d. Varchar_IgnoreCase 
 
Ans:  
a. LongVarchar or Memo 
87. Identify the odd one out. 
a. Binary Types 
b. Date & Day Type 
c. Numeric Types 
d. Alphanumeric Types 
Ans: b. Date & Day Type 
 
88. What does a single data item in a table represent? 
a. Columns 
b. Attribute 
c. Rows 
d. Field 
Ans: c. Rows 
 
89. Which toolbar helps us move from one record to another in a form in a database? 
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a. Formatting Toolbar 
b. Image Toolbar 
c. Standard Toolbar 
d. Form Navigation Toolbar 
Ans: d. Form Navigation Toolbar 
 
90. What is the correct query to increase the salary of all employees by Rs.10000 in a table named 
Employee with a column name of Salary? 
a. Update Employee set Salary = Salary + 10000; 
b. Update * Employee set Salary = Salary + 10000. 
c. Update table Employee set Salary = Salary + 10000; 
d. Update table Employee set Salary = 10000; 
Ans: a. Update Employee set Salary = Salary + 10000; 
 
91. Which query will display the details of all the students in increasing order of Roll number? 
a. Select * from student order by ‘Rollno’; 
b. Select * student order by ‘Rollno’; 
c. Select all from student order by ‘Rollno’; 
d. Select * from student orderby ‘Rollno’; 
Ans: a. Select * from student order by ‘Rollno’; 
 
92. Which clauses can be used with the SELECT statement? 
a. Order by Clause 
b. Where clause 
c. Both a) and b) 
d. None of the above 
 
Ans:  
c. Both a) and b) 
93. In which relationship, no table has the primary key column? 
a. Many to One 
b. One to One 
c. Many to Many 
d. One to Many 
Ans: c. Many to Many 
 
94. Referential integrity refers to the _______________ between tables. 
a. communication 
b. consistency 
c. relationship 
d. joining 
Ans: c. relationship 
 
95. Which field property in Base must be set to “Yes” in order to require a value to be entered in a 
field? 
a. Entry Required 
b. Auto Value 
c. Format 
d. Length 
 
Ans:  
a. Entry Required 
96. In which view can field properties be set in Base? 
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a. Design View 
b. Datasheet View 
c. Both of the above 
d. None of the above 
Ans: a. Design View 
 
97. Which of the following is a benefit of using a database management system? 
a. Improved data security 
b. Improved data accessibility 
c. Improved data consistency 
d. All of the above 
Ans: d. All of the above 
 
98. Which of the following is NOT a type of database model? 
a. Relational 
b. Object-oriented 
c. Hierarchical 
d. Procedural 
Ans: d. Procedural 
 
99. Which of the following is an example of an open-source RDBMS? 
a. Oracle 
b. Microsoft Access 
c. OpenOffice Base 
d. Microsoft SQL Server 
Ans: c. OpenOffice Base 
 
100. What is the purpose of a report in a database? 
a. Report is used to display information. 
b. Report is systematic way of storing information into the table. 
c. Both a) and b) 
d. None of the above. 
Ans: a. Report is used to display information. 
 

SHORT ANSWER TYPE QUESTIONS 
 

1. What is database? Give an example. What does DBMS stand for? 
Ans. A collection of related information organised as tables is known as database e.g. INGRES, 
MySQL etc. DBMS stands for DataBase Management System. It is a computer-based record 
keeping system. 
 

2. What is the difference between ‘Rows’ and ‘Columns’ in a table? 
Ans. In a table, rows are called records and columns are termed a fields. A row stores complete 
information of a record whereas column stores only similar data values for all records. 
 

3. What is field in database? Give an example. 
Ans. A field is an area, reserved for a specific piece of data. It is also known as attribute. e.g. 
Customer Name. 
  

4. Define forms and what is the need of using them? 
Ans. A form is a window or screen that contains numerous fields or spaces to enter data. Forms 
can be used to view and edit your data. It is an interface in user specified layout. 
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5. What does RDBMS stand for? 
Ans. RDBMS stands for Relational Database Management System. It is a type of DBMS that 
stores data in the form of relations (tables). 
 

6. How is data organized in a RDBMS? 
Ans. A relational database is a type of database. It uses a structure that allows us to identify and 
access datain relation to another piece of data in the database. Data in a relational database is 
organized into tables. 
 

7. Write the purpose of DBMS. 
Ans. DBMS is used to store logically related information at a centralised location. It facilitates 
data sharing among all the applications requiring it. 
 

8. Write any two uses of database management system. 
Ans. The two uses of database management system are as follows 
(i) DBMS is used to store data at a centralised location. 
(ii) It is used to minimise data redundancy and data inconsistency. 
 

9. Write any two advantages of using database. 
Ans. The two advantages of using database are as follows 
(i) It can ensure data security. 
(ii) It reduces the data redundancy. 
 

10. Give any two disadvantages of the database. 
Ans. The two disadiantages of the database are as follows 
(i) A database system creates additional complexity and requirements. 
(ii) A database system is a multi-user software, which is less efficient. 
 

11. A table named School (containing data of students of the whole school) is created, where 
each record consists of several fields including AdmissionNo (Admission Number), RollNo 
(Roll Number), Name. Which field out of these three should be set as the primary key and 
why? 
Ans. AdmissionNo should be set as primary key because admission numbers are unique for each 
and every students of the school, which is not possible in the case with RollNo and Name. 
 

12. Why Memo data type is preferred over Text data type for a field? 
Ans. When the length of the field is more than 255 characters. Text data type is not capable to 
store the project description because its length cannot be more than 255 characters so, Memo data 
type is preferred over Text data type. 
 

13. What happens when text is entered in a Number type field? 
Ans. When we enter text in a Number field and press Enter or press Tab key, it displays a 
message that ‘‘The value you entered does not match the Number data type in this column.’’ 
 

14. Damini is a programmer in an institute and is asked to handle the records containing 
information of students. Suggest any 5 fields name and their data type of students database. 
Ans.    
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15. Create a table of Student based on the following table instance.  

 
Ans. CREATE TABLE STUDENT (ID Integer, Name varchar (15), Stream_Id Integer); 
 

16. Write a SQL command to create the table BANK whose structure is given below. 

 
Ans. The SQL command to create a table as per given structure is as follows Mysql> CREATE 
TABLE BANK (ID Number integer (10) PRIMARY KEY, Name varchar (20), B date Date, 
Address varchar (50)); 
 

17. List datatypes available in Numeric data type. 
Ans. Datatypes available in numeric data type are TINYINT, SMALLCINT, MEDIUMINT, INT 
and BIGINT. 
 

18. Write one example of data field for which you would set the Required property to Yes. 
Ans. In a table, when we declare a field as a primary key, then the field’s Required property must 
be set to yes because in a primary key field, we need to enter data always. 
 

19. What is the purpose of Default Value field property? 
Ans. If there is a situation when you want to enter same value for all records. Then, to avoid 
typing the same thing many times, you can set as a Default Value property. 
 

20. Insert some information into a table COLLEGE, whose structure is given below. 

 
Ans. (i) Mysql>INSERT INTO COLLEGE (ROLL_NO, NAME, CLASS, BRANCH) VALUES 
(2, ‘VIKAS’,12, ‘SCIENCE’); (ii) Mysql>INSERT INTO COLLEGE (ROLL_NO, NAME, 
CLASS, BRANCH) VALUES (3, ‘RAJ’, 10, ‘SCIENCE’); 
 

21. What is the value of Entry Required field? 
Ans. The value of this property can be Yes or No. If entry required is Yes, the field cannot be 
absent i.e. should be necessarily present with a value. 
 

22. What is table? Also, define Candidate Key. 
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Ans. A table consists of a number of rows and columns. Each record contains values for the 
attributes. A candidate key is the smallest subset of the super key for which there does not exist a 
proper subset that is super key. Any candidate key can be choosen to uniquely identify the 
records, it is called primary key. 
 

23. What is Data Control Language? 
Ans. Data Control Language is used to create roles, permissions, and referential integrity as well 
it is used to control access to the database by securing it. These SQL commands are used for 
providing security to database objects. These commands are GRANT and REVOKE. 
 

24. What is Data Transaction Control Language? 
Ans. Transaction control commands manage changes made by DML commands. These SQL 
commands are used for managing changes affecting the data. These commands are COMMIT, 
ROLLBACK, and SAVEPOINT. 
 

LONG ANSWER TYPE QUESTIONS  
 

25. Describe any four major problems associated with sustainable development. 
Ans. Four problems associated with sustained development are as follows 
(i) The concept of sustainable development is subject to criticism. What, exactly, is to be 
sustained in a sustainable development? Any positive rate of exploitation of a non-renewable 
resource will eventually lead to exhaustion of Earth’s final stock. 
(ii) Turning the concept of sustainability into policy raises questions about how to assess the well-
being of present and future generations. The issue is more complicated because our children do 
not just inherit environmental pollution and resource depletion, but also enjoy the fruits of our 
labour, in the forms of education, skills, and knowledge (i.e. human capital), as well as physical 
capital. 
(iii) Poor management of natural resources, combined with growing economic activities, will 
continue to pose serious challenges to environment. The problem arises because people, 
institutions and governments have failed to evolve mechanism and policies to strike a balance 
between development and conservation of resources and preservation of environment. 
(iv) The commonly held view that greater economic activity necessarily hurts the environment, is 
based on static assumptions about technology, tastes and environmental investments. In reality, 
the relationships between inputs and outputs and the overall effects of economic activities on the 
environment, are continually changing. 
 

26. Mention the main principles of sustainable development. 
Ans. Main principles of sustainable development are 
(i) Respect and care for all forms of life. 
(ii) Improving the quality of human life. 
(iii) Minimising the depletion of natural resources. 
(iv) Conserving the Earth’s vitality and diversity. 
(v) Enabling communities to care for their own environment. 
(vi) Changing personal attitude and practices towards the environment. 
 

27. Why is it important to adopt sustainable development? Explain. 
Ans. A three-year study using satellites and aerial photography undertaken by the United Nations 
long ago warned that the environment had deteriorated so badly that it was ‘critical’ in many of 
eighty-eight countries, investigated. In view of all these findings and problems, sustainable 
development acquires much importance. 
Nature and mankind live and die together. 
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The Earth’s vital signs reveal a patient in declining health. We need to realise our ethical and 
moral obligations to the mother Earth. Human beings are caretakers of the planet and responsible 
trustees of the legacy of future generations. 
Due to the realisation of importance of sustainable development, now there is a transcending 
concern for survival of the people and planet. We need to take a holistic view of the very basis of 
our existence. The environmental problem does not necessarily signal our demise, rather it is our 
passport for the future. To save ourselves and our future generations from catastrophe, we require 
to take a holistic view, an ecological view, seeing the world as an integrated whole, rather than a 
dissociated collection of parts. 
 

28. Describe the meaning and importance of sustainable development. 
Ans. Sustainable development refers to the process of economic development where resources are 
used judiciously to satisfy needs of not only present generation but also to conserve them for the 
use of future generations. Sustainable development takes place without depleting the present 
natural resources. 
The importance of sustainable development is discussed below 
(i) It helps to conserve and make use of means and resources for the maximum benefit without 
wastage. 
(ii) It awares the people about the responsibility to use and preserve natural resources. 
(iii) It creates the feeling that natural resources are the common property of all and nobody can 
use the property according to his personal will. It helps to conserve natural and social 
environment. 
(iv) People’s participation  is to be given  priority in development work in order to achieve the 
aim of sustainable development. 
(v) It attempts to create the concept of maintaining the present work for the future and conserving 
natural resources for future generation. 
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DATABASE MANAGEMENT SYSTEM 
 

REVISION NOTES 
 
A database is an organized collection of data. It is considered as a container of information. In the 
manual system, you would maintain several files with different bits of information while in the 
computerized system you would use database programs such as Microsoft Access, OpenOffice.org 
Base, and MySQL, to organize the data as per your business need. 
 
A database is basically a computerbased record/data/information keeping system. Data is raw, 
unorganised facts and entities relevant to the user need to be processed such as a digital representation 
of text, numbers, graphical images or sound. The data are stored in such a way that, they are 
independent of the programs used by the people for accessing the data.  
 
Database can be created with the help of following structures 

 
 
DATABASE MANAGEMENT SYSTEM (DBMS): 
DBMS is a collection of programs that enables users to create, maintain database and control all the 
access to the database. It is a computer based record keeping system. 
The primary goal of the DBMS is to provide an environment that is convenient and efficient for user 
to retrieve and store information. It acts as an interface between the application program and the data 
stored in the database. 
DBMS is a software package that manages database. e.g. MySQL, INGRES, MS-Access, etc. 
DBMS is actually a tool that is used to perform any kind of operation on data in database. It also 
maintains data consistency in case of multiple users. The purpose of a DBMS is to bridge the gap 
between information and data. 
 
Data can be organized into two types: 
 Flat File: Data is stored in a single table. Usually suitable for less amount of data. 
 Relational: Data is stored in multiple tables and the tables are linked using a common field. 

Relational is suitable for medium to large amount of data. 
 
DATABASE SERVERS 
Database servers are dedicated computers that hold the actual databases and run only the DBMS and 
related software. 
 
ADVANTAGES OF A DATABASE/DBMS 
The centralised nature of database system provides several advantages, which overcome the 
limitations of the conventional file processing system. These advantages are as follows 
1. Reduce Data Redundancy: Redundancy means ‘duplication of data’. This eliminates the 

replication of data item in different files, extra processing required to face the data item from a 
large database. This also ensures data consistency and saves the storage space. 

2. Enforcing Data Integrity: It means that, the data contained in the database is accurate and 
consistent. Integrity constraints or consistency rules can be applied to database, so that the correct 
data can be entered into the database. 

3. Data Sharing: The data stored in the database can be shared among multiple users or application 
programs. 
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4. Data Security: The DBMS ensures that the access of database is done only through an authorised 
user. 

5. Ease of Application Development: The application programmer needs to develop the application 
programs according to the user’s needs. 

6. Backup and Recovery:  The DBMS provides backup and recovery sub-system that is responsible 
to recover data from hardware and software failures. 

7. Multiple Views of Data: A view may be the subset of database. Various users may have different 
views of the database itself. 

8. Enforced Standards: It can ensure that, all the data follow the applicable standards. 
9. Data Independence: System data descriptions are independent from the application programs. 
 
DISADVANTAGES OF A DATABASE/DBMS 
There are many advantages of database, but database also have some minor disadvantages. These 
disadvantages are as follows 
1. Cost of Hardware and Software: Through the use of a database system, new costs are generated 

due to additional hardware and software requirements. 
2. Complexity: A database system creates additional complexity and requirements. 
3. Database Failures: If database is corrupted due to power failure or it is corrupted on the storage 

media, then our valuable data may be lost or the system will stop working. 
4. Lower Efficiency: A database system is a multi-user software, which is less efficient. 
 
SOME KEY FEATURES OF A DATABASE: 
1. A database can have one or many tables. An address book example is a very simple one, in real 

world there are many more details involved.  
2. Each table in a database contains information about one type of item. So, a database is a container 

that holds tables and other objects and manages how they can be used. 
3. A record uniqueness in every table. It is important to be able to distinguish between different 

items having duplicate values. Uniqueness helps to avoid accidental duplication of records caused 
by user or computer error.  

4. Every database table should have one or more fields designated as key. You can assign a unique 
value to this key for differentiating records that may have similar names or addresses. 

 
COMPONENTS OF A DATABASE 
A database consists of several components. Each component plays an important role in the database 
system environment. 
The major components of database are as follows 
 Data: It is raw numbers, characters or facts represented by value. Most of the organisations 

generate, store and process large amount of data. The data acts as a bridge between the hardware 
and the software. Data may be of different types such as User data, Metadata and Application 
Metadata. 

 Software: It is a set of programs that lies between the stored data and the users of database. It is 
used to control and manage the overall computerised database. It uses different types of software 
such as MySQL, Oracle, etc. 

 Hardware: It is the physical aspect of computer, telecommunication and database, which consists 
of the secondary storage devices such as magnetic discs, optical discs, etc., on which data is 
stored. 

 Users: It is the person, who needs information from the database to carry out its primary business 
responsibilities. 

 
TYPES OF USERS 
The various types of users which can access the database system are as follows 
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 Database Administrator (DBA): A person, who is responsible for managing or establishing 
policies for the maintenance and handling the overall database management system is called 
DBA. 

 Application Programmer: A person, who writes application programs in programming 
languages to interact and manipulate the database are called application programmer. 

 End-user: A person, who interacts with the database system to perform different operations on 
the database like inserting, deleting, etc., through menus or forms is called end-user. 

 
RELATIONAL DATABASE MANAGEMENT SYSTEM (RDBMS) 
RDBMS is a type of DBMS that stores data in the form of relations (tables). Relational databases are 
powerful, so they require few assumptions about how data is related or how it will be extracted from 
the databases. 
An important feature of relational database system is that a single database can be spread across 
several tables. Base, Oracle, DB2, SAP, Sybase, ASE, Informix, Access, etc., are the examples of 
RDBMS. 
 
WORKING OF A DATABASE 
Database is created to operate large quantities of information by input, store, retrieve and manage the 
information. It is a centralised location which provides an easy way to access the data by several 
users. It does not keep the separate copies of a particular data file still a number of users can access 
the same data at the same time. 

 
 

As the diagram shows, DBMS works as an interface between the user and the centralised database. 
First, a request or a query is forwarded to a DBMS which works (i.e. a searching process is started on 
the centralised database) on the received query with the available data and if the result is obtained, it 
is forwarded to the user. 
If the output does not completely fulfill the requirements of the user, then a rollback (again search) is 
done and again search process is performed until the desired output is obtained. 
 
DATA INTEGRITY 
Data Integrity ensures the accuracy, reliability and consistency of the data during any operation. 
Each type of data integrity are as follows 
 Entity Integrity: It defines the primary key of a table. Entity integrity rule on a column does not 

allow duplicate and null values. 
 Domain Integrity: It defines the type, range and format of data allowed in a column. Domain 

integrity states that all values in a column must be of same type. 
 Referential Integrity: It defines the foreign key concepts. Referential integrity ensures that data 

in related tables remains accurate and consistent before and after changes. 
 User Defined Integrity: If there is some business requirements which do not fit any above data 

integrity then user can create own integrity, which is called user defined integrity. 
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KEY FIELDS 
The key is defined as the column or the set of columns of the database table which is used to identify 
each record uniquely in a relation. If a table has id, name and address as the column names, then each 
one is known as the key for that table. The key field is a unique identifier for each record. 
 
TYPES OF KEY FIELDS 
The following are the types of key fields available in the DBMS system 
Primary Key: A field or a set of fields that uniquely identify each record in a table is known as a 
primary key. Each relation has atleast one column for which each row that must have a unique value. 
Only one column attribute can be defined as a primary key for each table. 
A primary key must possess the following properties 
 It does not allow null values. 
 It has a unique index. 
 It allows numbers and text both. 

e.g. In the student’s table, StudentId works as a primary key because it contains Ids which are unique 
for each student. Note: Data cannot be primary key. 
 
Candidate Key: The set of all attributes which can uniquely identify each tuple of a relation are 
known as candidate keys. Each table may have one or more candidate keys and one of them will 
become the primary key. The candidate key of a relation is always a minimal key. e.g. Column 
StudentId and the combination of FirstName and LastName work as the candidate keys for the 
student table. 
A candidate key must possess the following properties 
 For each row, the value of the key must uniquely identify that row. 
 No attribute in the key can be discarded without destroying the property of unique 

identification. 
 
Alternate Key: From the set of candidate keys after selecting one of the keys as a primary key, all 
other remaining keys are known as alternate keys. e.g. From the candidate keys (StudentId, 
combination of FirstName and LastName), if StudentId is chosen as a primary key, then the 
combination of FirstName and LastName columns work as alternate keys. 
 
Foreign Key: A field of a table (relation) that references the primary key of another table is referred 
to as foreign key. The relationship between two tables is established with the help of foreign key. A 
table may have multiple foreign keys and each foreign key can have a different referenced table. 
Foreign keys play an essential role in database design, when tables are broken apart, then foreign keys 
make it possible for them to be reconstructed. e.g. CourseId column of student table (reference table) 
works as a foreign key as well as a primary key for course table (referenced table). 
 
Data in a relational database management system (RDBMS) is organized in the form of tables. 
 
DATABASE OBJECTS : 
1) Table: A table is a set of data elements (values) that is organized using a model of vertical 

columns and horizontal rows. A table has a defined number of columns, but can have any number 
of rows. Each row is identified by the values appearing in a particular column identified as a 
unique key index or the key field. 

2) Columns or Fields or Attributes: A column is a set of data values of a particular simple type, 
one for each row of the table. The columns provide the structure according to which the rows are 
composed. For example, cFirstName, or cLastName are fields in a row. 

3) Rows or Records or Tuples: A row also called a Record or Tuple represents a single data item in 
a table. Each row in a table represents a set of related data, and every row in the table has the 
same structure. 
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CREATING DATABASE USING OPENOFFICE: 
1) Open the OpenOffice Base Application by Clicking on Start>Programs>OpenOffice.org 

4>OpenOffice.org Base. 
2) Create a new database by selecting the option Create a new database 
3) Database wizard appear. Click Finish. The Save As dialog box appears. 
4) Specify a name for the database in the File name: field and click Save. 

 
CREATE TABLES: 
Tables are the basic building blocks of a database. You store the data in the database in the form of 
tables. 
There are different ways to create a table: 
 
a) Use Wizard To Create Table:  
The following are the steps to create a table: 
1) Click on Tables > Use Wizard to Create Table 
2) Click the Select Fields > Choose Category > Select the table > Click on Next Button. 
3) Select the fields as per the requirements. Click on Next button 
4) Set the data types and properties of the selected fields. Click on Next Button 
5) Set the Primary Key and Click on Next Button 
6) Window to rename the table will open. A user can either go ahead with the same table name or 

can change it. 
7) Click on Finish to insert the data in the table. 
 
b) Creating table using Design View 
1) Click on Create Table in Design View. 
2) Specify the field name and data type of the field. 
3) Save the table by clicking on File > Save 
4) Specify the table name. The default name is Table1. Click OK. 
5) An alert appears, if there is no primary key in the table. 
6) Click yes and set the primary key and finally save the table. 
 
DATA TYPES: 
Datatypes are used to identify which type of data (value) we are going to store in the database. Data 
types in OpenOffice base are broadly classified into five categories listed below. 
 Numeric Types 
 Alphanumeric Types 
 Binary Types 
 Date time 
 Other Variable types 

 
Numeric Types: Numeric data types in a database can be used for storing information such as mobile 
number, roll number, door number etc. The different types of numeric data types available are listed 
here. 
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Alphanumeric Types: This data type is used to store information which has alphabets as well as 
numbers for example address, book summary field etc. The different types of Alphanumeric Types 
available are listed here. 

 
Binary Types: Binary data types are used for storing data in binary formats. Binary data types in a 
database can be using for storing photos, music files, etc. 

 
Date time: Date time data types in a database can be used for storing information such as date of 
birth, date of admission, date of product sale, etc. 
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OTHER DATA TYPES: 

 
 
PERFORM OPERATIONS ON TABLE 
In OpenOffice Base, data is stored in tables which can be inserted, modified and removed using 
appropriate options. 
 
Inserting Data In The Table:  
To insert the data in the table, follow the steps: 
1) Select the table > Double click on it. 
2) The table will open in Datasheet View. 
3) Insert the required number of records in Datasheet View. 
 
Editing Records In The Table:  
To edit the data in the table, follow the steps: 
1) Select the table > Double click on it. 
2) The table will open in Datasheet View. 
3) Edit the required record in Datasheet View. 
 
Deleting Records From The Table:  
To remove the data from the table, follow the steps: 
1) Select the table > Double click on it. 
2) The table will open in Datasheet View. 
3) Select the data > right click on selected data > select the Delete option 
 
FIELD PROPERTIES: 
To set the field properties: Select the table > Right click > Select the option Edit > the table will open 
in Design View. 
In design view there are different properties of fields according to the data type set for each field. 
 
The properties of numeric type data is given below : 
1) AutoValue – if set to yes then field will get the auto numeric values. 
2) AutoValue – if set to yes then field will get the auto numeric values. 
3) Length – By default length of the field is 10 but the size of the field can be set to maximum 

length. 
4) Default Value – A default value can be set for a field if user don’t provide any value while 

entering the values in the table. 
5) Format – This property helps to set the format of the data entered in the field such as 91-222-333. 
 
The properties of character type data is shown below : 
1) Entry Required – if set to yes then it will be must to insert the value in the field. 
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2) Length – By default length of the field is 10 but the size of the field can be set to maximum length. 
3) Default Value – A default value can be set for a field if user don’t provide any value while 
entering the values in the table. 
4) Format – This property helps to set the format of the data entered in the field such as 91-222-333. 
 
SORTING DATA: Sorting means to arrange the data in either ascending order of descending order. 
 
REFERENTIAL INTEGRITY:  
Referential integrity is used to maintain accuracy and consistency of data in a relationship. In Base, 
data can be linked between two or more tables with the help of primary key and foreign key 
Referential integrity helps to avoid: 
1) Adding records to a related table if there is no associated record available in the primary key table. 
2) Changing values in a primary if any dependent records are present in associated table(s). 
3) Deleting records from a primary key table if there are any matching related records available in 

associated table(s). 
 
CREATING AND EDITING RELATIONSHIPS BETWEEN TABLES: 
A relationship refers to an association or connection between two or more tables. Relationships 
between tables helps to: 
 Save time as there is no need to enter the same data in separate tables. 
 Reduce data-entry errors. 
 Summarize data from related tables. 

 
You can create a relationship between any two tables by selecting Relationships option from the 
Tools menu. 
There are three types of relationships which can be created in tables: 
1) ONE to ONE Relationship: In this relationship, both the tables must have primary key columns. 
2) One to Many Relationship: In this relationship, one of the table must have primary key column. 
3) Many to Many Relationship: In this relationship, no table has the primary key column. 
 
REMOVE THE RELATIONSHIPS: 
The relationships applied on the tables can be removed also with the help of Delete option. Right 
Click on the relationship thread and select Delete option. 
 
RETRIEVE DATA USING QUERY 
A query is to collect specific information from the pool of data. A query helps us join information 
from different tables and filter that information 
OR 
Queries are commands that are used to define the data structure and also to manipulate the data in the 
database. 
 
There are two types of languages:- 
DDL (Data Definition Language) 
DML (Data Manipulation Language) 
 
DATA DEFINITION LANGUAGE (DDL) 
DDL is used to define the structure of your tables and other objects in the database. In DBMS, it is 
used to specify a database schema as a set of definitions (expressed in DDL). In SQL, the Data 
Definition Language allows you to create, alter and destroy database objects. Basically, a data 
definition language is a computer language used to create and modify the structure of database 
objects in a database. These database objects include views, schemes, tables, indexes, etc. 
This term is also known as data description language in some contexts, as it describes the fields and 
records in a database table. 
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Data definition language consists of various commands that lets you to perform some specified tasks 
as follows 
1) CREATE: Uses to create objects in the database. 
2) ALTER: Uses to alter the structure of the database table. This command can add up additional 

columns, drop existing columns and even change the data type of columns involved in a database 
table. 

3) DROP: Uses to delete objects from the database. 
4) TRUNCATE: Uses to remove all records from a table. 
5) RENAME: Uses to rename an object. 
 
DATA MANIPULATION LANGUAGE (DML) 
DML provides various commands used to access and manipulate data in existing database. This 
manipulation involves inserting data into database tables, retrieving existing data, deleting data from 
existing tables and modifying existing data. 
DML is mostly incorporated in SQL database. The basic goal of DML is to provide efficient human 
interaction with the system. 
The DMLs are of two types 
Procedural DMLs These require a user to specify what data is needed and how to get it. 
Non-Procedural DMLs These require a user to specify what data is needed without specifying how to 
get it. 
Various data manipulation language commands are as follows 
1) SELECT: Used to retrieve data from a database. 
2) INSERT: Used to insert data into a table. 
3) UPDATE: Used to update existing data within a table. 
4) DELETE: Used to delete all records from a table, the space of the records remains. 
5) LOCK TABLE: Used to control concurrency. 
 
SELECT STATEMENT : 
A SELECT statement retrieves zero or more rows from one or more tables. SELECT is the most 
commonly used Data Manipulation Language(DML) command. To retrieve all the columns in a table 
the syntax is: SELECT * FROM <Table Name>; 
 
For example, if you want to display all the data from table emp (short form of employee), the 
command is 
 
Select * from emp; 
 
The SELECT statement has many optional clauses: 
 WHERE specifies which rows to retrieve. 
 ORDER BY specifies an order in which to return the rows. 

for example : Select * from emp where name = “Ravi”; 
 
The above query will show result of a particular employee named “Ravi”. 
Select * from emp order by Salary; 
The above query will show all the records of table emp according to ascending order of column 
Salary. 
 
PERFORMING CALCULATIONS : 
In Base, simple calculations can be done on the data using arithmetic operators. Example: 
1) To display the salary of all the employees after incrementing by 1000 then the following SQL 
command will be executed in Base. (Fields of table Employee are EmployeeID, FirstName, Salary) 
Select “EmployeeID”, “FirstName”, “Salary” +1000 from “Employee”; 
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2) To display the salary of all the employees after decreasing by 10000 then the SQL command will 
be: 
Select “EmployeeID”, “FirstName”, “Salary” – 10000 from “Employee”; 
3) To display the salary of all the employees after incrementing it as twice the amount of present 
salary, then the SQL command will be . 
Select “EmployeeID”, “FirstName”, “Salary” * 2 from “Employee” 
 
UPDATE STATEMENT : 
Update statement is used for modifying records in a database. The general syntax of the update 
statement is as follows: 
UPDATE <table name> SET <Column name > = value [WHERE <Condition>]; 
 
for example : 
1) To increase(update) the salary of employee “Ravi” by Rs 2000 (in table Employee)then the SQL 
command will be: 
Update Employee set Salary = Salary + 2000 Where FirstName = “Ravi”; 
 
CREATE FORMS AND REPORTS USING WIZARD 
FORM: A form provides the user a systematic way of storing information into the database. It is an 
interface in a user specified layout that lets users to view, enter, and change data directly in database 
objects such as tables. 
 
Creating Form Using Wizard : Steps To Create Form Using Wizard are : 
1) Click Use Wizard to Create Form… option under Tasks group. The Form Wizard dialog box 

appears. 
2) Select selective fields to be sent onto the form by selecting the field name and clicking >button 

and click Next. 
3) Select the option Add Subform if you need to insert the contents in the table in a separate form 

and click Next. 
4) Arrange selected fields in a form and click Next. 
5) Select the data entry mode and click Next. 
6) Specify the styles to be used in the form and click Next. 
7) Specify the name of the form. Click Finish. 
 
REPORT: A report helps to display the data in a summarized manner. It is used to generate the 
overall work outcome in a clear format. 
 
Creating Reports using wizard : Steps To Create Report Using Wizard are : 
1) Click on Use Wizard to Create Report… option available under Tasks. 
2) Select all the table fields by selecting the >> button. 
3) Redefine the label of the fields in the reports or else you can set the default name and click Next. 
4) Define grouping for the fields of the table if required and click Next 
5) Sort the field in the report by selecting the appropriate field name and sorting method(if required) 

and click Next. 
6) Select the layout of the report and click Next. 
7) Define a name for the report and click Finish. 
 
 

 
 

 



Chapter 13. Health, Safety and Security at Work Place 

A. Multiple choice questions 

1. Workplace safety is essential in organization ____________. 

(a) to avoid the accident and injury   (b) to increase the productivity  

(b) to improve the work environment   (d) All of the above 

2. Which of the following is not mandatory to keep the good health of an employee?  

(a) Cleanliness  (b) Food court   (c) Clean and fresh air  (d) Clean washroom 

3. The security department is not responsible for __________. 

(a) personal safety     (b) computer system and equipment safety  

(c) electrical safety     (d) personal belongings 

4. The proper security procedures will increase ____________. 

(a) liabilities  (b) insurance   (c) business revenue   

(d) operational charges of the company 

5. Which kind of hazards can occur in IT industry?  

(a) Biological  (b) Chemical   (c) Physical    (d) Ergonomic 

6. Which of the following can cause hazards while using computers?  

(a) Poor sitting postures or excessive duration of sitting in one position  

(b) Lifting heavy object  

(c) Mishandling of tools and equipment  

(d) Improper handling of office equipment 

7. Which of the following statements is likely to result in an injury to the operator?  

(a) Selecting the right tool for the job  (b) Wearing safety goggles or glasses  

(c) Using a tool with loose handles   (d) Keeping cutting tools sharp 

8. What are the potential cause of hazards at workplace?  

(a) Poor ventilation  (b) Poor lighting  (c) Poor housekeeping  (d) All of the above 

 

B. Fill in the blanks 

1. Health of  an  employee  is  the  state  of  the  physical, mental and social well being. 

2. The work places must be cleaned in the morning before the people start working.  



3. A proper air conditioning provide clean and cool air at the workplace.  

4. A fresh food cafeteria helps to maintain the health of the employee.  

5. The work environment of the organization must be safe and free from hazard and risk. 

6. The proper security procedures will increase the business revenue and will reduce the 

operational charges of the company.  

7. Injuries and illness of the employees is prevented through national policy on Occupational 

health and safety. 

8. Physical hazards occurs due to physical work environment. 

9. Electrical hazards mostly caused due to coming in direct contact with live wires, or indirect 

contact through a Conductor.  

10. Hazards    while    using    computers    occurs    due    to poor sitting posture or excessive  

duration of sitting  in one position. 

 

C. State whether the following statements are True or False 

1. The employer and employees are responsible for workplace safety.               True 

2. Any injury at work should be reported to the supervisor immediately. True 

3. No matter how big or small the injury; the injured person should receive medical attention. True 

4. While working with machines and equipment, employees must follow the safety guidelines 

set by the company. True 

5. Bright light sources behind the display screen can create contrast problems.  True 

6. Exposure to bright lights and toxic fumes and vapour could damage the mouth and ears. False 

7. The use of personal protective clothing and equipment can control the hazards at workplace. True 

8. Do not throw rubbish daily.         True 

9. Proper handling of office equipment can result in injuries.   False 

10. Stress   at   workplace   can   cause   hazard   in   today’s organization. True 

 

D. Short answer questions 

1. Briefly explain the concept of health, safety and security at workplace. 

Ans. Health:  Health of an employee is the state of the physical, mental and social well-being. 

Every organization must provide health and safety working environment for their employees at 



the workplace. Health of an employee must be in a good condition so that the employees of the 

organization will not suffer from any disease. 

a) Cleanliness at the workplace is mandatory. 

b) A proper air conditioning is mandatory to provide cool air at workplace. 

c) A properly filtered water facility must be available for the employees of the company. 

d) A fresh food cafeteria must provide the good quality food for the employees. 

e) The organization should maintain a clean washroom facility in good condition to be used by 

the employees. 

Safety: The work environment of the organization must be safe. It must be free from hazards 

and risk. A hazard is the something that can cause harm to the people. A risk is a probability of 

causing harm to the people.  A proper safety guideline must be prepared by the company and it 

should be strictly followed. At regular intervals of time, the safety procedures must be practiced 

by employees. 

 

Security: Every employee working in an organization must feel that they are secured in the 

company campus. Security ensures the safety of the people working in the organization. Every 

organization must have separate security department. This department should be responsible 

for various security such as personal safety, computer system safety, electrical safety, transport 

safety and other equipment safety.  
 

2. State the most important reasons for health, safety and security programs in 

workplace. 

Ans: - Reasons for health, safety and security programs or policies in workplace are: 

a) It clearly indicates the company’s commitment for their employee’s health and safety.  

b) It shows the performance of the business and the safety performance are compatible with each other. 

c) It clearly states that the company is not only doing the business for profits but it is taking care 

of all its stake holders. 

d) Injuries and illness of the employees is prevented through such policy 

 

3. List out the various workplace safety hazards. 

Ans: - Various workplace safety hazards are: 

a) Chemical hazards  b) Health hazards   c) Fire hazards   

d) Physical hazards   e) Electrical hazards 

 



4. List out the potential sources of hazards in an organization. 

Ans: a) Hazards using computers b) Handling office equipment 

c) Handling objects    d) Stress at work 

 

5. List some of the IT Workplace hazards. 

Ans: IT workplaces present unique challenges to employee health and well-being. Here are some 

of the key IT workplace hazards: 

a) Eye strain and headache b) Musculoskeletal Disorders    c) Repetitive Strain Injuries 

d) Stress and Anxiety  e) Sleep Disruption   f) Social Isolation 

g) Environmental Hazards h) Poor Indoor Air Quality i) Improper Lighting 

 

6. What are the examples of potential hazards? 

Ans: a) Bright light sources behind the display screen can create contrast problems, making it 

difficult to clearly see your work. 

b) Hazards while using computers include poor sitting postures or excessive duration of sitting 

in one position. 

c) Improper handling of office equipment can result in injuries. 

d) Lifting or moving heavy items with out proper procedure or techniques can be source of 

potential hazard. 

e) Potential hazards at workplace area may include poor ventilation, chairs tables of 

inappropriate height, hard furniture, poor lighting, staff unaware of emergency procedures, or 

poor housekeeping. 

 

7. Describe information technology workplace hazards.  

Ans: IT workplaces present unique challenges to employee health and well-being. Here are some 

of the key IT workplace hazards: 

Physical Hazards: 

a) Eye Strain: Staring at computer screens for extended periods can lead to eye strain, headaches, 

and blurred vision. 

b) Musculoskeletal Disorders: Poor posture, repetitive motions like typing and awkward 

working positions cause neck pain, back pain, carpal tunnel syndrome and other MSDs. 



c) Repetitive Strain Injuries: Similar to MSD it often focused on specific area like wrists and hand 

repetitive movements.  

Work Organization Hazards: 

a) Stress and Anxiety: IT Professionals often face tight deadlines, demanding workloads, and the 

pressure to stay up to date with technology. This can lead to chronic stress and anxiety. 

b) Sleep Disruption: IT work can sometimes involve irregular hours or on-call duties, disrupting 

sleep patterns and impacting overall health. 

Environmental Hazards: 

a) Poor indoor Air Quality: Stale air in office environments can contribute to headaches, fatigue, 

and respiratory problems. 

b) Improper Lighting: Dim or flickering office lights can cause eye strain and headaches. 

 

8. What are the workplace safety rules? 

Ans: Basic safety rules to follow at workplace- Fire safety, falls and slips, Electrical safety, use of 

First aid. 

Basic Fire safety rules in an organization are: 

a) Fire escape plan must be installed at proper levels 

b) Smoke alarms must be placed at proper intervals 

c) Keep workplace a no-smoking zone. 

Fall and slips Safety rules: 

a) Keep the moving area clean and clutter free. 

b) Workplace must be proper ventilated receive light. 

c) Wear non slippery footwear. 

d) Floors must be clean and dry. 

Electrical safety rules: 

a) Electrical equipment used should be approved by a recognized organization. 

b) Workers should be trained to handle the electric equipment safely. 

c) Damaged and hazardous electrical equipment should be immediately replaced. 

d) Take care that the outlets/ circuits should not be overloaded. 

e) Switch off and unplug the electrical appliances before cleaning or relocating them. 

 



Use of First Aids: 

a) Assure the injured to remain calm and not to panic. 

b) Keep them warm if they are under shock. 

c) Do not move the victim in case of back/neck injury. 

 

9. List out different safety guidelines. 

Ans: 1.  Store all cleaning chemicals in tightly closed containers in separate cupboards. 

2.  Throw garbage daily. 

3.  Make sure all areas have proper lighting. 

4.  Do not wear loose clothing or jewellery when working with machines.  

5.  Never distract the attention of people who are working near a fire or with some machinery, 

tools or equipment. 

6.  Where required, wear protective items, such as goggles, safety glasses, masks, gloves, and hair nets. 

7.  Shut down all machines before leaving for the workplace. 

8.  Do not play with electrical controls or switches. 

9.  Do not operate machines or equipment until you have been properly trained and allowed to 

do so by your supervisor. 

10. Repair torn wires or broken plugs before using any electrical equipment. 

11. Do not use equipment if it smokes, sparks or looks unsafe. 

12. Cover all food with a lid, plastic wrap or aluminium foil. 

13. Do not smoke in ‘No Smoking’ areas. 

14. Report any unsafe condition or acts to your supervisor. 

 

10. Describe type of emergency with example. 

Ans: Some of the types of emergencies are as follows: 

a) Chemical spills   b) Extreme heat waves   c) Droughts 

d) Pandemics   e) Terrorist attack    f) Fire 

g) Floods    h) Thunderstorms 

i) Leakage of some hazardous gas/chemical 

 



Chapter 14. Workplace Quality Measures 

A. Multiple choice questions  

1. To provide healthy and safety working environment, every organization must have _________. 

(a) Cleanliness  (b) Filtered water   (c) Clean wash-room  (d) All of the above 

2. Air pollution is mostly caused by production of the ________in the surrounding air.  

(a) dust   (b) mixture of solid particles  (c) gases  (d) All of above 

3. Repetitive use of muscle may feel pain in your ___________. 

(a) neck   (b) shoulder   (c) wrist or fingers   (d) All of the above 

4. The security department organization is not responsible for __________________. 

(a) other safety  (b) computer system safety  (c) electrical safety    (d) transport safety 

(e) All of the above 

5. For an organization, the proper security procedures will reduce ________________. 

(a) liabilities  (b) insurance  (c) business revenue  

(d) operational charges of the company 

6. Do not wear ________ when working with machines.  

(a) jewellery  (b) safety glasses (c) masks  (d) gloves 

7. Sore lower back is caused due to _________________. 

(a) reaching forward frequently    (b) no lumbar support  

(c) no upper back support from chair   (d) reaching forward for long periods 

8. What should you do with the problem of dry eyes? 

(a) Forget to blink   (b) Do exercise   (c) Blink the eyes 

(d) Rest eyes periodically and do simple eye exercises  

9. If light is coming directly behind or in front of you then you may suffer from _________________. 

(a) eye strain (b) sore eyes  (c) dry eyes   (d) eye strain and sore eyes 

 

B.  Fill in the blanks  

1. Air and water pollution can be analyzed by using – physical, chemical and biological analysis.  

2. The PH value of the water can be measured through chemical analysis. 

3. The microbial indicators are used to monitor the health of the ecosystem. 



4. Ergonomics is the science concerned with designing and arranging things.  

5. Working with wrists extended too much repetition can cause arching wrists. 

6. The repetition of a seemingly innocuous task over a period of time can cause an injury. 

7. If a cord or wire will cross a pathway safety it should be mark it with hazard tape. 

8. Loose cords and wires can cause electrical hazards. 

9. Glare and reflections on the screen should be prevented.  

10. The keyboard should have a matt surface to avoid reflective glare. 

 

C.  State whether the following statements are True or False 

1. The work environment of the organization must be free from hazards and risk. True 

2. Practice a no vehicle day in every week to avoid air pollution.     True 

3. Applying     ergonomics     can     improve     performance and productivity.  True 

4. Wear rings, watches and necklaces while working on the computer.   False 

5. Never touch or try repairing any electrical equipment or circuits with wet hands.  True 

6. Unplug all power sources and cables from computer while working on computer.  False 

7. Occupational overuse syndrome, also known as repetition strain injury.  True  

8. The work chair must be stable and allow the user to move easily.   True  

9. Artificial lighting from computer screens can cause sleeping problems.  True  

10. The keyboard and mouse should not be kept at the same level.   False 

 

D.  Short answer type questions 

1. What causes the water pollution? 

Ans: Causes of Water Pollution: 

a) Industrial waste: Industries release a variety of pollutants into waterways, including 

chemicals, metals, and organic matter. 

b) Agricultural runoff: Fertilizers, pesticides, and herbicides used in agriculture can contaminate 

water sources which are washed away by rain. 

c) Sewage and wastewater: Untreated sewage can introduce harmful bacteria and viruses into 

water. 

d) Oil spills: Oil spills can have a devastating impact on marine life and ecosystems. 



e) Plastic pollution: Plastic pollution is a growing problem that is harming aquatic life and 

ecosystems. 

 

2. What is occupational overuse syndrome? 

Ans: Occupational overuse syndrome, also known as repetition strain injury, is a collective term 

for a range of conditions, characterised by discomfort or persistent pain in muscles, tendons and 

other soft tissues, with or without physical manifestations. It is usually caused or aggravated by 

work, and is associated with repetitive movement, sustained or constrained postures and/or 

forceful movements. 

 

3. What are musculoskeletal problems? 

Ans: This problem includes different areas of your body, such as neck, back, chests, arms 

shoulders and feet. It occurs because of your wrong posture, uncomfortable chair for sitting that 

is not ergonomically correct while working on the computer. 

 

4. What cautions to be taken while working on the computer? 

Ans: Various cautions to be taken while working on the computer are:  

a) Use Serge protector: The static electricity generated just by walking on the carpet can 

damage the computer component. So, use a surge protector when your plug your system in. 

b) Use a Battery backup system: It is the best way to protect against a power outage, at it 

provides the system with constant voltage. 

c) Remove ornaments while working: Remove rings, watches and necklaces while working on 

the computer. These ornaments are often made of conductive metals which can damage 

computer components by striking them static electricity. 

d) Unplug Cables: Unplug all power sources and cables from computer. If you are working with 

plugged in computer then it might damage your hardware. Modern processors will overheat 

within 7 seconds if heat sink is not attached. 

 

5. Why there is no right way to use a laptop? 

Ans: In laptop the screen and keyboard are very close together and there is really no right way 

to use a laptop because if you position the screen at the right height for your back and neck, it 

will cause you to have to lift your arms and shoulders too high to use it and vice versa. It will 

probably cause a problem. 

 



6. What causes eye strain and how to avoid it? 

Ans: Cause of Eye strain: 

a) Computer bright light. 

b) Glare and Flickering images. 

c) Constant focusing on screen without blinking. 

d) Poor lighting. 

Avoid eye strain by using following methods: 

a) Adjust the brightness of computer screen. 

b) Reposition the screen to avoid glare from lights or windows. 

c) Keep a proper vision distance from computer screen and blink your eyes in an interval. 

d) Wear anti-glare glasses while working in computer. 

e) Give your eyes periodic breaks form the screen. 

f) Performs frequent blinking. 

g) Look away form the screen into the distance form moments to relax your eyes. 

h) Keep your monitor between 18 to 24 inches ways form your face. 

 

7. What   type   of   display   screen   is   suitable   to   work on computer? 

Ans: a) Use the modern LED monitors of legible size and with adequate spacing between the 

characters and lines. 

b) The image on the screen should be stable, with no flickering or other forms of instability. 

c) The screen must be free of reflective glare and reflection liable to cause discomfort to the user. 

 

8. What type of keyboard is suitable to work on computer? 

Ans: a) The keyboard should be tilt and separate from the screen to find a comfortable working 

position and avoid fatigue in the arms or hands. 

b) The space in front of the keyboard must be sufficient to provide support for the hands and 

arms of the user. 

c) The keyboard should have a matt surface to avoid reflective glare. 

d) The symbols on the keys must be adequately contractable legible form the design working 

position. 



Chapter 15. Prevent Accidents and Emergencies 

A. Multiple choice questions 

1. What  are  the  steps  necessary  for  operating  a  fire extinguisher?  

(a) Identify the safety pin of the fire extinguisher which is generally present in its handle  

(b) Break the seal and pull the safety pin from the handle 

(c) Use the fire extinguisher by squeezing the lever  

(d) All of the above 

2. Which of the following is an examples of ignition sources of open flames?  

(a) Gas ovens  (b) Lighters in smoking areas  (c) Welding torches     (d) All of the above 

3. In fire classification, all liquid, grease, and gas material comes under __________________. 

(a) Class A material  (b) Class B material  (c) Class C material     (d) Class A material 

4. In fire classification, material magnesium, potassium, and sodium comes under _______________. 

(a) Class A material  (b) Class B material  (c) Class C material     (d) Class D material  

5. In  fire  classification,  material  wood,  cloth,  and  paper comes under ________________. 

(a) Class A material  (b) Class B material  (c) Class C material     (d) Class D material  

6. In fire classification, electrical material and equipment comes under ____________________.  

(a) Class A material  (b) Class B material  (c) Class C material     (d) Class D material 

7. When do we use a fire extinguisher?  

(a) In case of flood   (b) In case of electric shock  (c) In case of fire  (d) In case of burn injury  

8. What is the primary fire emergency telephone number is?  

(a) 011    (b) 101    (c) 108   (d) 111 

9. Which of the following contains everything you need to know about evacuating your facility safely?  

(a) Evacuation Diagram   (b) Emergency Action Plan   (c) Employee Directory    (d) Both (a) & (b) 

10. The best course of action to take during a medical emergency is to ________________. 

(a) Begin first aid immediately   (b) Activate the emergency plan for reporting injuries  

(c) Notify the person's family about the situation  (d) Both (a) and (b) 

 

 



B.  Fill in the blanks  

1. Emergency   is   a   serious   or   crisis   situation   that needs Immediate attention and action. 

2. A wet floor sign will warn people to walk carefully on freshly mopped floors. 

3. Watch your steps signs can prevent accidents on a staircase with a sharp bent or warn against 

a loose floor tile. 

4. The coordinator should be responsible to handle evacuation process.  

5. Workplace fires are commonly caused by improper storage of flammable material or 

combustible dust.  

6. There should always be an emergency response plan for scheduled electrical maintenance or 

work. 

7. If the victim is breathing and has a heartbeat, give first aid for injuries and treat for shock. 

8. A fire extinguisher is a cylindrical pressure vessel containing an agent which can be 

discharged to extinguish a fire. 

 

C.  State whether the following statements are True or False 

1. The organization’s policies and guidelines is the best guide to handle emergency.  True 

2. If someone is injured, act as per your impulse or gut feeling.     False 

3. Keep water and food items away from electrical equipment.     True 

4. Always switch off the electrical circuits.        False 

5. Always wear protective equipment, such as gloves and shoes.     False  

6. A fire extinguisher is a protection device used to extinguish fires.   True 

7. Flammable materials can be placed around a door exit.     False 

8. You can determine possible evacuation routes from floor plan diagrams posted in your facility. True 

 

D.  Short answer questions 

1. What is a workplace emergency? 

Ans: A workplace emergency is any sudden, unexpected event that threatens people or the work 

environment. These can be fires, medical emergencies, natural disasters, or security threats. 

They disrupt operations and require immediate action. 

 



2. How do you protect yourself, your employees, and your business? 

Ans: The best way to protect yourself and your organization is to develop a well-thought-out 

emergency action plan to guide the employees in the event of an emergency. 

 

3. What is an emergency action plan? 

Ans: An emergency action plan (EAP) is a written document that outlines how to respond to 

various emergencies in a specific location. This plan is typically required by law in workplaces, 

but it’s also a good idea to have one at home, school, or any place where people gather. The main 

purpose of an emergency action plan is to keep everyone safe in an emergency situation. By 

having a plan in place and knowing what to do, people can avoid confusion, injury, and property 

damage. 

 

4. What should your emergency action plan include? 

Ans: A well-crafted emergency action plan guides employees during emergencies. Here’s what 

to include: 

a) Identify: Workplace hazards and plan for likely threats. 

b) Evacuation: Define clear routes, exits and assembly points. 

c) Communication: Establish how emergencies are announced and who communicates 

with responders. 

d) Procedures: Outline actions for different emergencies (E.g. Fire extinguisher use, first aid) 

e) Training: Train employees on the EAP and conduct emergency drills. 

f) Maintain the Plan: Regularly review, update and conduct the EAP. 

 

5. How do you develop an evacuation policy and procedures? 

Ans: Evacuation is the process of emptying a place in case of an emergency, disaster.  

Every organization must have an evacuation policy. All the Team Leaders are responsible for 

informing about the policy to their employees about it. Proper attention must be paid when the 

Team Leader is informing you about these details.  

Organization must have a designated assembly point for emergencies. Ensure that every 

employee/worker must know where it is. 

 

 



6. How do you establish evacuation routes and exits? 

Ans: a) Leave the premises immediately and start moving towards the nearest emergency exit. 

b) Guide your customers to the emergency exits. 

c) If possible, assist the person with disability to move towards the emergency exit. 

d) You may carry your hand-held belongings, as you move towards the emergency exit. 

e) You can determine possible evacuation routes from floor plan diagrams posted in your facility 

f) Employees should be aware of all emergency exits, including fire escape routes, of the office 

building and also the locations of fire extinguishers and alarms. 

 

7. What are the various types of fire extinguisher and their extinguishing material? 

Ans: Types of Fire Extinguisher: 

a) Water CO2   b) Dry chemical powder   c) Carbon dioxide  

d) Mechanical foam  e) ABC dry powder 

Select the suitable type of fire extinguisher 

 Water CO2 Dry Chemical 
Powder 

Carbon 
Dioxide 

Mechanical 
Foam 

ABC Dry 
Powder 

Class A Suitable Not Suitable Not Suitable Suitable Suitable 
Class B Not Suitable Suitable Suitable Suitable Suitable 
Class C Not Suitable Suitable Suitable Not Suitable Not Suitable 
Class D Not Suitable Suitable Not Suitable Not Suitable Suitable 

 

 

8. What are the steps for operating a fire extinguisher in case of a fire emergency. 

Ans: Step 1: Identify the safety pin of the fire extinguisher, present in its handle. 

Step 2: Break the seal and pull the safety pin form the handle. 

Step 3: Use the fire extinguisher by squeezing the lever. 

Step 4. Sweep it from side to side. 

 

 

 

 

 



9. Compare the different type of fire extinguisher. 

Ans: 

 

 

10. List the different class of fire. 

Ans: Different class of fire: 

a) Class A (Solid Materials): materials such as wood, cloth, and paper, which won’t ignite on 

their own but will continue to burn once exposed to a heat source. 

b) Class B (Flammable liquid):  all liquid, grease, and has materials that burn when exposed to 

ignition sources. 

c) Class C (Gases): electrical materials and equipment. These materials cause fires very quickly 

and present a serious rick of arc flash. 

d) Class D (Metals): any materials that are volatile and able to quickly ignite, such as 

magnesium, potassium, and sodium. 

e) Electrical: Because electrical fires can easily fall within many of the other classes, they don’t 

really get their own full class. But electrical fires usually refer to wiring and equipment such as 

computers, televisions, and routers. 



f) Class F (Cooking fats and oils) – This is fairly self-explanatory and relates to things like 

chip pan fires. 
 

11. List out electrical rescue techniques. 

Ans: Approaching the accident 

a) Never rush into an accident situation. 

b) Call 108 or emergency number as soon as possible. 

c) Approach the accident place cautiously. 

Examining the scene 

a) Visually examine victims to determine if they are in with energized conductors. 

b) Do not touch the victim or conductive surfaces while they are energized. 

c) Switch off the electrical circuits if possible. 

Hazards and solutions 

a) Be alert for hazards, such as heated surface and fire. 

b) In case you cannot switch off the power source, take extreme care. 

c) Ensure that your hands and feet and dry. 

d) Wear protective equipment, such as gloves and shoes.  

e) Use non-conductive material to remove a victim from the conductor. 

High voltage rescue 

a) Special training is required for rescues if high voltage is present. 

b) Protective equipment, such as gloves and shoes must be worn. 

 

12. What is the first aid for electrical emergencies? 

Ans: A Victim may require Cardio-Pulmonary Resuscitation (CPR).  

a) If the victim is breathing and has heartbeat, give first aid for injuries and treat for shock. 

b) Ensure the victim gets medical care as soon as possible. 

c) Physician attending the victim must have detailed information to properly diagnose and care 

for the victim. 
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